FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

I’m a bit edgy on downloading a file from a cloud storage without details on where it originally comes from. Plus. I cannot access the link…

Well, seeing as @jftr is the person putting together this update and you’ve trusted them this far…
Also, looking at the link there’s probably a typo there. This should work:
https://s3.eu-central-1.amazonaws.com/gakitkat/gapps-1.9.9.zip

2 Likes

Why not try opengapps? It works fine…

Yes, sorry for the typo. I’ve corrected it now.

@DonatCallens, have you ever checked where the Google Apps package in previous OS versions came from? :wink:

I’m not a legal person and won’t try to understand any of the legal implications. However, there is also a technical reason: OpenGApps does not work with the recovery we ship.

Oh, ok, I didn’t know that Shazam needed Google Services too.

No I didn’t, I installed them like the others (via the Play Store).

That’s right, it happens in the settings (and also some notifications).

Sorry I don’t (haven’t understood how to do that :’-( ). The problem appeared again the next day, but hasn’t appeared since.

I used to have “Wi-Fi” directly in the app list (had a direct button on the home screen). Now I have to go to Settings / Wireless & Networks / Wi-Fi.

I respect that! :smiley:

This is strange indeed. Sorry, I have no clue why this happened.

How to create a bugreport is explained in the original post of this thread. It would be great if you could pull it off to help us fix this issue.

Do you know that you can pull down the notification drawer and access quick settings such as turning on and off Wifi? If your prefer to have a shortcut to Wifi on your home screen, you can also add it as a widget: Go to the launcher (e.g. by pressing the Home key), press the menu key or long press on an empty area of the home screen, then press Widgets and search for “Settings shortcut”. Drag this item to your home screen and select what setting you want to display. Done :smiley:

Can you give me more details? What operators are you on, etc? Do you know MCC and MNC of your operator?

Hello everyone,

The alpha testing has been running for a few weeks already. Thanks to all of your continued efforts we are able to significantly improve the upcoming release.

For transparency’s sake, I’d like to give you an update on where we stand and what our future plans are.

So far you’ve helped us uncover many issues. This is great because we want to iron out those issues before we release to all FP1 users. On the other hand this also means that there is more work to do than we had anticipated which endangers our release plan.

Initially we had announced that we are trying to release in September. To be honest, we had already given ourselves some margin because the real plan was to release in summer ;-). Unfortunately this has not worked out. Of course, September is still a while away but due to the summer holiday, many team members are out of the office, including me (the main developer) who will be on holiday most of August.

We just wanted to give you a heads-up of what to expect. So please don’t be surprised if I will be less responsive on the forum and via email.

Our current to-do list includes:

  • fixing known issues
  • upgrading to 4.4.4
  • applying security updates

These items need to be tackled in September. Our hopes are that we can still release in September and we will put all our efforts into achieving this goal.

See you around,
Franz

9 Likes

Thanks for the heads up, @jftr
Enjoy your holidays!

1 Like

Thanks for the update. This is really good to know.
Enjoy your vacation!

1 Like

Not a bug, just a feature. In the option “settings > device > display > sleep” the maximum is 30 mins. Since there are apps that close when the phone sleeps (and e.g. lose gps signal) it would be great to have an option like “never sleep” added.

I also would love to see the restart/reboot option again.

Some apps that need the screen to stay on have an option to prevent the phone from going to sleep. That’s probably the better way of implementing this.

Since some apps don’t have this option, it might be a nice-to-have. but i understand that it is lowest priority.

After a “Clear Data” the problem does not exist anymore (FYI, I received a “Information on mobile fees in Germany” each time I booted. I did not travel Germany in July though… It’s gone anyways now.)

The GPS issue persists though. In the location menu it shows “battery saving mode”, but in the battery usage menu, GPS shows as on.

Have you tracked down the issue or do you need more information? If yes, should I try logging the error?

Edit: I posted a bug report here:

https://forum.fairphone.com/t/gps-shows-as-on-in-battery-stats-after-turning-it-off/20564?source_topic_id=19450
1 Like

I have a FP1U (storage upgrade included) and this is my first upgrade. So I came from 1.5 Chenpi. I had no problems with updating. Just a little confusing that I had to download the zip, restart and only then the Updater offered me to upgrade. Maybe the Updater upgraded itself, maybe that was entirely my fault. I didn’t do any wipe data or anything. The computation seems a bit slower, but data access seems faster so it’s a draw.
I can confirm that the battery drops to 15% from time to time. I have not tried to install Playstore meaning I’m quite happy as is.

One reason why I upgraded was to play Pokemon but I didn’t get GPS to work. With Satstat I get a good GPS connection. I guess Pokemon needs Google …

It needs microg at least. :wink: You should read this thread:

2 Likes

Bluetooth really doesn’t work well… one time out of two it doesn’t find any devices and synchronization doesn’t work either… :confused:

Are we still testing this? any news about the next step?

Hello all,
I know I’m quite late on this testing but I just wanted to share my experiece.
I have been trying to update a FP1 without success.
I followed all the info in the forum, I ensured the memory partition issue, tried from adb push and I even tried to downgrade to 1.6 and make all the steps to the upgrade, but never get the Macadamia 1.9.
Always the Fairphone updater asks for a restart, then it seems to upgrade, but after that nothing changes.

The former user of the FP1 claimed that did never succeed to upgrade to Koala Nut 1.8.7 (it was 1.8 when I got it). For me worked with no issue.

I am just wondering if the bugreport.txt would help

Maybe I can try with my FP1U, but I’m currently using it so that is why I asked for FP1 to a friend.

Regards and salut!

Many many thanks!!!

I’m very patient because apart from minor things (bluetooth & battery life) this phone works great!!! (I left the FP2 sleeping in a drawer… )

1 Like