[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

Here is the call for beta testers of the official Kitkat port:

I’ve been using your build from the first version and admire your skills and your support to the community. A BIG thank you. You might have saved me from buying another phone. Wish you well, may good karma stay with you, may many people copy your attitude and contribute to the community. Thank you for the modest good bye - farewell

1 Like

Thanks and all the best as well! It was really helpful for me, else I would have bought a Nexus in the meantime. If you think about it, do you think from your experiences that Google will continue to support 4.4.4 after 2016? Thanks once again for all your unpretentious given builds and time!


We want to thank you @chrmhoffmann for all your work and we do so with a dedicated thread:


Hey guys,

there is still some time till the official release of KK 4.4.4 from fairphone.
I’m struggling with my fp1 kk 4.4.4 fp1-kk444-CH-0.9.7 without google playstore but with xposed and f-droid. I´ve tried to use pokemon go (0.29.2). Without google I used an pokemon club account to get access. My problem is die GPS-connection. My gps works perfectly with sygic (navigation) or gps-status, but pokemon says it cannot find a gps signal.
I tried:
-.apk 0.29.0 and 0.29.2
-several reboots
-clearing the cache
-gpsfix (sygic etc. works fine, but not pokemon)
-µGs from f-droid and xposed (but I don’t really now what I really did, it didn’t work out)
-fakelocation out of xposed to get at least one position in the game (no, didn’t work)
-deleted all gps-supporting apps (gps-status, µGs, etc.)

I’m wondering if it has something to do with the missing playstore and if yes, how can I solve the problem without installing it.

thanks for helping

PS. I did not want to open a new topic, because of my special setup, if the moderation team does not agree with my decision, then they are welcome to move it somewhere else.;-]

Can you tell us what permissions the game needs? Maybe you will need micoG or something like that to make Google happy?

this are the permissions. when I install the app, the OS is asking if I want to let pokemon go use my current position. I always agreed and said don’t ask me again.

I don’t know if this is of any help, but I’m successfully running Ingress (which is quite similar) with microG.

First thanks both of you.

But what does microG or Ingress?

Anyway I will give it a try and will report.

Okay I see, Ingress is a game.
So which versions of microG are you using and where did you get them (xposed, browser, f-droid?)
On F-drid I can find µG (GApps); µG (no GApps); and µG (no GApps, legacy).

Ingress is a game from the same vendor as Pokémon Go. And it’s really mostly the same (but without Pokémon).

I’ve installed microG from their F-Droid repository.

I think I’m running microG successfully, but it still doesn’t work.

I tried to use Ingress to check if it is a problem with my settings, but when I’m starting it I have to use an account (I think google), but you see in the screenshots that I cannot choose it.

So I still think I have a problem with my setup.

@YtvwlD You are using chishoffmanns KK 4.4.4 without google play store? Could you please explain your setup a bit more detailed to me.

Thank you,


Well, I did the same things as you.
Then I installed the blank store and configured it (not sure if that’s relevant).
And I added my Google account.

Hey @YtvwlD, I think the blankstore was decidend. I have problems to get it running. I downloaded it microG XDA and followed the instruction more or less here. When I’m starting blankstore I register with my mail address and password but I have no clue what to do with my android ID. I tried a few times this on windows but I got an error message and I cannot get it running on linux, I have problems with java on linux.

I also tried this, but it didn’t solve the problem.

Hello & thank you @chrmhoffmann!

I’ve been happily running your 4.4.4 for six months. Almost everything worked super well. The phone felt snappier first (but that could be because of wipe data). Got to install some new kitkat-only apps, like Google Camera w/ photo sphere!

Slight glitches observed:

  • Battery status stuck at 14% again.
  • Often telephony hangs if there’s 2+ consecutive phone calls & needs reboot.
  • Sometimes wifi stops working. Sometimes mobile data stops working. Sometimes all works fine for over a week.
  • Facebook Messenger: about 1/20 messages are missing the last word, as the text does not fit into its allocated bubble.
  • Snapchat: encodes glitched video. Preview is ok, but sent videos have color plane displacement glitch and band of noise on the side, saved videos are completely black with band of noise on the side. Instagam, which also re-encodes video, works fine.

Two days ago I switched to Fairphone’s 4.4.2, and it seems to be working almost identically to chrmhoffmann’s. It has the same glitches (as above) with few extra, including different battery status inconsistency.

In the end, I’d say the unofficial 4.4 worked better than official 4.2! Let’s see how the official 4.4 fares : )

Best future adventures :koala:


I’ve simply done this to create my Android ID - and it worked. But this was some time ago.

This topic was automatically closed after 55 days. New replies are no longer allowed.