FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

Are you sure the download isn’t corrupted?

The md5sum is correct, so not sure if there’s any other way for it to be corrupt?

No, then it’s probably correct. One (hopefully last) question: You say, everything is stock. Does that mean stock FP1 or stock FP1U? (i.e. do you have the unified partition layout? If not, you need to follow these instructions on upgrading to the unified partition layout first.

Yea, I have a FP1 without the storage upgrade, will fix that and let you know what happens!

Update: Allright, everything worked perfectly after installing the storage upgrade, thanks!

1 Like

I updated from XDA’s 4.4 and installed Gapps Nano. The only problem I ran into was Android Keyboard crashing all the time (solved by deactivating it, including as a spell checker, and using another keyboard). I noticed some other people were complaining about the battery draining suddenly after a given threshold. I also had (and still have) this problem with Chris’ 4.4 build, where the battery reaches ~50% and quickly drops to red.

@jftr (or other official people): Are the kernel sources for this version already available for download?

We didn’t release them yet. However, they might be available from other sources. This is something we should look into.

When opening the downloaded FP1-Fairphone_OS-1.9.9-pre1-ota.zip file in the installer, the installer asks me to “Restart your phone to complete the update.”. When clicking on “restart”, I see a toast saying “File not found: /cache/fp_update_999.zip”

Apparently, this error happened to other users too: New software update Kola Nut 1.8.5 is ready

I’ve tried cleaning the Fairphone Updater App’s data, but this hasn’t helped. Any ideas?

Problem solved: When you open a file from the “Downloads” app, it creates the following intent:

{act=android.intent.action.VIEW dat=content://downloads/all_downloads/11164 typ=application/zip flg=0x13000001 cmp=com.fairphone.updater/.FairphoneUpdater}

Note that the path is not a valid file path. It would be great if the Updater handled this, and resolved content://downloads links to the right path.

1 Like

Eduroam works, but I also had to “Forget” the network and re-enter the password.

1 Like

I installed the update yesterday and had at first some problems with unpacking the dowloaded .zip. I can’t remember how I’ve done it but afterwards the update installed without any problems.
Now it runs good but with some problems.
As alread mentioned by others the google installer doesn’t work.
And the GPS signal doesn’t work. I tried some diffrent apps but none can find my location. Has anyone else this probelem?

I also installed the update successfully two days ago (coming from the last official version) and got the GApps working with CWM recovery and OpenGApps pico. So far everything seems to work rather well, no problems with GPS - even Pokémon Go is running fine.
Will report back if anything comes up. :slight_smile:

1 Like

GPS is always turning on when I have data connection on mobile network. I’m using the very same apps I has on a previous installation (no weather , so I suspect the issue is the OS. It even reverts from Battery Saving Mode to GPS location. Any suggestion?

I’ve even already uninstalled Google Play services, which was the only app requesting my location.

Thank you for your answer! It’s good to know that there’s a way to fix my problem:) but I’m not sure if I will try the CWM recovery and opengapps solution yet, cause I’ m not used to that stuff so I don’t feel safe doing this without reading more about it

Can you please describe this in a bit more detail? I want to make sure I understand the problem correctly and can follow your steps. Especially, how do you see that location is turned on on data connection and that it reverts from battery saving to GPS location.

Had you installed OpenGApps? How did you uninstall it again? Did you only remove Google Play Services or all Google Apps? (the latter heavily rely on the former and you probably mess up your system if you remove Google Play Services alone).

I hope a suitable Google Apps package will be released early next week.


Say I’m connected to Wifi, as soon as I’m far from it and it disconnects (or I deactivate it) and the phone changes to mobile data, the Location icon lights up. Every single time the phone relies on mobile data the gps turns on.

If I then go to location settings, the mode is set to Devices, when I had deliberately set it to Battery Saving beforehand.

Under Recent Location Requests the only thing is always there is Google Play Services and sometimes Store. So I uninstalled Services using 3C Toolbox but the same thing kept happening, but now there was no app under Requests. (I’ve since reinstalled it)

I remember the same thing happening on 4.2 as well, but not (by far) as consistently as now.

1 Like

Reminds me of this (unresolved) ancient topic (just mentioning in case there’s something relevant there):

I´ve tried to create a bug report with adb but it didn´t work. I can´t find it anywhere. I´ve an MTK Logger Report, which i could send to you.

Just quick feedback after using Kitkat for half a week. Overall the system seems to work really well. I’ve used sound, location, sensors, wifi.

The issues I’ve come across:

  • The updater does not work when opened from the Downloads app. In this case the intent does not contain a file path, and the updater fails with a very strange, unrelated error message.
  • Several Google apps crashed after installing OpenGApps. Re-installing them helped.
  • After installing OpenGApps nano, the AOSP keyboard that I was using kept crashing. Installing the Google keyboard fails, claiming that the package is not signed properly. Installing Swiftkey works; this is what I’m currently using.
    This problem was surprisingly tricky to solve. After all, how do you install another keyboard if that requires you to log in to Google, and that requires you to type your password, and typing your password is not possible because your keyboard keeps crashing :slight_smile: ?

I’ll also give a quick update on things I’ve noticed, I installed Macadamia at the start of this week (upgraded from Koala Nut):

  • Keyboard: Had the same issue with Google keyboard not working after installing Open GApps.
  • GPS: Not working properly. Regularly unconnects. As in I tried using navigation and every other minute I get the status it’s searching for GPS again. It’s fairly reliable in that it will connect again in a few seconds, but it’s so consistent that it’s kind of weird.
  • Language: When I select German system language, the entire settings menu remains English, the rest of the phone changes language as far as I can see.
  • Power Menu: Not a bug, but I’m actually missing the “reboot” button in the quick menu from holding down the power button, it was handy.
  • Wi-Fi hotspot: No issues, just wanted to say I used it and had no troubles.
  • Sensors: Again no issues, using the app “Sensor Kinetics” all built-in sensors seem to work perfectly.