FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

eduroam is no problem here. (Other wpa2 enterprise secured networks work as well.)

Also my device is encrypted (only internal storage not SDcard) and just works. Battery usage was not different to the unofficial built thus far.

1 Like


I’ve updated my FP1 to the Android 4.4.
But I’m not able to run Google apps anymore.
Playstore is stopped.
I tried differents tricks llisted here.
If someone has any idea ?


Try to install OpenGapps while waiting that the Gapps problem is solved…

You can find everything you need here OpenGapps project

eduroam works perfect for me

Sorry, after removing the old settings and reentering them it does seem to work. Seems the upgrade might have messed the settings up somehow.


Can anyone please give me detailed instructions, how to install opengapps?

One method:

  1. Download on your FP an open gapps package on http://opengapps.org/. Usually the nano package is a good option (ARM/Android 4.4/nano). This gives you a .zip file on your phone.
  2. Boot in recovery mode() and choose “Install from zip” to install the open gapps zip file from your phone
    ) to get it you have to push simultaneously the buttons volume up AND power for about 10s. Be careful though if you never did this kind of operation…

Thanks four your reply

In recovery mode I have the options.

  • reboot system now
  • apply update from adb
  • apply update from sdcard
  • apply update from cache
  • wipe data/factory reset
  • wipe cache partition
  • backup user data
  • restore user data

I have already tried “apply update from sdcard” and choose the opengapps.zip, but it abadons after some seconds
I have also tried to wipe the cache partition before

Could it cause problems, that I have uninstalled the Google Play Services?

a.t.m. I try to get another recovery tool. I have downloaded the “recovery.img” (I think it is CWM Recovery) here: http://forum.xda-developers.com/fairphone/orig-development/rom-fairphone-fp1-kitkat-4-4-2-t3243623
but I dont know what to do whith it

“Apply from sdcard” is the right option. Are you sure you choose the right options for open gapps: Platform ARM, Android 4.4 and Variant nano?

From my experience, having uninstalled Google Play Services doesn’t matter as it comes again with the open gapps package. Also I don’t think the recovery image is a problem as soon as you have access to “apply update from sdcard”.

Did you read the HOW TO for the topic “[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U?” on this forum? There is a description of how to install a new recovery image, and another way to install opengapps with adb an the sideload command.

In my experience the original recovery refuses to work because the opengapps verification key is invalid. I had to use CWM which allows you to install even if verification key is invalid.

1 Like

That makes sense. Hence the need @Lukas to install a new recovery image as described in [UNOFFICIAL] ✏ HOWTO Testing the latest UNOFFICIAL 4.4.4 ROM and switching back to FP OS again [for Unix & FP1].

I did it, and installed opengapps too, and the play store seems to work :slight_smile: (thanks for your help)

But now the android-keyboard stopped working which is nearly as bad as before, because i cannot login to my account :cry: I only want to validate my poweramp which requires google play

so… are there any alternative keyboards I could use?

E: Okay i simply installed another keyboard :smiley: (adaptxt https://www.apk4fun.com/apk/6440/)

1 Like

I explained how I did it a bit further up the topic… This worked for me. You can either stick with google keybord or install swipe… whatever you like best.

I flashed it with adb sideload and everything seems to went fine.
The only issue I noticed is that localization doesn’t work everywhere (eg settings is still not german, as I have selected in the settings menu). I hope the rough edges gets fixed (kinda) soon! :slight_smile:

1 Like

Just installed over unofficial chris 4.4 by doing this:

  • put macadamia zip on phone
  • reboot in recovery (btw the app (“SimpleReboot” on f-droid is great for that)
  • clear cache
  • advanced, clear dalvik cache
  • install from zip, choose the macadamia zip

Problems so far:

  • I has constant crashes of the Email app and Exchange Service, probably due to the downgrade from 4.4 to 4.2. I managed to clear the user data of these apps (by setting these two apps as User apps, then back to System apps, using the application “/system/app mover”), then I’ve re-configured my account manually, and now it’s working again.
  • The system configuration UI is still in English despite the fact that I chose French.
  • It does seem that the UI is slightly less responsive, but it’s hard to really tell.

thanks for your work on this ROM! long live our old FP1s!

Not sure what is going wrong, but the update does not seem to install on my device.

Step 1-5 are going fine, at step 6 I have little to no wait time for preparations, it just instantly gives me the restart button.

During the restart it seems to be installing the update, but after the boot nothing has changed:
* android version is 4.2.2
* no new launcher to be found
* fairphone updater indicates OS version is 1.8.7 (which as I’ve read might be normal)

I’ve tried multiple downloads and a factory reset. Any idea what might be going wrong?

Trying to install Xposed I got finally stuck with the same problem. Here is an alternative working without a Google Play account: the google keyboard as an apk at https://www.apkmirror.com/wp-content/themes/APKMirror/download.php?id=90957

What recovery are you using (i.e. did you ever flash a custom recovery such as ClockworkMod recovery)?

You should be able to get a log of the last recovery run in /cache/recovery/last_log (or a similarly named file). Please have a look there if it indicates a problem.


I’ve never flashed a custom recovery, everything on my phone is stock.

# cat /cache/recovery/last_log -- Install /sccard/Download ... I:Finding update package... I:Update location: /tmp/sideload/package.zip I:Opening update package... I:read key e=3 I:1 key(s) loaded from /res/keys I:Verifying update package I:comment is 1646 bytes; signature is 1628 bytes from end E:failed to verify whole-file signature I:verify_file return 1 E:signature verification failed Installation aborted

No sorry, I just messed up, I edited my response.