FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

Hi, I have OpenGapps installed and xposed (of course!)

I don’t think I enabled anything optimizating battery… I’ll check it out and I’ll do what you’re suggesting.

Will get back to you…

Downgrade instructions don’t work: it leaves me with Error: “System property does not match Installation aborted.”

Oups sorry can’t find it… :worried: can you please point me to the right direction?

Just found out that my phone has focus problems with the camera movie mode. It keeps going out of focus every “less than” seconds. I have to touch the screen to stabilize it again and so on…

Sorry for that. I will immediately try to reproduce this and give you updated instructions.

Edit: I was ably to reproduce it and will look for a solution.

Why do you not provide more often a new preview version?
Thanks for your work!!! :slight_smile:


@martin1 I have corrected the OTA package for downgrading and updated the description in the original post.

New: The downgrade OTA is now also available from the advanced section of the Updater app.

Thanks for the solution, this works now.

1 Like

I had the same setting…

How about the camera focus problem? Can it be OS related?

It can be driver related. It could also be an hardware issue. Did you have the same problem with 1.8.7?

Unfortunately, bad battery life could be influenced by a lot of factors. XPosed modules are among them. In most cases poor battery life is caused by the phone not being able to save power because some process keeps the CPU active too often. That could be anything from hardware that sends too many interrupts or software that performs some computation or polls sensor data too frequently.

Both the Google framework and XPosed often cause such behavior.

We probably should. It’s always a trade-off between spending time on preparation of a release and spending that time working on issues. But you are right: It’s about time :slight_smile:

1 Like

To see if a process is consuming a lot of CPU power, follow the troubleshooting steps in this thread:

Can we await some changes at the bt le Support?

[quote=“jftr, post:288, topic:19450”]
Go back to the stable version 1.8.7 and see if that changes anything.
[/quote]Now the display is black and stays black. I’ll try the waiting again… as I can’t unlock adb without the screen I can not retrieve a bugreport or dig around in the device. But it boots up, first time I heard the jingle and now I’ve got access to the device using the file browser. Looks like a hardware issue now, which is … :frowning:

Edit: Waiting resulted in the same behavior as with 4.4.x, the screen is usable for a short preriod of time and flickering starts to occur. As the display assembly is sold out, I’ll try my luck asking the support for a replacement by the service center.

1 Like

I don’t think I had this problem with 1.8.7… But I can’t be 100% sure.

Would you mind going back to 1.8.7 and testing?

When I test the GPS in Location Engineer Mode, it works really great, but as soon as I use an app like Google Maps or Pokémon Go the GPS is awful, taking much longer to fix and refreshing the location much slower. Is there any possibility to fix this?

Regarding the GPS-turning-on-by-itself bug: it’s gone. Since it only happened when connecting the 3G data, I spent the last few months using mostly 2G (3G only when really needed), and now, out of nowhere, it’s solved. No idea what happened.

Interesting observation. Thanks for sharing. Maybe it helps.

Odd. I think we still need to find the root of the original problem and solve it.

I’d like to take the opportunity, being it the end of October already, and dare to ask about your progress, @jftr? :slight_smile: Is there any? Or are the bugs just impossible to iron out?

1 Like