FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

I also installed the update successfully two days ago (coming from the last official version) and got the GApps working with CWM recovery and OpenGApps pico. So far everything seems to work rather well, no problems with GPS - even Pokémon Go is running fine.
Will report back if anything comes up. :slight_smile:

1 Like

GPS is always turning on when I have data connection on mobile network. I’m using the very same apps I has on a previous installation (no weather , so I suspect the issue is the OS. It even reverts from Battery Saving Mode to GPS location. Any suggestion?

I’ve even already uninstalled Google Play services, which was the only app requesting my location.

Thank you for your answer! It’s good to know that there’s a way to fix my problem:) but I’m not sure if I will try the CWM recovery and opengapps solution yet, cause I’ m not used to that stuff so I don’t feel safe doing this without reading more about it

Can you please describe this in a bit more detail? I want to make sure I understand the problem correctly and can follow your steps. Especially, how do you see that location is turned on on data connection and that it reverts from battery saving to GPS location.

Had you installed OpenGApps? How did you uninstall it again? Did you only remove Google Play Services or all Google Apps? (the latter heavily rely on the former and you probably mess up your system if you remove Google Play Services alone).

I hope a suitable Google Apps package will be released early next week.


Say I’m connected to Wifi, as soon as I’m far from it and it disconnects (or I deactivate it) and the phone changes to mobile data, the Location icon lights up. Every single time the phone relies on mobile data the gps turns on.

If I then go to location settings, the mode is set to Devices, when I had deliberately set it to Battery Saving beforehand.

Under Recent Location Requests the only thing is always there is Google Play Services and sometimes Store. So I uninstalled Services using 3C Toolbox but the same thing kept happening, but now there was no app under Requests. (I’ve since reinstalled it)

I remember the same thing happening on 4.2 as well, but not (by far) as consistently as now.

1 Like

Reminds me of this (unresolved) ancient topic (just mentioning in case there’s something relevant there):

I´ve tried to create a bug report with adb but it didn´t work. I can´t find it anywhere. I´ve an MTK Logger Report, which i could send to you.

Just quick feedback after using Kitkat for half a week. Overall the system seems to work really well. I’ve used sound, location, sensors, wifi.

The issues I’ve come across:

  • The updater does not work when opened from the Downloads app. In this case the intent does not contain a file path, and the updater fails with a very strange, unrelated error message.
  • Several Google apps crashed after installing OpenGApps. Re-installing them helped.
  • After installing OpenGApps nano, the AOSP keyboard that I was using kept crashing. Installing the Google keyboard fails, claiming that the package is not signed properly. Installing Swiftkey works; this is what I’m currently using.
    This problem was surprisingly tricky to solve. After all, how do you install another keyboard if that requires you to log in to Google, and that requires you to type your password, and typing your password is not possible because your keyboard keeps crashing :slight_smile: ?

I’ll also give a quick update on things I’ve noticed, I installed Macadamia at the start of this week (upgraded from Koala Nut):

  • Keyboard: Had the same issue with Google keyboard not working after installing Open GApps.
  • GPS: Not working properly. Regularly unconnects. As in I tried using navigation and every other minute I get the status it’s searching for GPS again. It’s fairly reliable in that it will connect again in a few seconds, but it’s so consistent that it’s kind of weird.
  • Language: When I select German system language, the entire settings menu remains English, the rest of the phone changes language as far as I can see.
  • Power Menu: Not a bug, but I’m actually missing the “reboot” button in the quick menu from holding down the power button, it was handy.
  • Wi-Fi hotspot: No issues, just wanted to say I used it and had no troubles.
  • Sensors: Again no issues, using the app “Sensor Kinetics” all built-in sensors seem to work perfectly.

The location icon showing up does not necessarily mean that GPS is on. Maybe it’s just updating the estimated location based on the cell towers it connects to.

This is strange indeed. I’ll look into it.

@Luiz_Eduardo_Pia_de_, do you have a SIM card with data only?[quote=“makkno, post:115, topic:19450”]
I´ve an MTK Logger Report, which i could send to you.

Perfect. Send it my way if it’s not too big or upload it somewhere and send me the link.

@Sjlver and @Kris_S

Noted. Thanks for your detailed feedback. (I won’t look into the OpenGApps issues because there will be a different GApps package).

It is on your computer at the location you run the command from. If you are on Linux and you haven’t switched directory, it’s probably in your home directory. On Windows, it might be in your User directory or maybe at C:\?

When the location icon is lit, the battery report also claims GPS is on, and the battery drain in noticeable (yesterday it was almost scarily vertical). My SIM is a regular one, not data only (the provider is TIM, in Brazil).

You can try sideloading Google Keyboard and enabling installation from untrusted sources, you don’t even need a working keyboard on the phone for that! But that’s probably a GApps issue that the final version won’t have.

1 Like

I don’t know if it is available for Android KitKat (I don’t know how to check it), but can you add the galician language?

Unfortunately not. These are the only languages we have available:

en_GB, en_SG, zh_CN, en_US, en_AU, zh_TW, en_NZ, fr_CA, nl_BE, fr_BE, de_DE, de_CH, fr_CH, it_CH, de_LI, nl_NL, pl_PL, ja_JP, fr_FR, ko_KR, es_ES, de_AT, it_IT, ru_RU, cs_CZ

(and we won’t include all of them, I guess, e.g. no Chinese)

Installed over @chrmhoffmann’s like in post #28. Didn’t need to wipe data.

After two days using, seems to be working almost identically to chrmhoffmann’s, ie. super well!

New glitches:

  • Fairphone updater keeps asking sudo.
  • “Unfortunately, Email has stopped” occasionally pops up. I only use Gmail for email.
  • Battery status not stuck at 14%, but is otherwise glitchy as in FairphoneOS 1.8.5.
  • Maximum charging current has dropped from 0.8A to 0.67A? I have a current meter, and the current used to be steadily around 0.8A, only depending on charger & usb cable. I didn’t think Android handles the inner charging stuff at all. There is a slight chance that this is because I dropped my phone the day before installing, who knows!
  • I liked old Fairphone 1 style boot & charging animations better : )

Glitches common to chrmhoffmann’s:

  • Facebook Messenger: about 1/20 messages are missing the last word, as the text does not fit into its allocated bubble.
  • Snapchat: encodes glitched video. Preview is ok, but sent videos have color plane displacement and band of noise on the side, while saved videos are completely black with band of noise on the side. Instagam, which also re-encodes video, works fine.

Telephony was buggy on chrmhoffmann’s build, and wifi & mobile data sometimes stopped working. Will report any glitches on these. I do suspect that my Fairphone once called to my aunt Tupu on its own.

Good work, thank you :frog:

1 Like

Trying to help someone navigate to the #touchscreentest I just went to testing mode and saw that the english translations to the mandarin characters are missing.


Oh wow, I didn’t know anyone would ever boot into that mode … I’ll see whether there is anything I can do.


I’ll quickly sum up my experience (But nothing I haven’t read already in previous posts):

  • Upgrade from Kola Nut worked fine
  • All the previously installed apps were still there, some worked only after installing SDFix
  • Play Store doesn’t work
  • Can’t get OpenGApps to work, but have only tried via sd-card.
  • BT works fine with my headset, which is BT 4.0

I can confirm the langauge bug. The language is set to spanish, all the apps and menus seems to be in spanish except for the settings that is in english.