Finally... a new forum theme!

The community forum has received a long-overdue cosmetic makeover, solving many technical issues and enabling new options.

Here’s what changed:

  • The Phone|Story|Community|Support header has been removed because it was severely broken, which caused browser issues and interface inconsistencies
  • The existing (broken) themes have been removed and a new default theme has been added
  • New color palettes have been added, including Solarized and WCAG versions
  • Logos, icons and emojis have been recreated with the new Fairphone blue color
  • The forum logo has been redesigned
  • Dark Mode is fully supported

You can enable the Dark Mode option in Preferences > Interface:

Dark Mode

22 Likes

Using dark theme now ~ will see how it goes :slight_smile:

Nice! This theme component (no rebuild required) allows people to switch manually from the hamburger menu, or enable automatic switching.

I think this was simply an artefact from an ancient version of fairphone.com anyway and served no real purpose to anyone anymore. Thank god it’s been cleared out.

3 Likes

I installed the Dark-Light Toggle theme component. After selecting a Dark color scheme in Preferences > Interface and reloading the webpage you will see the Dark-Light toggle button in the top-right corner, next to the Search and Hamburger icons.
Dark-Light Toggle

9 Likes

Ah I see. Didn’t know about this component. I believe you can set a default for everyone for the dark theme setting, if not set. It’s in settings called default_dark_mode_color_scheme_id. Then it’s available for all without an extra step.

This theme component doesn’t automatically switch when dark mode is enabled. The one I posted in this thread does. Could be useful.

You could still do something which is maintained by the community, no effort on your side. The theme component below offers a way to welcome new users. Based on the trust level you can hide it, if needed. Some basic links could be in there such as the Fairphone mission, how to contact support, the scope of this forum, etc. You can also theme it with your own custom background and colors.


I by the way still see my profile URL twice, this doesn’t occur in a vanilla Discourse installation. Maybe there is still a plugin/theme component enabled that’s incompatible?

Screenshot 2022-10-14 at 11-17-32 Finally... a new forum theme! - Discuss _ The Forum - Fairphone Community Forum

That option is indeed set to Dark. But I noticed that it wasn’t automatically updated in Preferences > Interface for my account. So I’m assuming that others also need to select that color scheme manually.

1 Like

Drats. I hoped that would be solved as there’s no custom HTML/CSS in the new theme. There are also no obscure theme components installed. So I guess it’s caused by one of the plugins. I’ll have a look.

2 Likes

That one is still on the to-do list. One thing at a time… :wink:

3 Likes

I tried installing the theme component that you suggested but got a warning that it was already installed. Upon closer inspection of the GitHub URL I noticed that it’s in fact the exact same theme component that I already installed. :grin:

You’re right, I think they removed the hamburger menu item because of the new sidebar behavior in Discourse, which is not enabled yet on this forum (still experimental). It’s strange that my forum does automatically switch theme when dark mode is enabled on my Fedora Linux and Android OS. I hope they merge the icons in the sidebar/hamburger menu soon again. It’s more efficient for space.

and it’s beautiful!

I wouldn’t say that but useable in the evening seems tolerable :slight_smile:

Just a brainfart. If the top logo has the round logo with the hands on the left side, then the transition from the big logo to the small logo when scrolling through a thread is smoother. Because then the round hand logo remains static and the text just gets replaced with the thread details. At the moment the round logo is on the right and then pops to the left corner when scrolling. It’s not a major thing. But I think it can be smoother. :nerd_face:

5 Likes

When in WCAG dark mode I go to

some of the text is in black and unreadable.

As always, @UPPERCASE is absolutely right! I moved the round logo to the left and indeed it looks much better. Thanks for pointing it out! :slight_smile:

5 Likes

I would say since the update I have troubles to use the forum on my FP4. I see glitches when an answer box is open I start to type, look up something and come back and than I cant see the cursor in the box, its hidden by the keyboard. I have to close the forum and reopen to proceed with my answer. Cant explain well and I’m wondering if anyone else is seeing this?

Also, today I tried to move some posts to another topic and I think I selected those I wanted to move (last 3), however the system moved all other posts except the last 3 I selected and closed the topic I was moving into. I have re-done this now and I’m sure I wrote a reply on the topic I wanted to move and which I finally moved, however the answer was put on the other topic where it was split from.
So yeah, I know sounds more like a glitch in blond brain and a user error, still I would like to document…

Is it like this? It’s partly fixed by Discourse, but needs more work. I don’t think it’s related to the theme change.

2 Likes

Yes thats it.

I have seen this sometimes (quite rarely) before the theme change, and see it since the theme change def more often than ever before, so wondering of I’m doing something different since yesterday🤔

So it def. happens when I’m at the bottom of a page, seems when you then scroll up a bit, the answer Windows is “released” again, so no need to close…