English

Fairphone Open OS 17.09.3 (Android 6.0) release

There is a new update for Fairphone Open OS. Use the update app or download to 17.09.3 here.
For release notes see here.

8 Likes

At my phone the update went smoothly.

2 Likes

Impossible to switch on my phone after the update. Any solution ?

1 Like

Could you check the battery, perhaps you need to charge your phone.

1 Like

Short question:
I still did not upgrade from Android 5 to Android 6 as there were some strange bugs which lead to freezes and frequent reboots. Can I give it another try with this release?

As I have an encrypted phone and xposed installed as well I would follow this guide: ✏ Update Guide for a modified FP Open OS (with Gapps, Xposed and more)

Short answer: No.

Long answer:
With this reasoning no upgrade or update will ever be safe to do for you.
Just stay on Android 5 getting no updates any more and wait for somebody to remotely tamper with your phone via some security hole that was patched with a later upgrade or update. Currently you want to google “BlueBorne”.

There is no such thing as a bug-free OS. But with every update there is at least hope that the bugs are getting less … until there’s a version upgrade of course, and the circle starts anew :slight_smile:

4 Likes

Hi,

The baseband has also been updated. But the changelog doesn’t say what changed. Is it possible to get changelog for the modem?

Chris

8 Likes

Mise à jour longue à charger, mais tout s’est parfaitement bien passé.
Francis

Went smoothly for me!

Update went flawlessly for me. Thanks!

Finally on Android 6 -> my upgrade story

1 Like

The update went well for me, as always. I used the manual package from command line, omitting the recovery.img so the manually upgraded TWRP doesn’t get overwritten. Kudos to the Fairphone devs for emitting the BlueBorne fix in such a fast way!

1 Like

Another one who the upgrade went smoothly and fine :slight_smile: great work!

1 Like

The update seemed to go smoothly and then I put on opengapps micro. A few hours later, I got repeat messages that GiphyCam had crashed. I didn’t think I’d opened the app, so I just uninstalled it. Now, when I try to run Signal, I get a few messages in a row that it’s crashed.

I’ve tried installing today’s version of opengapps micro, which did not solve it. I also tried uninstalling all giphy software, which did not help.

Signal is the app I use most, so this is highly disconcerting. Should I try downgrading FPOOS to a previous version?

2 Likes

Using an encrypted phone, update went well.

1 Like

Hi all,

All good for me too via the updater, just like previous releases. :slight_smile:

Apparently, what’s happened is that when I updated FPOOS and opengapps, all of the security permissions on my phone seem to have gotten messed up. They get fixed if I uninstall and reinstall the aps, but I’ve now lost all of my conversations since august and will have to reinstall nearly every app I installed form the app store, also losing all of their history.

I did the update on Friday I think, and this morning I experienced loss of Wifi-Connections several times. The signal was very good, but when the phone went idle, the connection was lost, like in those old Android5-days. Has anybody experienced the same? The “keep Wifi on when idle”(or whatever it is called in English)-option is set, of course.

You can go in to Settings>Apps> and change the permissions per app. No need to reinstall all apps.
Though, yeah it is a known thing that using OpenGapps can create an issue. That’s why I decided not to use Nano or Micro anymore but went for Mini. Less problems with having to update everything all the time.