Fairphone Open OS 17.08.1 and (Android 6.0) release

Firefox hangs about twice a week, I wouldn’t consider it dramatic. I haven’t seen any other apps hang since then.

TWRP is the recovery mode. If you press Power + Volume down you get into Fastboot mode, and that looks exactly like you describe, there’s nothing more to it :wink: .

Em… I ment the fastboot mode, sorry. :wink: I guess I have found the mistake: I have removed the sd-card - and now the recovery and the fastboot mode are running well. :slight_smile:

I had stability issues with stock TWRP, too. Since I need a recent version for backups anyway (encrypted data partition), this problem didn’t affect me very much.


Hi all!
A few days ago I noticed that my contacts are damaged/corrupted. I am not sure if that happened after 17.08.1 or My FP2 is unmodified.
I restored a contacts backup (vcf) but after that all contact-photos were pixelized. So I restored a TWRP Backup (17.07.6) yesterday and all my contacts reappeared. Before that I did a full threema-backup.
Meanwhile the updater doesn’t show 17.08.1 any more so I had to update to again. After that my contacts were still all right, at least I think so. I restored my threema-backup and was happy again.
As always I switched off my phone in the night and started again this morning. The contacts are corrupted again!!
It seems to me that one of these two updates damage my contacts.
Anybody else having this problem?
Is there a work-around?
Maybe I should report that to the bugtracker?

I just made a new, full threema-Backup again and I have just restored my TWRP Backup (17.07.6) again and restarted my phone. Contacts are all right!
Now I am restoring my threema-backup again…
All my contacts are damaged again so it’s not the fp-update but threema!

1 Like

I can not get into Fastboot. I just want to Flash OpenGapps but pressing VolDown+Power gets me stuck in the first Fairphone screen. Now my phone is only half working and furthermore my SD-Card is not accepted anymore, cant even format it.
I also removed the card and tried booting without it cause someone posted that as a solution but it did not change.

Considering the fact that I have more problems of this kind with each Update, I’m really thinking about switching back to FP OS :frowning:

That is what Fastboot mode on the phone looks like, you have to access it via adb or fastboot commands from your PC then.

Alternatively you could boot into the TWRP recovery by pressing Power + Volume Up and install the Open GApps ZIP file from there (but this works better with SD card in the phone to put the file on admittedly).

So I updated from 17.07.6 to yesterday and it kind of worked. But my contacts are gone now (glad I made a backup before) and I have a new error message appearing every now and then. It says:

license check error
error when checking your license
please try again later
error code: 6


What license are you talking about, phone? generic expletives

This message always appears when the alarm clock rings (and also after I snooze it away) and on yet unknown further occasions, like the last 2 times I woke the phone from standby mode.

Why am I still using this phone?!

1 Like

Thanks. Now I learned the difference between Fastboot and TRWP recovery. I managed to flash everything now and all is good. Well except for my SD-Card which seems to be broken now, I cannot read or format it on multiple devices. RIP

Update from 17.07.6 to using Fairphone Updater went smoothly, contacts don’t seem to have gotten corrupted.

Phone is encrypted, but otherwise using standard configuration.

My experience (from 17.06.4 to, on a 'phone with encrypted data and Xposed, which AFAIK means I have to manually upgrade using TWRP) was mixed, but also illuminating. In brief:

  • Used these excellent instructions and at least suffered no boot loops.
  • Lost all contact and calendar data. Fortunately it was all remote via DAVDroid, so not too difficult to restore. I had no local contact or calendar data but expect I’d’ve lost those too, given the copious other stories of same.
  • Don’t trust Titanium Backup since its “backup” of DAVDroid didn’t include any of DAVDroid’s configuration information (remote calendar and contact accounts).
  • As others have discovered, despite the fact that you use TWRP to manually install the update, you surprisingly don’t use the “manual” userdebug .zip file (the “manual” .zip will cause TWRP to give an “invalid zip file format” error): you use the “ota” userdebug .zip file instead.
  • I found upgrading TWRP (to 3.1.1-0 using the Official TWRP App) well worth doing because it’s easier to use, and can back up encrypted data partitions (extremely important since Titanium seems to be unreliable).
  • I learned that the encryption under FPOOS defaults to something completely bogus: despite enabling encryption on my data partition, TWRP could decrypt it using a default password, without any help from me.

As far as the encryption goes, some very shallow research suggests that it’s possible to go through the encryption process and somehow use a default password without realising you’re doing so, rendering the encryption completely pointless. I’d always assumed that entering my PIN unlocked my data partition, but it seems not. I feel like a complete idiot of course, and probably am a complete idiot, but if I were the FPOOS developers I would have put up a screaming red flashing are-you-sure are-you-really-sure are-you-really-really-sure three page warning before allowing a user to “encrypt” their 'phone using the password (quite literally) “default_password”. Next job is to find out how to correct this.

1 Like

I had trouble to update, and the support service sent me this :
Since the phone does not give a detailed error description, we recommend trying to manually update the software version. The following article will help you do this:

After following the very well detailed instructions, my FP2 rebooted in Fairphone OS 17.08.1
Thank you !
Denis from 38630 Les Avenières (France)


Hey guys,

I’m new here, I just got my new FP2 yesterday and now I’m trying to get rid of google on it. So FP Open OS it is but the Updater won’t restart my phone.

I used this link and "Method 1: Using the OTA package"
I opened the zip and the screen to “Restart” does appear but nothing happens when I tap it, when I double tap it, when I crazily frequently tap it - you get the idea.

I really don’t want to have to use Methode 2 since I’m not at all familiar with any of these techniques…

Sorry, if this has already been solved somewhere - I didn’t find it, so I would appreciate a link then.

1 Like

In post 14 of this threadL


Thanks @Lidwien. Since I don’t have a free micro SD right now, I followed the instructions here ✏ Installing Fairphone Open OS using Fastboot (Step-by-step Guide) at least for the first part and then Method 2 wasn’t that difficult anymore. It just seems that in every explanation here and on code.fairphone.com there’s something missing… But now the phone reboots and I hope that problem is solved.

Oh no… the phone froze on reboot and I did the same as mae in post 13. My phone doesn’t boot in any mode any more. All I can do, is to start the TWRP recovery mode.

Am I right that I now only need to follow the last 4 points of the instructions in post 14:

Or is it also necessary to do the first part with the adapted TWRP image?

Update: I somehow magically solved the issue. I just want to post it here since I haven’t read it anywhere else yet and if someone has the same problem it might work easier than the other ways I found (the thread was already closed by the time so I post it as an edit):

I used Method 2 to flash my new FP2 and my comp said, my phone was sucessfully flashed and I ordered the reboot. It got hung up in the reboot and I took out the battery to kill it. In that state only the fast boot and the TWRP recovery mode worked. In TWRP I simply “wiped” the phone (resert to factory setting) and suddenly it worked. It properly booted into the normal mode.

1 Like

If the image is on your phone then you only need to follow the last 4 points.
If this doesn’t work, the next update for the Fairphone Open should be available tomorrow.

1 Like

The new update to 17.09.3 is released…