English

[Bug] ✏ Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

So far we were not able to find the reason for this to break.
It seems connected the installation of some 3rd party system modifications and the team is not able to support and test for these kind of modifications.

In what sense do you think the bug was renamed incorrectly?

Some people suffered it without modifying their systems in any way.

We weren’t able to reproduce this bug on unmodified Fairphone 2’s

I have the bug and I did not install any 3rd party system modifications. I just enabled root access (for CatLog to see if I can find out why I get random reboots) and installed some regular apps (through F-Droid or apks downloaded from Google Store). I don’t have any (Open) Google Apps installed.

1 Like

How did you download the apps from the Google store?

Through https://apps.evozi.com/apk-downloader/ on my PC and then transferred to the SD card.

Clear. Thank you for explaining.
We’ve tried several times here to reproduce the bug and did not succeed, so it is difficult for us to find out what is happening.

Today we will release the July update for Open. We have not changed anything in regards to this bug (as we wouldn’t know what to change). But we’d be happy to hear if you still experience this issue when updating to 17.07.

2 Likes

I’ll try upgrading directly to 17.07. and if that fails I’m pretty much out of ideas, as I already tried to completely unmodify my phone. I will try to go back to the regular OS, upgrade and then install Open OS again. I just hope that it works eventually!

2 Likes

Thanks for your effort and constantly providing updates!

How can i completely wipe the phone and do a clean install? I thought flashing the image with fastboot would be enough but it seams the /data partition is still there?

Is encrypting the phone officially supported?

3 Likes

Sorry, @Douwe, but I can’t see how marking the bug report as “Rejected” solves anything at all. Ignoring the fact that its new name doesn’t truly descript the issue.

After a month and a half, I don’t have the Open 5.1 backup anymore to try the new Open 6 update —because of the bug I switched to Lineage OS— so I’m afraid I can’t help with the bug.

I did not mantioned yet, I just needed to delete the app AdBlockPlus, I were able to do it in safe mode and the freezing and reloop found an end…
But that takes me two days in front of two Displays.

But I still got, like some others, the problem with stuttering when playing audiofiles since the update… That means in fact I can not hear music with the phone…very sad for me.

Tried to update to 17.07, same issue.
Are we on our own here or is someone still working on this ?

Hi all,

since I had some time today, I thought I’d finally try my luck with the newest Marshmallow FP Open version.

Of course (of course!) I got stuck in boot loops. Luckily I made extensive backups beforehand, but I’m a little unsure how to go on and after several hours of searching the forum, I’m giving up on finding the answer without asking…

Here’s the current situation:

  • I have both a Titanium Backup Pro backup and a TWRP backup

  • I factory reset my phone and installed 17.07, OpenGapps and Xposed via TWRP, all of which seems to have worked (I think, unsure on how to check for Xposed).

  • Now I’d like to get my apps and data back. I first tried to install TiBa, but while the Play Store lets me install it, I cannot open it thereafter (it doesn’t show up anywhere on the home screen or in the list of all apps, but does show up as installed in the Play Store. But when I click on Open in the Play Store, it just opens the Play Store page for TiBa, not the app. The only other option is uninstall. Un- and reinstalling it doesn’t change anything).

  • So then I figured I’d go the TWRP route, but am also uncertain what I should restore - all partitions (Boot, System, Cache, Data)? Or does one of these include the old Android 5.1, which I don’t actually want back and if so, which one should I uncheck?

On the off chance that someone has a better solution for how to get my apps and data back, I’m open for it. Worst case I guess I’ll go back to 5.1, but since I’ve managed to get 6 installed now, it would be nice to keep going…

Help is much appreciated!!

Regards
Emmy

P.S. Phone is not encrypted but rooted.

Oy…okay, found the problem with TiBa. I only installed the Pro version and forgot that only the free version is the actual app. So now TiBa is restoring my apps and their data.

I’m still a little unclear on whether that’s EVERYTHING I want to install, or whether some things (systems settings of some sort?) will still be missing. I’m also still unclear on how exactly I’d go about doing a TWRP restore and what it includes exactly…maybe someone could clarify or point me to a thread where this is explained, in case I missed it?

Thanks.

I had the same problem when I updated from FPOS with android 5 to 17.08 yesterday and there are no GAPPS on it.
I also had a feeling that these freezes are comming from some App, which wasn’t up to date or maybe wants to get access of Superuser functionalities. I think my phone wasn’t happy about that so i went into Safe Mode end uninstalled some Apps like Aptoide and others I don’t use.

Now everything works just fine.

EDIT:
Ah, well, except I lost all my contacts. But I made a Backup some months ago, so what.

Well, I went with the solution described in the wiki post :

Then restored what I could using titanium backup.
It worked, except I lost my contacts and I can’t add an account in davdroid (so I cannot retrieve my contacts).
It just says “the account could not be created”. If you have any idea…

@Tohuwabohu
I just realized yesterday that I experienced exatly the same issue as you. I lost all my locally safed contacts. Unfortunately I did not realize it, because most of my contacts have telegram and the telegram-contacts stayed in the list (of course only with the telegram-numbers. Email-adresses etc. were lost). I can not trace back the data-loss to a specific time. But I am pretty sure, that I did not loose them too long ago (probably with the last update a week ago) because I use the normal contacts regularily.
A few things I did in the last days that could have caused the problem were:

  • updating to 17.09.3
  • upgrading Xpricacy to PRO
    -> to be able to install the s…-f…ing-whatsapp for my work without having my contacts stolen (I only needed one work-contact in my list which worked well with Xposed)
  • installed uptodown and Yalp-store for test reasons (and to download the right-ignoring, identity-stealing, privacy-killing “whats-up with this-app?”)

[Side comment: Yes, I did not like being forced to using this app. And just installing it proved to me why in more than one way. I have never installed an app before demanding that many permissions. And perfidious messages like: “We make the installation even more easy for you: Just give us access to all your SMS messages.” Ahhh, yeah, for saving ONE CLICK to copy and paste a security-code I give you access to ALL MY PRIVATE MESSAGES!!! Seriously, what is wrong with these people???]

I did realize last week also that the name connected to SMS (which remained on the phone) were lost. But I did not have time to look into this yet. It is the same fault though, lost contacts.

First I tried to fix it by restoring my contact list from Titanium Backup, but with no success! I also tried to load the contacts directly from my SIM-card with no success! I can see the contacts on the SIM (when trying to import them from the card), but importing does not work. Of course I restarted my phone after the recovery attempts.
-> So I figure that for some reason my contacts are not lost, but they are simply blocked.
The android 6 permissions are all given. Xprivacy does not have permissions for “Contacts”.

From other posts, I red that AdblockPlus can cause this problem. I have the app AdAway which is similar. So I would like to uninstall it but red that people go into some safe-mode in TWRP before. Why is that? I was not in this mode before, but I guess you get there from TWRP.

Anyone any other suggestions for the issue? I have looked through quite a few older posts, but maybe I have missed one.

I spent some time the last two days to try the update again. Good news, I found the responsible app.

First I want to mention that just doing the update still didn’t work with the latest version. It worked after I uninstalled all my custom installed apps. I did a backup with TitaniumBackup first, so I could restore them afterwards. However, I when uninstalling the custom apps I noticed that I had installed updates to Amaze with F-Droid. I also noticed that Amaze was completely gone after the update. So I did a complete roll-back (restored TWRP backup from before the upate) and tried the update again after I just uninstalled the updates to Amaze and then it worked.

So tldr: In my case the issue was the Amaze updates coming from F-Droid.

4 Likes

@Lluvia
I can confirm this. Thank you so much for finding out. Finally I have my contacts back. I am very happy.
Just uninstalled amaze and loaded my contacts from titanium backup.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.