Fastboot does not work + Android 6 upgrade issues

Yesterday evening I wanted to try to upgrade my FP2 to Android 6 (17.09.3).
(encrypted, FP Open 17.03.0, xposed+xprivacy, no GApps)

Of course I made a lot backups in advance (TWRP and Backups off all Apps+Data using oandbackup)

Unfortunately several things went wrong:
At first I ran into the same issues as everyone who tried this. I disabled xposed framework in advance but my phone freezed after the upgrade as well. Same problems most people had --> [Bug] ✏ Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)
Wipe data helped me to be able to start Android 6 (without freezes or reboots), but WLAN was not working (it somehow did not really turn on so it did not discover any available WLAN :-/)

An additional problem I have is that I cannot boot into fastboot mode (phone is hanging and shows a Fairphone Start Logo/screen). Fastboot (one my laptop) is not discovering it (-> shows < waiting for any device > infinite). So I was also not able to perform the downgrade as workaround in between.

After the WLAN issue under Android 6, I decided to go back as I need at least a somehow working phone. It worked fine using my TRWP (v. -> works with encryption) Backup.
So here I’m back at Android 17.03.0. :-/

Personally I would go on like this:

  1. try to fix the fastboot problem --> what can I do to be able to boot normal into fastboot mode? (normal boot works as well as a boot into TWRP recovery)
  2. Another attempt to upgrade to Android 6.

I would like to go this step (Step 2) as staying at 17.03 for a longer time is not good as well. I would also be ok with a clean 17.09.3 which I can setup on my own step by step (restore all apps one by one). I hope I will not get this WLAN problem after my next attempt again.

But one step after the other. At first I don’t know how to fix 1. and after that I can think about what is the best way to upgrade for me.
Any recommendation?

1 Like

Fastboot on your phone is supposed to look like that, so there is a chance it’s actually the USB connection that doesn’t work. Have you tried different cables?

Ok, the point 1 was a simple laptop OS-user permission problem so I would say my fault or my own foolishness (never tested when I was in fastboot if fastboot devices works just tried to install something instead and it did not show any permission problem). I used the opportunity to flash the latest TWRP

my-user@my-machine:~$ adb devices -l
List of devices attached
fbcfb651               device usb:1-1 product:FP2 model:FP2 device:FP2

my-user@my-machine:~$ fastboot devices
no permissions (verify udev rules); see []	fastboot

root@my-machine:~# fastboot devices
fbcfb651	fastboot

root@my-machine:~# fastboot flash recovery twrp-3.1.1-0-fp2.img
target reported max download size of 536870912 bytes
sending 'recovery' (12204 KB)...
OKAY [  0.386s]
writing 'recovery'...
OKAY [  0.281s]
finished. total time: 0.668s

root@my-machine:~# fastboot reboot

finished. total time: 0.055s

So now I can give the Android6 upgrade another try. It feels that the only way is this very strange procedure with the downgrade in between, right?
I’m still confused a bit what would be the best way to proceed. The bug node describes a lot different workarounds: [Bug] ✏ Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)
One with Destroy the LUKS Header the other one without. Still confused what would be the best option. I think uninstall or at least disable xposed seems to be a good idea (but I did that before my first attempt as well)

Any last tips before I give it another try?

Tried to followed this procedure: Fairphone Open 17.06.4 (Android 6.0) release

One of the workarounds but I stuck ad the adb sideload step. :confused:

adb sideload 
opening ''...
falling back to older sideload method...
error: closed

So finally I have a phone running Android 6.

I followed the link I mentioned before. Only the sideload did not work so I used fastboot mode flash method instead:

  • downloaded (on the phone)

  • downloaded (on the laptop)

  • downloaded (on the laptop)

  • unzip the …manual …zips

  • !!! backup backup backup !!! -> I used oandbackup for Apps+Data and TWRP Backup in addition

  • flash via TWRP --> run into freeze reboot bug

  • started the FP2 in Fastboot-Mode (Power-On + Vol-Down)

  • run the ./ in the unzipped (17.04.0 manual) folder *

  • rebooted phone (Android 5.1, stuck in boot-loop, optimizing apps)

  • switched off by pulling out the battery

  • started the FP2 in Fastboot-Mode (Power-On + Vol-Down)

  • run the ./ in the unzipped (17.09.3 manual) folder *

  • rebooted

  • phone started “normal” with Android 6 (but the apps lost the data)

  • prepare oandbackup again and don’t forget to setup busybox correctly

  • restore all the app data you need one by one

*flashing the manual-userdebug.zips via script also means the related TWRP recovery will be flashed. As the device was encrypted I had to re-flash the latest twrp via fastboot like shown some posts before (otherwise decrypt is not possible). You can also edit the script before executing it to exclude recovery flash.

A very long and annoying procedure. Hope the next major release upgrade will be more smooth.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.