English

Oandbackup restore faillure on Marshmallow

I had a backup on oandbackup on my sd-card.
After updating to Open 17.06.1 I can’t restore several data from apps.
I get the error:
:sed: No such file or directory
:sed: No such file or directory
:stat: write: Broken pipe
:setPermissions error: could not find permissions for /data/user/0/com.nononsenseapps.notepad

Has anybody an idea who to retieve my data from the app Notepad (F-Droid)

FP Open has no busybox installed. Follow the instructions on the oandbackup github page to install busybox manually.
I complained before, that FP has too many missing console programs. At least a working busybox should be present.

Do you mean install the app Busybox of F-Droid or must I install Busybox on my computer.
And when done, what’s next?
Could you give me easy to understand instructions?
Much appreciated.

Installing the busybox app from F-Droid should do it (you don’t need anything on your computer). After that, you can just retry restoring your data with Oandbackup.

The background is that Oandbackup needs an installed instance of busybox on the phone to work (cause this brings support for basic linux console commands).

I have installed Busybox en retried to restore the notepad app.
Sorry to say, I get the same error as I stated in the beginning of this thread.

Look at the readme on the github page of oandbackup. There are also links to pre-built busybox binaries.

From the readme:

copy the busybox binary to your system, for example /system/xbin or /data/local, and make it executable. symlinking is not necessary for use with oandbackup. in the oandbackup preferences, provide the whole path to the busybox binary, including the binary’s file name (e.g. /data/local/busybox).

I installed the busybox in /system/xbin.
How do you make the app busybox executable? It’s showing -rwxr-xr-x
Isn’t that executable enough?

Yeah, but have you done this?

In your case, you need to enter /system/xbin/busybox.

Btw @mase: Are you sure that a missing busybox is the cause for this problem? Looks like it could also be something else (haven’t tried oandbackup with different android versions yet) - i.e. the backup works but setting the correct permissions for the system to be able to use the backuped data doesn’t work. Have a look here.

@Lidwien Is your phone properly rooted with root access for oandbackup?

I just found that one indeed need to enter in the oandbackup preferences the whole path to the busybox binary.
I overlooked this. Sorry @mase and @tphysm.
I am so happy, now I can restore all the apps. :point_up_2: :clap:

@Lidwien
Did you have to copy a busybox binary?
I am on LineageOS. Here everything is present.

Busybox is as an app available through F-Droid.

For clarification, this is not a FP OS/Open bug. Android only included a little subset of busybox utilities.
Furthermore, Android 6 replaced busybox with toybox (because Gobble don’t like busybox’s GPL license, maybe? :smirk:).

Can any of you with FP Open 6 try, out of curiosity, if oandbackup works placing /sbin/toybox as the busybox path?

Toybox is not included in FP Open and is not available through F-Droid, so I can’t test it.

The toybox can be found at /system/bin/toybox. But I have the very same issue in oandbackup as described by @Lidwien. It seems that sed is missing in that toybox…

1 Like

Same issue here (Fairphone Open), solved it by installing busybox with FDroid, start and install it with root rights, start oandbackup and put the path /system/xbin/busybox into the settings. I restored a backup of Signal with it.

Good luck!

Sebastian

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.