Fairphone 4 reboots

Hi !

I got a weird problem; got a rather new FP4 that reboots in a strange way. Being the owner of a dog you have a tendency of walking the same route every morning. And, my FP4 reboots in about the same place every morning ±100 meter. On a field. 250 meter to next building :slight_smile: Only thing that I can possible think of is a 5G basestation located about 400 meters away, and on this spot I am pretty exposed to this station. The throughput is nicely around 150-180 Mb/s, without wifi. I guess most people would be happy, but would be even better if it didn’t reboot.

Any idea of what to do to narrow down the problem ?

/Anders

PS ! I have been closer to the basestation, but then no issue. But I guess it would also depend how any array in the basestation antenna is configured

Hi and welcome to the forum.

You may find an option to restrict the network connection to only 4G which then would hopefully ignore 5G

Checking the options on my FP3 A11 beta :slight_smile:

Although I cannot access 5G on my FP3 there is a setting
Settings > Network and Internet > Mobile network > Advanced > Preferred network type >

Not sure if it’s the same location on the FP4 A11

1 Like

Good point ! Yes, the setting is there to restrict so 4G and below. But if the interference is on a more ‘general’ level that won’t help. But worth trying !

Thanks
A

2 Likes

Just a bit more info for what it’s worth.
Reboot problems have in the past been ascribed to frequent movement from cell to cell (when moving fast, such as in a train). Walking the dog is obviously not travelling fast :wink: but close proximity of the mast may be having an adverse effect, even if it is not carrying the network you use.
You may also look at only enabling Wi-Fi OR data at any one time. In other words turn off Wi-Fi when you don’t expect to be using it for a while, such as when you go out ; and maybe turn off data when you’re using Wi-Fi. This may also reduce battery usage too.

When next out with the dog, try turning off all connectivity (enable aeroplane mode), just to see if this does avoid the reboot. Obviously I’m not suggesting this is a solution.

1 Like

Thanks for the tips !!

Did switch off the 5G (kept the 4G/3G/2G option), and did switch off the wireless. And: No reboot !

This morning I enabled the 5G again, but kept wireless off. And: rebooted…

To be continued :slight_smile:

/A

4 Likes

Why it reboots is an issue. Sure it may have to switch between network bands but although that may interrupt a call etc. there’s no really acceptable reason for it to cause a phone reboot.

But if it does, given that 5G is not as common and has a shorter range then for now it seems best to keep it off in situations as you have found.

2 Likes

Still a mystery why this happens. Since last time I have been trying to find some logic behind the reboots. Didn’t mention, but I got two simcards ( one e-sim…) ,but same mobile operator ( work and private). So been trying different options with data and 5g on/off on different sim-cards. This morning everything worked (= no reboot) with this setting
Card 1: 4G, mobile data off
Card 2: 5G, mobile data on

And been trying some different options, will see if I could narrow it down further. I have also been travelling to other cities where there is a lot of 5G, and roaming between different cells and being close to the antenna is not an issue anywhere else. Except for this one. Also noticed this morning that the 5G speed had decreased significantly ( from 180 MB down to 80-100), wonder if the operator has been changing a few things as well…

I’ll see if I could find some more logic in this… :slight_smile:

It happens to me now as well. Second time in the past 4 days.

what do you think what occours?

Hard to say, what I see on my screen could be irrelevant to what goes on under the hood. It will need to happen more often to find a common factor. Once instance I unlocked my phone, got a Teams DM and then rebooted. The other instance I was watching a YouTube video.

At least the SIM is still unlocked and the phone is decrypted (I guess). So this soft reboot doesn’t numb your phone when it happens in your pocket, if I’m correct.

Edit: uptime is still 48 hours, so the phone doesn’t fully reboot leaving apps unlocked and the SIM as well. That at least limits the impact.

You are using a SD card, or? How is it formatted? As there are still overall issues seen with SD cards in the FP4 and SD cards can cause trouble irrespective of the device, I would keep that in mind…

I use one, as external storage. However, these issues didn’t happen before with the same SD card. It could still be related, but there are more (mostly cheap) phones with sudden reboots that don’t have SD cards. For example my OnePlus One had similar issues. Let’s hope it won’t happen again, and if it does I hope it’s easy to fix :slight_smile:

It hasn’t happened again, so that’s a good sign :slight_smile:

Hope it stays that way for you !

For me it is definitively related to the 5G setting. By the way, no SD card for me. Also been travelling the last 2 weeks, incl to other 5G areas, but no reboot at all…Just this strange basestation back home… :slight_smile: Will be there next week again…

3 Likes

just a me too, and for me it’s definitely related to 5G. i’ve removed my sd card, just to be sure, but if i do a network test (rtr netztest here in austria) and if i’m on 5G the phone locks up and reboots a few seconds later. i’ve disabled 5G for now and the network test succeeds.

the reboots do not happen all the time, sometimes the network test is successful even on 5G.

i also had these reboots when watching youtube or browsing with firefox, connected to 5G. so IMHO it’s not app related.

i’ve only discovered that 5G might be the issue yesterday, so will keep you posted how stable the phone is when only using 4G.

ah, and i also did a hardware test as recommended in the FAQ, the test app reports no errors.

thanks
toni

3 Likes

a quick update: phone is running stable with 5G switched off. 2 weeks of LTE usage without any reboots. as soon as i enable 5g i’m back to reboots if downloading via 5G.

@fairphone: is this a known issue?

1 Like

I think proper debugging (with e.g. logcat) is required before we point at 5G. There is a lot going on we don’t see. I had a sudden soft reboot today as well. It has been almost a month since. So 2 weeks of a stable run could be unrelated to 5G, I have 5G enabled BTW.

1 Like

To make Fairphone aware please #contactsupport

1 Like