Fairphone 2 touchscreen suddenly freezes

I have now had the FP2 for a little less than a week. Sometimes (about 5 or 6 times up until now) the touchscreen freezes and I have to remove the cover and take out the battery, restarting the phone to make it work.

One of these times, the screen turned black after restarting, so that I had to remove the battery again.

This freeze has happened at different times and I haven’t seen a pattern yet. It does not seem to be an issue with a certain app or mode.

Note by Moderator:

Before responding to this topic, please check whether this topic actually matches your issue:

  • Screen still on, but no response to touch: this topic
  • Screen stays black during/after phone calls: follow this link.
  • Screen doesn’t turn back on after locking phone: follow this link.

You may also be interested in the black screen guide.


The same just happened on my FP2.
The touchscreen does not respond to any touches anymore.
The power button is still working, but since you have to select reboot with the touchscreen, the only option is to remove the battery.

One funny thing I noticed:
The lockscreen did rotate when I rotated the phone (you do funny thinks when your phone isn’t working :wink:).
I never saw that behaviour before, and I checked, now that I rebooted the phone, the lockscreen doesn’t rotate anymore.
Not sure if it’s related…

1 Like

It just happend again. I just rebooted the phone and when it started up, the screen was non-responsive.

Again, I had to remove the battery to make it work.

This happened to me once. You don’t actually have to remove the battery though: If you press and hold the power button (even after the power menu appears on the screen) the phone will reboot itself after a while. This solved the problem for me.


Just for clarification. How long did you have to hold the button for? I ask, because this was one of the first things I tried, but after about 10 seconds I gave up, as it didn’t do anything.

I’ve timed it just now, and it’s almost exactly 15 seconds. First the power menu appears, then the screen dims, then goes completely black and about 1 second later you’ll feel the short vibration indicating that the phone is starting up again.

This has now happend again. Once yesterday and twice today.

On all three occasions, rebooting did not work. After trying to reboot three times, with all three times not rendering the touchscreen responsive, I had to take out the battery. Two of the times, this helped.

The third, and most recent was the most trying. I tried rebooting many times, to no avail. Then I removed the battery, which did not work either.

Only after having removed the battery 4 times the touchscreen started responding again. This left me without a phone for over an hour, at a time where I really needed it at the start of my working day, so I very much hope that it can be fixed.

Have you contacted support? I would do so and ask for a replacement.


I had screen locking by accident from my very first impressions (see forum “First Impressions with FP2”) e.g during very first power on and walking through getting started steps . More than one time !

After first time disassembling of FP2 only of display module and assembling once again I had no accidently screen locking ever since 1 week now. By the way several people had same experience under different forum subjects.

So I have to admit this is a typical issue of final fabric or compound of the product completion and delivery e.g. triggered by later by transport and cargo shift. It maybe not unusual for a modular system like FP2 actually is. However I am not sure if reassembling the display module also solves your issue here.

But I realized or maybe I oversee still an own sub-forum headline for typical primary issues pooled together after unpacking and experiencing same grave issues like flickering displays or wild jumping touch screen cursors. THe FAQ list of know bugs and problems is only the qualified output of that forum subject. The problems after unpacking are rather dispersed. Paul Kreutzer e.g. recommended me to search around in the forum. I don’t find this acceptable .


I have the same problem like you can read in other posts. After reassembling the display it works for me, too.
I also think this is a problem of the modular system of the FP2, but I’m fine with that small problems.

I have contacted support, but since this was done Friday, I don’t expect an answer until a weekday in next week.

Thanks for the tip. I will try disassembling and reassembling to see if it solves my problem. I’ll write results here.

Is one of the modules not working or is it a software problem ?

I have the same problem from time to time. The screen suddently freezes.
The power button still works. And after turning off the screen and back on, i.e. pressing the power button twice everything seems to work fine again. I haven’t disassembled and reassembled my FP2 yet, but the fact that it works again after pressing the power button makes me believe that it’s not a module connection problem. Maybe a software bug?
However, I’m waiting for other people’s results with disassembling and maybe I’ll try it as well then.



I have tried disassembling the screen, but alas, I cannot get it loose. I have followed the instructions, removed the battery, slid the two blue clips to the unlock position and tried to slide the screen loose. But it won’t budge. And there are limits to how much force I am willing to try. But I did use some stength without being able to get the screen to move at all!

So now I have turned it on again and it has worked for 3 Minutes😜. I’m hoping it doesn’t return anytime soon.

1 Like

I have now had the phone turned on for over a week, without the screen freezing. The only thing that I have done differently is that I tried to disassemble the screen. I wasn’t succesful however, as the screen couldn’t be removed with the moderate force tried (and yes, the blue screen lock clips were in the open position :stuck_out_tongue: ).

But it seems that the fact that I tried may have made a difference, since I have had no more problems with this issue.


Same here, on my phone it is similar, but just while charging… Plesse report, if there are any other solutions but reassembling.

1 Like

Did you already try it with another charger and/or cable?

Yes, tried three different chargers. Otherwise no phone had problems with any of my chargers…

Experienced the same problem, for the first time, today: the touchscreen didn’t response for about a minute or two while charging. Unplugged the charger, got a responsive screen, replugged the charger and again got a non-responsive screen. A minute of charging and it’s all working again. Weird.