English

Fairphone 2 touchscreen suddenly freezes

The same just happened to me on my FP2.
I have already had some issues with the touchscreen freezing but it would work again after blocking and unblocking the screen. But now the touchscreen does not respond to any touches anymore.
The power button is still working, but since I can’t type I can’t unlock the SIM.
Is is a bug or shall I try reassembling the screen?

Thx!

2 Likes

Got my Fairphone2 a few days ago, and there’s a couple of bugs - most which I hope will be fixable through software updates soon. :slightly_smiling:

The most crippling one of them is that I often cannot seem to even unlock my phone: Pressing the power button gets me to the lock screen, but the swipe-up gesture won’t be recognised. Sometimes double-clicking on notifications will help (if I have any), but other times that doesn’t work either. Holding the power button brings up the display with the option to turn off or reboot your phone, but this menu is not resposive either, so you need to keep holding the power button for longer to turn off and reboot the FP2.

The issue seems to be intermittent, sometimes things work fine and sometimes this “locked lock screen” mode just won’t go away. Although if you do manage to get past the lock screen, other software on the phone seem to respond just fine until you’re at the lock screen again.

It’s really frustrating to not even be able to get past the lock screen on your device. Is there any work-around for this bug?

1 Like

When the phone is locked (using the on/off button or if it goes to sleep) the touch screen becomes unresponsive and I cannot unlock the phone. I can unlock the phone from the lock screen when it is first turned on and the touch screen functions normally, but as soon as it is locked again this problem occurs and I have to remove the battery to turn it off as I cannot confirm switching off on the screen itself. I have tried rebooting the phone several times, increasing the delay on the long press and tried with different sim cards and no sim inserted but the problem occurs exactly the same every time.

1 Like

I have the same problem from time to time. The screen suddently freezes.
The power button still works. And after turning off the screen and back on, i.e. pressing the power button twice everything seems to work fine again. I will try to disassemble the screen and see if that helps matters but i doubt this tho it really looks like software issue. The easiest way to replicate is to play with moving widgets around the screens. Btw has anybody heard from the manufacturer about that? If issue will persist shall i consider returning within 14 days?

I recieved my FP2 last week and the same problem is happening to me, as well described by the other posters.

A major problem with my new FP2 is that it randomly freezes the touchscreen, meaning i can’t unlock if locked, navigate, type or anything.
Sometimes it “unfreeze” itself within a few minutes without any action from me, other times I can reboot it several times without any luck.

I have tried demounting the screen, looks fine but didn’t help.

1 Like

I had the same problem as you all… It looks like a problem a big part of FP2 have, will have… so, did anyone get a Problem Statement by Fairphone? did anyone get a proposal for a solution. I guess the problem has been properly described through the many messages here… May be we can focus on finding out if Fairphone has anything to say to that… I sent my complain to FP today, anyone did so much earlier?any reply?

Regards!
JM

I did manage to fix this by trying to loosen the screen and putting it
back. Since I did this, the problem has not returned. So it may just be a
matter of the screen needing to be jiggled in out and then back in place,
maybe because of how they are initially put together at the factory…

But then again, I don’t know if this “fix” only works on my phone.

Jens

kunstnerisk leder/artistic director Terra Nova
bestyrelsesmedlem af Uafhængige Scenekunstnere (US)
tlf. (+45) 25 48 64 84
www.jensbackvall.dk
www.future-force.net
www.t-nova.org
www.scenekunstnere.dk

Hi Jens,

Thanks for the message! Sounds good, at least worth a try! if I only knew how to loosen the scrren and put it back… I will probably need to go and find out, it is supposed to be an advantage of the FP2 right? Only that I was not expecting to having to do that so early after puchase !! :slight_smile: if you have a tip where can I check out how to do that… I would appreciate it! thanks a lot again!
JM

Here you can find instructions on how to disassemble it: https://de.ifixit.com/Device/Fairphone_2

1 Like

Thanks a lot! I had found that in the meantime… and tried to follow the instructions, but there is no way i can remove the screen in my phone. I am afriad I might damage it if i keep pushing!From what I read in the comments… apparently i am not the only one… Thanks anyway for the quick reply!
JM

1 Like

Same here with two new FP2 phones. I am not able to remove the display according to instructions.

You can try to use a plectrum/opening pick to just open the phone a little bit on the side, after flipping the switches.

Thanks for instructions. I dit it according to https://de.ifixit.com/Guide/Fairphone+2+Display_Einheit+ersetzen/53562 but step 4 does not work. I used a lot of energy to slide the display. I am afraid to damage it. I have that on two new FP2 phones. Hope for help.

Hi all… I dont know about you but I am geetting so pissed off with the thing I want to throw it out of the window!! anyone got a reply from FP?? is this happening to only some of the devices or to the majority of them? :frowning:

1 Like

I can assure you that it’s only happening to some phones.

Hey guys,
I had to reassemble my display yesterday again because my phone reacts with a relay of 1s on touch gestures.
So the same procedure: Remove display, clean the contacts, add the display. Ready. Its working again. :wink:

@paulkreuz: What shall I do? Ask support for help or replacement?

1 Like

Expierencing the same problems: no reaction of the touchscreen, several times a day! This is not a bug, this is a malfunction. Will send it back soon

Same here trying the RC 1.2.6 (2 times yesterday)

@anon12454812

1 Like