Touchscreen problems since 1.2.8

Bevore the 1.2.8 update I had several issues with the touchscreen as mentioned here Fairphone 2 touchscreen suddenly freezes and here Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay

Now I still experience crazy touch inputs, which disappear after locking/unlocking it for 2 to 3 times. But they seem to be of another kind than the old ones. Bevore the update I had problems while scrolling, now it’s coming suddenly and looks like someone is playing piano with 20 fingers on it. Totally going mad.

But even worse is the touch behaviour while typing. Using a German qwertz keyboard layout I can’t type an ‘u’. It always recognizes ‘z’ and ‘i’. Also the ‘Go Keyboard’ from Playstore has similar issues with the ‘n’.


1 Like

I can confirm for the “piano”-thingy since 1.2.8. No problems with typing though…

1 Like

I upgraded the same day of announcement e.g. early evening hour. The upgrade went without a problem in 15 minutes.

I checked several things here but the big problem was the oversensitive screen only while charging. I had opened a ticket 4 weeks ago that has not been answered until today because during charging my FP2 could not be really used.

With upgrade I was happy because the problem was really diminished although not vanished completely. Suddenly on the second day the screen was frozen for a short time after automatic screen locking. After pushing short the power button the locking background image appeared but without any responsiveness to my swipings or touching. I was really shocked because this was new after the upgrade while it happened while not charging.

On the other hand frozen screen was really not new to me. It happened on the first day with delivery and already immediately on first start of my FP2 for the very first time. It was on 14.1.2016 when I still had no SIM card with the micro factor. I wrote EMail for opening a ticket. That first ticket (out of 4) was not answered for almost 3-4 weeks! Still in january It took me half a week to disassemble the device how it was described by FP team. After I reassambled the device the problem vanished for a while. But only after I put in the first clipped SIM card the same day the frozen screen problem vanished completely. Only charging times was still a problem for this unstable device. I worked and lived with FP2 for 3 month only with minor problems. I didnot think I could give it away.

I describe the first week this way because only 3 days after the upgrade my FP2 dropped back into this state!

However for 2 days now it worked although I had experienced screen freeze already several hours after the upgrade. For other reason - I was in holiday - I decided to disable the second SIM card from my employer. And after this the screen freeze happened after every almost every screen lock. Typical as in january I could push loudness button with all working visible effects. Also the Wifi worked and pulled my mails silently in background because I had no chance to interact. I am sure that the complete FP2 worked behind the frozen display. After minutes of pushing power button, restarting the touchscreen came still back to work. So, with my memory of the first days in january I decided to disassemble only the display and reassamble it.

After restart the problem even increased because it was nearly impossible to get back to work. While I had a few free minutes to do things I decided to pull out the inactive second SIM card.

And yes: stability came back for 2 or 3 hours. For some reason I restarted the phone in the afternoon yesterday. This restart yesterday was fatal. It was the last one because every attempt until now was in vain and only shows thin lines all over the display without any other image or sign of file any more on my FP2. This morning I checked the defect display once again before I call FP hotline to get my FP2 back to Holland.


I cannot confirm 100% that the issue occured after upgrading to 1.2.8, but I would say it has.

Since then, I also experience the “playing piano with 20 fingers on it” problem.

Sometimes it stops for a while, then comes back randomly, sometimes a reboot fixes it, sometimes not. I haven’t found a clear pattern yet of when the problem occurs.

At this precise moment, I don’t have a problem with typing (as explained above), although I have had it appear randomly during two days last week.

Thanks for any advice.



Very similar on my phone. When unlocking (espacially after charging) it sometimes shows the described piano effect. The display is then either oversensitive or doesn’t respond at all.
I have to lock the screen again, wait a second, and unlock it to solve the problem for the next few hours.

Have a nice day

Could someone take a video of the so called piano-thingy? :smiley:

Here you go, a video from my fairphone 2 which is rendered completely useless by the piano-behaviour or at least a very similar looking effect:
fairphone 2 ghost touch syndrome


I can confirm this bug. After updating, I first thought the ghost touches went away, but unfortunately they got even more!

I’m nearly done with my FP2 =( Hope they fix the issues soon, otherwise I’ll switch again.

1 Like

Here a video of the weird typing and swiping problem I have with my phone.

It makes the phone very hard to handle, so I probably have to return it if this won’t be fixed soon.


1 Like

Hi - I got the same problem after the update an particularly typing an ‘s’, ‘w’ and any character close to the left and bottom edge is impossible (I have to turn the phone every time typing a ‘1’ and a space).
The keyboard sometimes also freezes briefly. Moreover (though that problem I had from start), is the screen completely blocked during call. Anyone knows what to do - can one get a new one?

Also the same problem here! It’s terrible, with this issue the FP2 is absolute useless. I don’t know what to do…

The typing problem became worse so I sent it in. Still waiting to get it back, but can keep you updated. For me it looks like a hardware problem.

Same for me…I handed the problem in a month ago but still got no answer on a solution so far…

I also have this problem!

The crazy piano fingers makes the phone unusable half of the time, and when they are not around, more than half the screen is unresponsive. This means that it is impossible to type, but also to open apps that are in the unresponsive areas. The problem started with parts of the screen to the left, and slowly it has been spreading to more and more parts of the screen. It’s basically noting more than a calling machine right now.

I reported the problem almost 1,5 month ago, but still no answer. Have they answered any of you yet?

So after Update 1.3.6 I have still the same problems… Maybe it’s really a hardware problem. I contacted support and asked, if I can send it in so they can have a look at it.

I’ve only used 1.2.8 and 1.3.6.

I had this occur on 1.2.8 for sure. I’m not sure about 1.3.6.

It doesn’t occur often, and IIRC if I put the screen off and on its gone.

Important details I feel are generally omitted in posts here are:

How often does it occur?


What are the circumstances?

I’m not yet sure when it occurs, how often it occurs, and what my circumstances are/were. Hope to add that in another post once I gathered more info.

It came back jeah. They swapped out the complete screen. Everything is working now.

Hey hubbeshunter, did you asked them, if you could send in your FP2, or did you just sent it in? Because I am waiting 9 days now for an answer of my request to send it in…

I opened a support ticket and just received a mail that they’re busy at the moment. Then I waited for a month until I called. Then everything worked out quickly.

40 days ago I made a longer report about my frozen display right after updating to 1.2.8 (see above). After display exchange on 20.4 my original phone returned with 1.2.8 but without any problems . It works well today and I don’t expect new display problems. However I am not sure due to the repair report if only the display was repaired. Also some (many?) people with newly delivered FP2 experience similiar problems until today. Sometimes it is solved after 1st opening of the display hw unit and reconstruct it sometimes it is not solved. So from the FP repair team for transparence only I am missing an incident report about DOAs (dead on arrivals) only with mal functional displays. To me it looks like a general problem even though many (not most ?) of them may be repaired persistently like my FP2 was repaired.