Encryption password does not work anymore for normal boot but for twrp (changed with snooperstopper)


I have the problem that I’m not able to decrypt my phone on normal boot anymore.

I changed the encryption password to an easier one before I performed an upgrade (FPOpen - Android 5 to 6 - as I had it to enter so often) using Snopperstopper. Now as the upgrade finished successful I wanted to change it back.
Snooperstopper showed (after chaning it to the new one):

Failed to change device encryption password.
Use the 'vdc cryptfs changepw password' command in a root shell
to set the password manually BEFORE rebooting.

I did that but now the encryption does not accept the new nor the old one when I try to decrypt the phone on boot.
The old one works in TWRP
So I wanted to ask if there is an option to fix this in TWRP? (e.g. via terminal or adb shell)

Thanks in advance.

Sounds similar to this issue: https://bugtracker.fairphone.com/project/fairphone-fairphone-os-android-6/issue/50

Unfortunately the issue remains unanswered. I am not aware of a workaround either. Also using the vdc command from the shell didn’t help. I had to format /data a couple of times due to this issue.

Ok thanks @freibadschwimmer At least now I know that it was not to 100% my fault. :wink:

Why did you have to format several times? I just did it once and was able to access the OS (clean) again.
I used a TWRP-backup I created before the password change (via snooperstopper) to bring back my data. I don’t know if this was a good idea, as it was a backup of an encrypted phone (of course decrypted in TWRP in advance) I still face some strange problems under Android6, but I will post them separatly to not mix up to many topics here.

Did you encrypt your phone in the meanwhile again? And if yes do you still use Snooperstopper (to set different things for unlock and encryption)?

1 Like

I had the same problem. Thanks to this thread I wiped my data once and I have a clean FPOpen with android 6 now. At the moment I am restoring my apps from a TitaniumBackup (except SnooperStopper). Is there any way to use SnooperStopper with an encrypted Android 6 meanwhile?

Ok. Forget about this. I go back to the stock version. FPO 17.10.1 doesn’t even have a basic file manager any more. I want to have IT to work with not IT that keeps me working.

Edit 2:
Ok I might have a similar problem using stock version as well. But eventually it should save me time to switch back to stock version.

Unfortatelly not. I asked this:

in another topic as well, but it looks like that nobody (at least here in the Forum) has an answer yet.
I would like to encrypt my FP2 as well again (see the last few entries in this topic, beginning with the linked one), but I’m not sure if it is a good idea to use SnooperStopper again.

In an XMPP MUC some FP2 owners said that they don’t have any problem while using SnooperStopper. I will asked there again and post it here if I get any relevant info.

1 Like

Because I tried over and over again, different ways to get it encrypted with different passwords :wink:

Yes, but with the same password as the display pw. Sucks, but better than nothing.

So basic encryption should work fine, just setting a specific password for encryption only seems not to work on FPOOS.

1 Like

Actually, I found sort of a workaround.
Because this issue (and some others) annoyed me with FPOOS, I changed to Lineage OS.
There it is no problem to set a secure password; snooperstopper works at the community’s Lineage OS build :thumbsup: :slight_smile:

1 Like

Hm, ok up to now I don’t saw any reason to use Lineage as I don’t miss any feature with FPOOS (at least I will get security updates very quick which is more importent to me … ah and Xposed+XPrivacy is still working).

In addition Lineage is Android 7, right? So not sure if Android 6 is the problem or somehing within FPOOS.

I don’t know what would be the best way to proceed. I like to have a strong encryption password (somehthing diceware like) but typing it in everytime when I want to unlock the screen (screenlock is configured on power button hit as well as after 15 secs) will annoy me of course ;-).

While this is a bit off topic from the issue here: In my opinion, xprivacy is more or less unneccessary in LineageOS, because it includes a decent permission management.

The community is doing an amazing job. There are ca. 2 updates per month. I just installed the latest: patch-level 5. October 2017 :thumbsup:

7.1 :wink:

1 Like

Step 1: Install F-Droid.
Step 2: Via F-Droid install Amaze :wink: .

1 Like

I panicked a bit as after seven years I had just migrated back from linux os to windows 10 and no idea yet how to deal with adb and fastboot here. But after a bunch of hours I have a fresh FPO 17.10.1 now and would like to encrypt my phone again.

1 Like

Of course you are right. Only wanting to update my FPO all of a sudden without having any spare time I saw hours of work in front of me (also see my post above). So I was just angry and in panic.

Oh, on Windows it is super easy, just install Minimal ADB and Fastboot.

Yes, I did find out this meanwhile. Thank you anyway :slight_smile:

What can I do? I’m locked out of my FP2 the same way like Smojo reported.

What I did:

  • change encryption pw on stock FP OS Android 6.0 (current FP version) with SnooperStopper, getting the same error message
  • then I used terminal command “vdc cryptfs changepw password [newpw]”

Now on normal boot after typing the correct pw it says “wrong pw” but booting recovery (TWRP) and typing the pw it can succesfully decrypt

what should I do now? And what the heck is going on after all?

Any updates or resolution for this issue?

Fortunately I failed coming up with a current syntax for changepw (and looked here for an example):

root@FP2:/ # vdc cryptfs changepw pin OLDPIN password NEWPW                 
500 0 Usage: cryptfs changepw default|password|pin|pattern [currentpasswd] default|password|pin|pattern [newpasswd]

But after reading this, I´d rather not try to find the right syntax and use the screen lock pin for now. I´d rather put in the new camera module now again and call it a day with messing around with that new Fairphone 2 and FPOOS.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.