English

Encrypt phone with FairPhone Open OS

Trying to encrypt with Fairphone Open OS 17.02.
After starting the encryption an Android picture was shown, then the phone rebooted immediately and is now showing the flashing “LOADING” since approx. 3 hours …
I would guess that the phone is not encrypting, or is it?

Edit: Took the battery out, put it in again and started the phone, seems like nothing happened.

Edit:

Thanks @sil-van, that did the trick … now on to struggling with an unresponsive touchscreen …

Edit: Ok, checked this touchscreen thread and it seems my charger is causing the touchscreen issue … but only after encrypting the phone … This feels like an adventure game, I don’t know whether I like this gamification trend nowadays :slight_smile:

For some reason, the afforementionned commands does not work for me. No error, the logs show the commands are executed proprely. But when I reboot, system is still unencrypted (and relaunching the encryption setup does not work).

As I’m completely new to both android and fair phone, I’m not sure what I can do to achieve encryption on my system. It’s a FP2, running FairPhone Open OS 17.09.3 (I used the OTA build switcher from here.

At least the system is booting properly and my data still there. I just fill a bit naked with my data stored in clear :smiley:

This has worked for me a few days ago.

What do the logs say why the encryption doesn’t work?

I’ve got no log of any kind (at least nothing visible). The system simply reboot unencrypted.

Anyway, I’ve wiped the data partition from the phone, as suggestion in another post, and encryption worked. But I had to reconfigure everything from scratch, which is a bit sad :wink:

Okay, just for the sake of completeness:

You can capture the log by connecting your phone via USB (using WiFi probably won’t work as the connection gets lost in the reboot),
going to the settings and enabling the encryption.

The phone doesn’t completely reboot - the only part that is being restarted is the user interface. Your USB connection and both adb processes (the one on your phone and the one on your PC) will stay alive.

The first time, I tried to enable the encryption, I got the same error that someone posted here in this thread.
After resizing, everything went well for me.

1 Like

After my Android 6 upgrade was very time consuming (Upgrade + Encryption problem -> factory reset) I’m a bit afraid of encrypting my phone again.

The necessary steps you discuss here feels like another adventure.

  • Can I somehow check if the resize is really necessary?
  • Will I lose any settings or data when the resize will be performed?
  • Did anyone of you use SnooperStopper in addition (I would like to, but see my linked encryption problem after the upgrade)

It will only become an adventure if those steps don’t work :wink: .

You should make a backup of your stuff anyway before encrypting it all.
Remember you are using Android and have a look at the forum … Regardless of anybody telling you “worked fine for me” … there is a chance it might still not work fine for you, even if all prerequisites seem to be the same. On that note …

General note:

When I install or set up a computer (term includes smartphones) for the first time, I try to take the time and make a list of all the stuff I initially install, and all the settings I initially change. If I find something relevant later, I try to remember to update the list.
With the help of this list installing or setting up everything from scratch again if necessary still takes time and I try to avoid it with the help of backups, but it takes much less time than if I would have to think about every program to install and every setting to change all over again.

So prepare yourself for failure … this is a bit tedious, but there will be not much left to be afraid of afterwards :wink:

  • Make a list of your installed Apps
  • Go through the settings and make a list of every setting you remember to have changed or which seems somehow important to you
  • Backup your internal storage data (pictures, contacts, ringtones etc. …)
  • Make a TWRP backup of the OS (TWRP doesn’t backup internal storage anyway)

… then make sure you are not in a rush and have a go.

Hey @AnotherElk,

thanks for the fast reply.

You are probably right such a list might make sense to speed up all the necessary reinstall and reconfiguration steps. I will create one before I will try to encrypt my device.

At least I’m practiced in backup and recovery stuff, because of the last problems I had. ^^

So some addtional questions:

  • What is the correct amount 4K blocks? And in addition how to ensure that there is enough space in the encryption folder? I thought this is somehow equal for all FP2s?! (right now this procedure feels a bit hacky to me)
  • So you don’t use Snooperstopper? As my encryption password will probably be some kind of dice-ware near strong password I would really like to set a separarte simpler screen unlock password.

Today I will not going todo anything as I’m “on the rush” :wink:

I don’t know … I quickly tried to run the quoted e2fsck command on my phone to see whether its output gives a hint, but even with everything unmounted it just reported something is in use, perhaps because of the active encryption, no idea.
So I have no way of knowing whether the 4K block number given in the quoted resize2fs command does work for every Fairphone. I would try the TWRP “Resize” first and have a look whether all the data is still there and whether encryption works then … that would be nice :slight_smile: .

If that doesn’t work, I would of course try the more complicated stuff and confront losing my data and perhaps having to reinstall.

By the way … there is a nice bonus if you decide to go the 100% clean way, meaning to wipe everything, do the resize, install the OS from scratch and as soon as it successfully booted start the encryption … because there is almost no data at this point, encrypting will be lightning fast.
Of course you have to invest the time saved by that in reinstalling Apps and re-setting all those important settings :slight_smile: .

No, I can’t help with that, sorry.

Yes, for a long time already I use FP Open OS with encryption, pattern lock screen and a separate alphanumeric password which I installed with Snooper Stopper. I never had a problem with wrong partition size, I think.

Thanks @m4lvin for your reply.

So maybe I will just give it a try without resizing stuff in advance. (of course I will still take backups :wink: )

Can you have a short look to this thread: Encryption password does not work anymore for normal boot but for twrp (changed with snooperstopper)
I (as well as @freibadschwimmer ) ran into a problem while using Snooperstopper and I’m afraid that this will happen again. Not sure if this is a specific problem while resetting encryption password with Snooperstopper.

Eventually encryption password should only be set and changed via encryption menu of the OS. Snooperstopper should only be used to set a separate screen unlock password/pattern. Just a theory.

I saw the other thread before but don’t know how to help you because for me Snooperstopper did not generate this or any other problem.

I think it is the other way round: The separate password in SnooperStopper is for the encryption and the PIN or pattern for unlock is managed by android. I don’t have a separate encryption menu where I could change the encryption password.

Maybe first try encrypting and reboot a few times and also check that you can mount it in TWRP, and only after that install and use SnooperStopper?

Yes, you are right I mixed that up.

Ok, I will give it a try as soon as I have enough time for eventual troubleshooting. I will let you guys know the result.

For the record, I just got a brand new FP2. After the initial boot in the normal OS, I did the OTA install of FP Open. Then after making sure things worked, I launched the encryption process. Everything proceeded smoothly, and it’s asking me for a password before booting.

1 Like

Hello,
I got a new FP 2 and have the same problem after changing back from FP Open to the Google software. I am trying since days to solve the problem. Therefore, I read with interest a lot of info. Many thanks! But much to my regret the instruction to resize the data partition does not work.

As I am a Fairphone newcomer, sorry for the silly questions:

I would also like to test the other resizing as indicated above :
quote
e2fsck -y -f /dev/block/mmcblk0p20
resize2fs /dev/block/mmcblk0p20 6790139
unquote

But where in TWRP can i do it?

Thanks in anticipation.

Advanced -> Terminal

1 Like

It seemed to be successful because I got the info:
“The filesystem on /dev/block/mmcblk0p20 is now 6790139 blocks long”

After reboot the encryption, however, did not yet work.
Do I also have to go back to factory settings?
Via TWRP?
If via TWRP please give me a short info whether only the data partition is concerned.

Many thanks.

If you’re willing to start from scratch (you will lose your data on the phone), you might as well do it right and wipe the whole phone for a really clean new install …

Some findings about android device encryption:

  • A Factory data reset (via Settings --> Backup & reset) does not remove device encryption.
  • A clean way to remove device encryption: TWRP -> Wipe -> Format Data
  • When you have a TWRP-backup of an encrypted userdata partition, it is not possible to restore to an unencrypted userdata partition (boot loop). Workaround: 1. Factory data reset 2. Encrypt phone via (Settings -> Security) 3. Restore your TWRP-backup of userdata via TWRP.

Tested with twrp-3.1.1-1-fp2.img and LineageOS.

5 Likes

Many thanks to all for the info concerning failed encryption. I tried everything to get my phone encrypted because this is an essential factor for me since one of my phones was stolen some time ago.
I tried resizing, wiping, factory reset etc. but no success. Then I contacted Fairphone Support and also tried their advice.
Also no success! Frankly speaking I was frustrated and used the phone without encryption.

Today I found the solution occasionally. I had to buy a new micro SD card because I wanted to store my complete music collection on the card. I bought a 64 GB SanDisk card, formated it under Linux Ubuntu with FAT, inserted it and tried to encrypt.
It worked!!! My Open Fairphone is now encrypted. I do not know why it works, but I am completely happy!

1 Like