English

System near applications seem to be not able to perform storage operations

Since I upgraded my FP2 to Fairphone Open 17.09.3 (no GApps nor microG, Xposed+XPrivacy) not everything is working as expected.
(eventually I should say that the way to Android 6 was a bit arduous: Upgrade + Encryption problem -> factory reset )

As most things I use day by day works fine (Browsing, Install Apps via F-Droid, Messaging with Conversations or Signal, tacking app+data backup with oandbackup, backups via TWRP to external SD) I had some time to observe the situation.

It seems to be somehow related to system apps/functionalities and especially when they have to access the storage of the phone. Of course there is storage available more than 15GB free internal and 90GB on the external SD card.
Apps/functionality/dialog examples: Camera, Gallery, Downloads, Package Installer, “Recent” dialog (whenever it is shown up e.g. access external sd via Amaze)

Some examples of these tasks which are related to the problem:

  • Taking a screenshot - e.g. simply from the home-screen --> Volume down + Power button (Notification message: “Couldn’t capture Screenshot - Can’t take screenshot due to limited storage space, or it isn’t allowed by the app or your organization”)
  • Using the default Camera App (is showing “Insert an SD card before using the camera.”)
  • Most operations within Gallery App (Sharing a picture, click on edit pencil when a picture is opened -> leads to pop up message “Cannot load the image” )
  • Install an APK via Package Manager (After clicking on Install it shows: App not installed. - The package appears to be corrupt.)
  • Download an APK via Yalp (Download icon is shown only very short in the status bar. After some time a Notification message: " Unknown file storage error" is shown)
  • Save a new note in the App Omni Notes FOSS (phone hangs for a short while and reboots after that)

There might be more issues. At the end I’m pretty sure that all of them have the same root cause.
-> Something prevents the storage operations.

EDIT (20170925):


One thing I forgot to mention is that I see Apps under Data Usage which are just named by five-digit number.
I don’t know if this has the same root-cause as the other problems but at least this looks somehow strange that there seems to be some kind of name resolving problem for some apps

I can currently use the phone as I use an alternative for nearly all default apps, but it is really annoying e.g. that I cannot:

  • take screenshots
  • use the external SD correctly
  • use Yalp
  • add notes to Omni Notes FOSS

Thanks for any idea how I can resolve this or at least how to come closer to the root cause.

1 Like

One thing which came in to my mind today:
I flashed the last version of Fairphone Open (fp2-sibon-17.09.3-manual-userdebug.zip) via fastboot.

I remember that I was a bit confused about the file privileges (and ownership) of the unzipped files.
As I can see here:


there is nothing special todo before flashing. Even there is one reply which indicates that a chmod has to be performed in advanced before executing the flash*.sh.

I remember I did something like that as well, but I’m not sure if I changed the privileges of all files.
Could it be that the problems I described have something todo with a wrong privileges (and eventually also ownership) of the unzipped manual-userdebug.zip files and folders?

Just want to reply to this thread as I resolved it on my own.

Unfortunately the only way was a Full-Wipe (Dalvik / ART Cache, System, Cache, Data). Of course a backup of your data should be done in advance. (I used oandbackup, contacts+calender were synced via DavDroid with my mail-provider, you should save your pictures and other file which don’t belong to a specific app separately). So after the wipe I flashed the Fairphone Open 17.09.3 via fastboot and setup/recovered all my stuff step by step / from scratch. Annoying and time consuming, but at least everything is fine now again. Good to know that all the restore and sync stuff worked as expected.

I assume that most problems had something todo with the Snooperstopper issue I already linked in my first post.

Solving this one I used a TWRP-backup of my encrypted phone after I had to wipe the system completely as well (I thought this is ok as TWRP de-cryptes the device directly after the start and before performing a backup). Unfortunately as you could read not everything worked after that (and I recognized not everything directly). I think most of the issues were related to that. Eventually the Yalp Store problem was just a missing rule for the Downloader in Afwall+.

4 Likes

Just want to say, that I had the same problems with FPOOS 17.10, coming from FPOOS 17.04 and thus switching from Android 5 to 6.
And I didn’t use Snooperstopper. The only thing I had to flash in addition to the ROM was Xposed to use Xprivacy.

Now after wiping and spending days to also install everything again from scratch on Lineage OS, I hope the only problems to deal with after updates will be easy to solve ones, as mentioned here today.
Of course it is helpful for this, that I won’t use Xposed anymore on Lineage OS as Xprivacy is not available and also not that much needed there as on FPOOS. And if this big update problem on FPOOS has nothing to do with Xposed and Xprivacy, it probably just was something with the permissions and the big step from Android 5 to 6.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.