Can't access Pictures on SD card via USB

Since about a month I can’t acess my pictures on the SD card anymore.
I use Open Camera and I know in which folder they would be stored.
When I access to the FP2 via USB (be it PTP or MTP), Windows does as if the folder wouldn’t exist.
But when I search the folders via the phone, they seem to be just quietly lying around where they are supposed to be. There seems to be a permission issue.
So please help: How can I get access to this folder through windows?

I have OS 6.0.1
The SD card is set as part of internal storage
The folder is /storage/emulated/0/DCIM/OpenCamera

Problem is, that you use the SD-card as internal storage.
This topic has already been addressed in this thread:

I saw that one! But in order to change the setting back I have to get access to the photos somehow!
Don’t want to format without having saved the pictures before!

Maybe you can save the pictures using MyPhone Explorer.
To be able to use this software, USB debugging has to be enabled on the phone.
Here’s how to enable this if necessary:

When connect on USB, the phone show “USB Charge”. You open that message, and you can choice another method, transfer files via MPT for windows.
Maybe must first add developper options, i’am not sure…

Thanks for your help.
I tryed to connect to the phone through MyPhone Explorer and failed.
(USB Debugging mode on, connection mode charging, ADB-Driver installed, what else can I do?)

Still at the same point. Can’t beleive its so difficult to access photos on my phone. Does anyone have another idea?
And I repeat: It doesn’t show the folder in either mode: MTP as well as PTP!

Failed how? Error message? Screenshot?

I’m using MyPhoneExplorer myself, never had such a problem … I didn’t define my SD card as internal storage though.

(USB Debugging mode on, connection mode charging, ADB-Driver installed, what else can I do?)

MyPhoneExplorer doesn’t bother with the USB mode set in the notfications, so on that end everything seems fine to me.

The MyPhone Explorer says he can’t connect. And there’s not much more I can do than follow the points which are mentioned to be necessary in order to connect to the phone. I did and it can’t connect.

Ok. If you start the “MyPhoneExplorer Client” App on your phone, it should nest itself in the notifications, saying something like “Waiting for connection” … is this the case?

If so, and connecting via USB fails, you could change the way MyPhoneExplorer connects to the phone to Wifi (it’s faster than USB anyway) or Bluetooth (if you use a notebook capable of this or have a PC dongle) to check whether it is a USB-only problem.
Start MyPhoneExplorer on your PC - File - Settings - Connection (or something like that, sorry, German locale).

I guess, I remember, that you should not select any option or in other words unselect all options.
Charging only did not work for me as well.
I might be wrong, but it’s worth a try.

Hello, Did you try with another USB cable? Sometime is the material who mistake, only…

I Can’t unselect all options. There is always at least one selected.

And no, it’s not the USB-Cable, as it sees a lot of other files.

I’m actually quite desperate! How can it be so difficult to access to files which are visibly on my phone and of which I even know the path?
I’m uploading everything on Dropbox (quite some work), but there are some videos I’m very fond of, which are too large to be uploaded anywhere. I’ve got the choice: Try for the seventieth time to access these files through USB or delete them while reconverting the SD-Card into external storage.
So thanks in advance to anyone who has any idea on what could be the problem and it’s solution.
(Tried MyPhoneExplorer again and again, but it doesn’t want to connect to my phone)

I am really sorry, I remember, that I had troubles connecting my FP2 to MyPhoneExplorer myself, but I can’t recall how I overcame the obstacles.
My FP2 is connected in charging only mode (Debug Mode on). I really wonder if it might be the formatting as internal storage.
Have you tried connecting via WiFi already? I guess you did.
Have you tried sending the file via e-mail or bluetooth as a workaround?

In fact, i also meet the same trouble since the last update. So i decide to change the OpenOS for the LineageOS. Everything is well now, without losing any datas on the SDCard…

I just experienced a strange problem that might be related to this one.

Yesterday I finally updated to Android 6.

Just to check if everything works, I took some photos with Open Camera, they were stored in the folder on my SD card (external storage) where all my pictures have always been stored and everything seemed fine.

Today I recieved my new camera modules. Before changing them, I took some pictures with the old modules and afterwards with the new ones to compare them.

But when I wanted to transfer the pictures to my Windows 7 PC via MTP, I noticed that all photos taken after the update to Marshmellow are shown as 0 kb.

The older photos taken with Android 5 are OK, with their real file size and I can open or copy them in the Windows Explorer, but not the new ones.

But the new pictures do really exist in this folder on the SD card and on my FP2 I can copy them to the internal storage and access them from there through the Windows Explorer.

I can also copy them directly from the external SD card to the PC via MyPhoneExplorer.

What could be the problem???

I found the solution (at least to my problem with the 0 kb files) thanks to this page.

Go to Settings --> Apps, choose in the three dot menu “Show system”, and delete data and cache for the apps “External Storage” and “Media Storage”. Then reboot the phone.

The file index will be rebuild and everything works fine again :slight_smile:

Edit: Permissions to store files on the SD card or to edit them need to be given again to the camera and gallery apps.


Thanks! I came here because of the same kind of problem, after the last update I could not find the files on my phone anymore, but this was the solution :slight_smile:

1 Like

Thanks for the advice.
I deleted the cashe as you discribed. After that I didn’t see even the one (useless) file anymore which was supposed to be around the path where the photos are.

After a last try to connect my phone to my computer via Myphone Explorer I lost my patience. I uploaded every bloody single photo on dropbox and formated the sd card as external storage.

Now I have a new problem: Open Camera doesn’t allow me to choose a path which will end up on the external storage. It’s nice that any path I chose I find the picture through USB directly. But I have bought an expensive 60 GB SD-Card and it remains empty. It’s driving me mad!