USB debugging is permanently greyed out

The USB debugging option is permanently greyed out, claiming that the ‘Device is in charging mode’, even though the phone is not connected to a USB cable.
I’ve tried a restart, but that didn’t help.
Anything I am missing here?

connect it to a PC and you can uncheck the charge-mode

Spielmops

Not sure what you mean exactly. I tried following your suggestion by connecting the FP2 to a macbook, but there was still no obvious way to turn of charge mode

When you connect your phone to the macbook, swipe down the notification bar. In the upper left corner you should then have a notification to change the USB options.

Well, as posted in the other thread: this might not work for everybody… including me. I can not change my USB options…

Edit: Ok, I could change them after I connected to a PC and it showed me the USB-Connection “drop down menu” after connecting. But that was a different PC; a solution for those not having easy access to a 2nd PC with a different OS…

If you can’t change the USB options, then either the USB port fails or your USB cable isn’t a data cable.
So if you use the same USB cable on both computers, try then another USB post on your computer.

I want to connect my labtop and my Fairphone 2 with MyPhone Explorer and I can’t.
It appears that I can’t enable the debugging USB, in the developper menu.The option satys in grey, so I can change it. Does someone ase a solution?

See above - when connected via USB (using a USB data cable) uncheck all the options in the USB-connection drop down menu.

2 Likes

Are you sure the Developper Options are enabled? The switch is on the very top of the menu.

Thank you Irina.yes it is enabled.Actually I got the answer with the previous advise.It works now.merci beaucoup.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.