Camera "running out of space" when only 33% used, and storage bugs?

I started writing this post asking for help, I think I now have a partial solution but posting here in case anyone has a better one.

When I open the camera app I get an error message “You are running out of space. Change the quality setting or delete some images or other files.” This prevents me taking a photo. It has been like this for a few months.

I have looked at the other threads (here, here, here) about storage issues but in all these, it has turned out that the phone only has about 5GB free. I am not sure if that’s the case for me - the phone is giving me conflicting information.

When I open ‘Storage’ in Settings, the top level summary page says I have used 59.46GB of 64.00GB. However, when I click on ‘Internal Shared Storage’ it says that I am only using 64.21GB of 192 GB, i.e. 33%. So my phone seems confused about how much storage it has, and how much it is using.

Also, I can get around the camera storage error message by taking photos in other apps. I still have no problems taking photos in WhatsApp, Instagram, etc. Which makes me wonder if the storage issue that the camera app is reporting is real or a bug.

Important context: I do have a 128 GB SD card. When I inserted it (years ago) I tried to change the settings so that photos would be saved to the SD card rather than internal storage. However, this broke several of the apps, so I reversed this change, and since then the SD has just been sitting in the phone but not used. I had been meaning to sort it out at some point but hadn’t got round to it. I had not made any changes to the SD card around the time that I started getting the camera app storage error message (a few months ago). Might it be that the presence of the SD card has confused my phone about how much storage it has?

Software is all up to date, I have tried rebooting the phone, clearing the the camera cache and ejecting and re-adding the SD card, none of which helps.

Screenshots attached:

Partial solution

Since 192 GB = 64 + 128, I figured the phone was getting confused about whether the SD card was internal storage or not. To test the theory I reformatted the SD card as portable storage (in Settings, Storage, SD card) then manually moved over old photos from both the camera folder and other folders with lots of images (e.g. WhatsApp). I had seen this suggested on some of the other threads.

However, this is annoyingly labour-intensive because it’s a manual process that I have to do for each folder in turn. I would prefer to just have the camera save to somewhere with enough space as standard. Also, the manual moving process is buggy - every time I’ve tried to Select All and move all the files in the DCIM/Camera folder it’s only taken some of them and I’ve had to go back and repeat the process 3 or 4 times to get them all. I’ve been at this for an hour now and I’ve still only managed to move about 10GB of the 20GB of photos on my phone. Which means that I am still at ~77% usage on my internal storage.

Also - a few months ago, my first attempt to fix this problem was to use the Storage Manager feature that removes photos and videos more than 90 days old if they are backed up on Google Photos. So this setting has been turned on on my phone for months, but doesn’t seem to be doing anything.

Any ideas for how to deal with this more efficiently? Thank you!

[NOTE: The 3 screenshots above are from before I tried this partial solution. This is a screenshot of the Storage page after.]

At the risk of sounding like a broken record to you – I think it’s still about the formatting of the SD card.

You said you actually switched the card from internal to portable. I remember that others who did so often had the “old” internally formatted SD card remaining to be shown in the Settings > Storage list like a hollow artefact/leftover (in addition to the active SD card formatted as portable).

If that is the case after switching from internal to portable, I would recommend to (virtually) eject the old entry from the list, reboot and see if things wiggle in.


Sometimes the SD card, once it has been formatted as Internal still shows, although in my case as ‘Not Inserted’

And my camera apps do save to the Portable SD card

Regarding moving older images: Usually when reformatting an SD from Internal to Portable there is an option to move files ‘en masse’

Otherwise you may be able to use a PC : Insert the SD card in the PC use ADB to download all the images to the Sd card on the PC in one go. Then re-insert the SD in the phone.

Don’t use google so I’m of no help there

1 Like

Thanks for suggesting, but I had already ejected, re-added and then re-formatted as portable. I only have one listing for the SD card on the Storage page.


But it doesn’t look like that, your screenshot is showing no portable space at all, just shared internal space.

As Incanus has pointed out.

If the screenshot you provide is after the reformat then it doesn’t make sense as it shows it as Internal.

Hopefully you meant that since then you have reformatted as Portable ??

The screenshots are from before I reformatted the SD card as portable. My post is written in chronological order so the photos are showing the status at that point in my notes. To clarify I have now added an ‘after’ screenshot at the end as well.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.