Bootloader Unlocking Code for Fairphone 3 not working

I’ve had a similar problem trying to unlock an FP3+. Neither code generated by either the official for the alternative web site worked, but I found fastboot oem 8901_unlock works, which makes enabling unlocking on the phone a bit redundant.


This command is not being officially communicated, it was found by clever examination. It looks to me like this mainly exists as a tool for support and repair folks for the same situations in which it helps users here now.


As I just got a new F3+ I am trying to in stall /e/ os in F3+, in Developer Option I have been trying to unlock the OEM which call for a code.
After getting the IMEI (slot 1) number and the Serial number, went to get the code at and
One after another none of these codes worked, each time at the bottom of the screen a small message pops up “Inner Unknown failure” while the another message says “Processing”

With ADB adb reboot bootloader the phone screen menu says “DEVICE STATE - locked”
Got the latest F3+ buitd 3.A.0054. and thoroughly imput the IMEI (slot 1) and the SN without typo.
Fastboot oem unlock command does not work either.
Did a factory reset still doesn’t work !
Please help!

1 Like

Hello !

I tried to unlock the F3+ Bootlader by following the procedure described in the link above :

I received a code but my keyboard displays numbers only. I wrote the code in text message, copied it and pasted, but I have a message : wrong password…
The letters a deleted to keep only the numbers when I paste the code

Can you help me please ?

Best regards,

Yes, indeed. We switched the implementation with Android 10. The code retrieved from the website only works with Android 10 and up.


Franz, Unfortunately it does not seem to work on the Fairphone 3+ with Android 10 (Build #8901.3.A.0054). Support Request #397991

Pasting select logs from adb logcat below the line. Please replace the items in CAPITAL with the relevant values:

11-17 16:57:57.113  8036  8036 I OemUnlockPreferenceController: mVerifier == null ? true
11-17 16:57:57.113  8036  8036 I OemUnlockPreferenceController: invoke mVerifier.queryVerifyResult()----password=UNLOCK_CODE
11-17 16:57:57.116  8036  8036 D OemLockVerifier: queryVerifyResultGet--targetUrl=
11-17 16:57:57.117  8036 11102 D OemLockVerifier: queryVerifyResultGet--oem Lock verifier Start
11-17 16:57:57.117  8036 11102 D OemLockVerifier: acquireWakeLock
11-17 16:57:57.118  8036 11102 D OemLockVerifier: wakeLock acquire.
11-17 16:57:57.198  2141  2141 E PhoneInterfaceManager: [PhoneIntfMgr] getAllowedCarriers: CommandException: REQUEST_NOT_SUPPORTED
11-17 16:57:57.208  2141  2141 E PhoneInterfaceManager: [PhoneIntfMgr] getAllowedCarriers: CommandException: REQUEST_NOT_SUPPORTED
11-17 16:57:57.712  8036 11102 D OemLockVerifier: WARNING: Hostname is not matched for cert.
11-17 16:57:57.936  8036 11102 D OemLockVerifier: queryVerifyResultGet()--resp_code1=404
11-17 16:57:57.936  8036 11102 D OemLockVerifier: queryVerifyResultGet()--verify_code1=
11-17 16:57:57.936  8036 11102 I OemUnlockPreferenceController: Verify oem lock Result : 404,msg: URL not found

Best Regards,

Hi @rohan, that’s strange. The unlocking seems to fail because the request returns the status 404 Not Found. The most likely problem is that the unlock code is wrong. Is it possible that you filled in an old unlock code? It is important to know that any new request for an unlock code invalidates the previous unlock codes.

So the order of the steps is relevant:

  1. Generate a new code from the website
  2. Try unlocking with the code that you just generated.

When doing that and if fails again, can you please verify that the logs show the correct IMEI, serial number, and unlock code?

One other strange thing is the message in your logs OemLockVerifier: WARNING: Hostname is not matched for cert. The certificate should be for (the current one has fingerprint SHA-256 93:CE:7B:13:80:F8:A1:0F:2A:44:10:EF:43:7E:89:88:54:CD:09:58:73:A1:C5:51:DC:82:B0:29:D5:73:E0:CE). Is it possible that you are using a proxy or anything that would strip the certificate?

Edit: Clarified that the code must be generated from the website


Have you managed to unlock it by now?
This error might appear when the phone is not connected to the internet while unlocking. See Problem OEM unlocking "Inner unknown failure"


Yes after connecting to the Internet the code worked and the OEM was unlocked. Thank you.


Thanks @jftr. In my case I noticed from the logs that the last digit of IMEI1 was removed, supposedly an issue witnessed with my provider, whether it be Fairphone or any other device. Bizarre but true. Removed the SIM card, post which the device started reporting all of the 16 digts and the un-lock worked. Thank you for your help! Cheers,


Whaaaat? This is crazy and I don’t know how it happened. However, I am happy that you solved it.

19 posts were split to a new topic: Problems with OEM unlock

Thanks! the fairphone website version never works for me FP3 but the other one does.

I’m surprised that the guide doesn’t give the alternative right there as it is an known issue :thinking:

Hello Kollimatorn,
I agree it is surprising as many people will have the same issue, quite a waste of time for everyone, luckily if you have the time the forums work fairly well . Cheers.

Hello everyone.

I have (almost) the same problem as paul-antoine, I’m trying to install /e/OS on my FP3 with the Easy Installer.

I am at the “unlocking bootloader code” step, and after getting the code at FP3 'verify code' generator (the Fairphone site dosen’t work for me to get the code), I’m blocked with the same message “Processing…”.

[Edit: The Fairphone site gaves me one finally, but it takes several time to show it… and still change nothing, same “Processing…” message]

I read all the topics, my phone is connected to internet by Wi-Fi but it’s still blocked for now.

Have you got any news about that problem, please ?

Yea same problem here. I made a new post about it since it seems to be a slightly different problem.


Ok, I contacted the support about that, maybe they will have a solution.

1 Like

So I assume you also read this topic…

…and it neither works this time?

Sorry, english is not my native language.
I meant, all the messages of this topic.

The topic you mentioned will not help me, because I can get a bootloader code, it’s just on my phone the process is not responding after the message “Processing…”.
I tried, just for testing, random codes and it is the same message each time.

I will try again later during this week.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.