Auto-correct / suggestion issue with Google Keyboard

Hello there!

I recently got a FP1U running on Kola Nut 1.8.5. So far it works like a charm and I really love it!
So far I only encountered one issue and that is regarding the out-of-the-box keyboard, the Google Keyboard.

It gives me from time to time suggestions like shown in the attached picture. Even though the intended word which I was going to write is in the smaller, black band below, I am forced to select a word from the big grey box. Using the back button closes the entire keyboard forcing me to bring it up again, still left with a wrong word.

I’ve already fiddled around with a lot of the keyboard settings including auto-correct (is off) as suggestions etc. I just can’t find a fix for this. Any suggestions? Thanks in advance!


Just press “space” ( :de: Leertaste). The word which is written in bold letters, is the one, which will be placed in your text.


Hey @UncleBAZINGA: I am faced and annoyed by the same behaviour at my FP. I encountered this since the first usage more than one year ago. I did not try to understand or avoid it until now.

Furthermore I am not familar, after which interaction provokes the “Press here again to save the word” message…and I never noticed that it worked to save the word…

But luckily the first problem comes very seldom, interestingly it is not that reproducibly. If just delete the last letters and write again the same word - sometime it do NOT happen…strange…

@Stefan: OK, space works for the word in the middle…but if I want to choose the word at the left? It is just not allowed to tap on! That’s the point…


I can tap on the words on the left and right to choose them.

also when the big grey window pops up??? (Which I cannot reproduce now…)

Sometimes I can, sometimes the popup with 15 further suggestions comes up. The keyboard’s auto correct generally seems a bit buggy…

Anyways: we should keep things separate: @Paulkreuzer and I don’t have Google Apps installed and therefore use the AOSP keyboard. (Popup here is blue BTW.)

@therob and @UncleBAZINGA apparently use the Google keyboard which appears after installing Google Apps.

1 Like

@Stefan is right, we are using the AOSP keyboard which is the real

since the FP thankfully doesn’t come with gapps preinstalled. :smiley:

I never got the popup without tapping the word in the middle which is supposed to trigger the popup, so nothing buggy here for me.
But installing Gapps doesn’t overwrite the AOSP keyboard does it? You should be able to switch to it in the “language & input” settings.


Maybe I misconceived that the popup comes up, when tapping the outer words. My fault!

  • hm…I think the other way round it is correct: you cannot tap on the outer words, when the grey popup has appeared (what in my case I cannot provoke intentianally…because I don’t know why and when it pops up)…am I right, @UncleBAZINGA?

  • And yes: I use the standard Google Keyboard

  • And no: I can not choose another keyboard neither in settings nor by long pressing space (just speech and my other two languages available) … but no problem, in general I am fine with the google keyboard…

Oh now I know what you mean with the “Press here again to save the word” thingy.
For me usually the popup appears and not that thingy but now I played around a bit a normal tap really randomly results in the one or the other. A long tap however always starts the popup.

So here are the “rules” for the AOSP keyboard:

  • You get 3 suggerstions, the one in the middle is most likely, you accept it by tapping space
  • You can tap one of the other two suggestions to accept them
  • If you want more suggestions long-tap the word in the middle (the button for the popup is symbolized by the “…” underneath the primary suggestion)
  • Once the pupup is there you can tap the button again to save the word you actually put in.
  • To close the popup erase/retype the last letter.

Does the Google keyboard show different behavior in one of these points?


First of all thanks to all for your feedback!

@therob: yes, you’re right, I can fully confirm what you are describing.

So it seems that this is somehow by design and how this Google keyboard should work. Even though I find it very annoying and contra productive… I’m fine with the keyboard in general, but this one thing can be a showstopper. Sometimes the popup appears for every second word I type.

There is a new official Google keyboard in the Play Store. It seems to be the one from Android 4.4, but is backwards compatible. Maybe I try this or Swype/SwiftKey, but I’m vey concerned about privacy. Not that the standard Google keyboard would be a better choice.

Are there any good working keyboards with swype-like functionality out there for Android which aren’t collecting and sending data etc.?

So it actually pops up on its own, without tapping the middle suggestion? I don’t think that can be intended behavior.
Or does it only automatically popup if you pause writing for a moment?

I don’t think so. Read here.

Btw, did you read my post right above yours? We posted at about the same time.

1 Like

You are the savior of (my) day, sir! :smile:
The Google keyboard works exactly the same as you have described. When I press longer on the word with the three dots below it, the popup of my screenshot appears!

I think my issue is that the touchscreen of my FP1U often requires are stronger and/or longer press to recognize the touch. It doesn’t feel broken to me, just different to touchscreens which I was used to before. That’s why I often got the popup with word suggestions.

Once again thank you very much!

Do you think, my touchscreen behaves normal. Is it the same with other FP1Us?


Glad we worked it out. :smiley:

Some people reported different problems with FP touchscreens. You could do the touchscreen test to find out if something is really wrong and if it is you should contact support.

1 Like

Thanks again, I will do the touchscreen test and if there are some issues, I’ll contact the Fairphone support team.
What a great community the Fairphone has. Awesome :smiley:


It’s not random: If you write a word that is not in your dictionary yet, short-press and you will be asked to save it. Long press and the popup will appear.

Maybe adjusting the reaction time in Settings > Accessibility > Reaction Time Touch/Hold results in a better experience for you?

Thanks @Stefan, but the reaction time already is set to “short/fast”.

I use MessagEase keyboard which I found very useful and fast, moreover by installing XPosed Framework and XPrivacy module you can choose the permissions to grant to any app, keyboards included :wink: you can find more information on security here


As reported above sometimes I am also confused about the keyboard behaviour of the FP1/Android … but I get used to it.
Just if anybody can me explain, why the auto suggestions give me different guesses when I use the phone in the horizontal or in the vetical orientation…Strange behaviour, isn’t it?

See yourself:



Hi everyone, I am new here, and have to say I am finding the FP1U keyboard a nightmare! Can anyone help it is making it so slow for me to text! It just writes utter nonsense and clearly my fingers are too large for the keyboard or something!! Help!