English

6.0 permissions: Screen Overlay detected - unable to change app permission bug

When trying to change permission settings for apps such as Malwarebytes Anti-Malware or Camera ZOOM FX, you’ll be met with the message seen here:

“Screen overlay detected - To change this permission setting you first have to turn off the screen overlay from Settings > Apps”

However, even if you do that you’ll get the same error/message when trying to change permissions again. This seems to be an error encountered on many different phones.
I’ve not yet tried the workarounds as suggested places such as:

4 Likes

Hi,
I just upgraded my FP2 to the new Android version and I can’t view images on Whatsapp.When I click on them, I see a message that Whatsapp needs to access photos, media and files and to go to Settings and enable that, but when I do, I can’t enable Storage.
I’m then taken to the Draw over other apps menu that I can’t enable for Whatsapp either.
I’ve been looking in the manuals/forum to no avail, can someone help, please?
Thanks!

Had a similar thing with RocketPlayer myself - you need to basically turn off ‘Draw over other apps’ for every app that you can (no option with built-in apps), then give it permission to access storage, and then you can switch ‘Draw over other apps’ back on for whichever apps you like (floating ones will need it).

Hi,
Thanks for your answer, how do I turn off the ‘Draw over other apps’ though? I don’t seem to be able to do so.

apps like Velis auto brightness control the screen brightness with an overlay.
Google recognized this as a security risk as some malware might draw an overlay over a question to change what it says or what the buttons say.
As such, while an overlay is active, you can’t give any answer to system questions like permission requests and other choices.

1 Like

You can’t do it for all apps at once - it’s laborious, but you need to go into the permissions settings, find the “Draw over other apps” settings and then go into each app and uncheck that toggle.

Thanks again, the problem is that I can’t: when I go into App permissions and Storage, I’m prompted to go to Settings > Apps, I go there and then I find Whatsapp. I get to a screen with ‘Draw over other apps’ but I can’t change this setting.

Hi QED, that was very helpful, thank you!

You’re welcome :slight_smile:

1 Like

Same problem here. After multiples tries I chose to go to the three points and click “Reset app preferences”… and Whatsapp disappeared from the list. Anyway, same problem with other apps that stayed in the list like Skype. In this case I can change and turning off (and stay off) but anyway it doesn’t allow me to give permissions. Any help? It’s frustrating.

Same problem here. I tried “reset app preferences” on the “draw over apps” screen and now other apps don’t work.

Well, after a lot of trying I think I fixed it. In my case I think that what worked was that I have some problems with the app “Google Play Services” but after updating this (and others) app in Google Play Store I was able to change the permissions. But I realized that with this update it only let you power off yor phone when you push the button, no reboot or Airplane mode…

Well, it worked only partially. I was able to give permissions to Whatsapp and Skype (maybe other, I don’t remember) but now I can’t give permission to Twitter or other apps. Any idea?

On my phone I finally found out an app was disturbing my efforts to change the Permission settings: CleanMaster. When I removed that app (temporarily) , I could make the changes that were needed. Maybe you also have a cleaning app or antivirus app that is interfering?

4 Likes

Erna you’ve nailed it! I had a blue light filter app that was interfering. I desinstalled it and now it works. Thanks so much!

5 Likes

You’re welcome! I’m glad you found the problem :slight_smile:

this is a #wiki post

List of Apps that can cause this problem (even with permission denied):

  • ESFile Explorer
  • Blue Light Filter/Night Light/Brightness controller Apps, e.g.:
  • Velis auto brightness control
  • Clean Master
5 Likes

Culprit Confirmed: ESFile Explorer
Just deactivating the “Draw over other apps” function was not enough. Force Stopping did help.

Thanks for the hint!

2 Likes

thank you, ESFile Explorer was the problem in my case.
Turning it off did allow me to set camera permission to my app

1 Like

Thanks from Brasil Ema! I also had a blue light filter app. Now everything works just fine!