Windows PC does not recognize Fairphone 3 (Android 10)


this is my first post and I hope someone can help me with a problem.

Since the update of my Fairphone 3 to Android 10 the Windows 10 PC does not recognize the Fairphone anymore.
Data transfer mode does not show the Fairphone in the Windows Explorer (PTP mode is working, DCIM folder and contained pictures show up in Windows Explorer).
Connection is via a USB-C to USB-C or USB-C to USB-A cable on different USB ports at the PC. Both does not work.

Do you have any hint for me?

Thank you,


Welcome to the forum. Here are my results upon FP3 Android 10 Build number 8901.3A.0045.2020095

Do you get a chime when connecting to Windows PC and are you using USB 2 or 3 here? Have you tried selecting “No data transfer” disconnect cable and try reconnecting? Are you using cable you use to charge FP3 normally or a different one? Using USB-A to USB-C upon my laptop.

1 Like

Hello aspergerguy,
thank you for your answer.

I have the same Android 10 build version and also use the File transfer setting. But I don’t see the FP3 folder. I do get a chime and also tried disconnect/reconnect. All with no success.
I tried both cables, a USB-C to USB-C with USB 3 and the original Fairphone cable USB-A to USB-C, makes no difference.

On another thread (FP 3+ doesn't show files after connected to PC), the problem was with the PC. Could you test with another Windows PC?

Are you sure the cables you tried are data cables? You can for example test with another device whether it works.

It is an indication that a connection to the PC has been established, so it is a software related issue.

1 Like

MTP (the “File transfer” mode) can be somewhat flimsy on the computer side.
Here’s a generic repair you could try …


Hi Alex,
Yes, I can try another PC tomorrow.
The cables are ok, it already worked before Android 10. One of them is the original Fairphone cable that could be ordered with the Fairphone 3.

1 Like

I checked with another PC and it is working, the Fairphone is recognized in File transfer mode. So I will have a deeper look at my PC at home in the evening.

Thanks to all for now.



after a lot of trial and error I made it today. The Fairphone 3 is shown again in Windows Explorer in File Transfer Mode.
I am not 100% sure how I came there but I try to explain.
I did all the things AnotherElk suggested, uninstalled SDK, MTP and ADB devices. But after reboot ADB was shown again. I did this several times in different order with reboot of PC and Fairphone. But no success.
Today I attached my Fairphone 1 to the PC to check if it works. After this, one of the ADB entries in the Device Manager was activated (not greyed out) and it offered the option (beside uninstall driver) to delete the driver software from the computer. I did this, rebooted and … success. When attaching the Fairphone 3 new drivers were installed and it showed up in Windows Explorer.
In the Device Manager now I see the Fairphone in Portable devices and the ADB interface under USB devices.
Hope this perhaps helps other users to solve such a problem.
Thank very much again,


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.