Windows 10 don't recognize my Fairphone3 via USB

Hello,
I’m trying to connect via USB my FP3 to my pc (Windows 10 OS), but the system says me “unrecognized usb device”.
I already activate debug USB option form developer menu and changed the USB transfer option to PTP.

Anyone knows how to fix this issue? Thanks!

First, make sure you use a data cable, there are USB cables out there only for charging, and they will not work for data.

Second, I guess most people would want to connect via MTP to see their files.
When I had trouble with MTP on Windows 10, I did the following to get old phone or MTP stuff in the system out of the way …

  • Disconnected the phone from the computer.
  • In Control Panel - Programs and Features:
    Uninstalled everything with “MTP” or “ADB” in its name.
  • Rebooted Windows.
  • In Control Panel - Device Manager:
    Enabled View - Show hidden devices, and then uninstalled every possible ADB, MTP and smartphone device, hidden or not.
  • Rebooted Windows.
  • Connected the phone again, Windows then needed a moment to set up MTP again automatically and prompted a success message afterwards.
4 Likes

If that doesn’t help, you should also try another USB-C cable and connect your phone through another USB-port on your computer.

Have you tried everything described here:

? Good luck!

2 Likes

The problem was the cable, thank you! I didn’t know there was cable only for charging.
Thank you all for your precious help!

5 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Hello there,

I’d like to connect my FP3 with my laptop via USB. My laptop (Win10 operating system) says that it doesn’t recognize the Phone and that it doesn’t work as intended. So I installed the latest update, rebooted the phone and I get the same error. I also used different cables. Same result.

Is there any solution to this problem besides buying a new bottom module or a factory reset?

Tried the stuff above. I still get the same error.
Factory reset didn’t work.

All of the above ??

There is an option to install Features update, did you do that on Windows, also see

This really sounds like driver trouble, how about this …

And to rule out something else …

2 Likes

Is it possible that a loose contact might be the problem? The phone had issues with charging during the last days and I was able to connect another phone to the computer without a problem