English

FP3 via USB doesn't show as drive on Windows 7

Hi all,

this sounds similar to Windows 10 don't recognize my Fairphone3 via USB however it’s a different issue.

I finally got around starting to set up my FP3 - or at least I thought so…my laptop, which is running Windows 7 Pro, successfully installed drivers when I first connected the phone via USB cable (the USB cable from the Fairphone shop, by the way), but nothing shows up in the explorer. When I check under “Devices and Printers”, it’s listed under the category “Not specified” as “FP3”, with the properties showing it’s in device category “Unknown”. The driver Windows installed automatically is called “Google Nexus ADB Interface”, and it further says “This devices works without issues.” (or whatever the equivalent wording in an English-language Windows would be).

I’ve worked through this - https://www.makeuseof.com/tag/android-wont-connect-windows-adb-fix-it-three-steps/ - but to no avail. I downloaded ADB drivers elsewhere and tried installing them manually, that didn’t help either.

It’s definitely a software problem since I connected it to my work laptop, which runs Windows 10 Pro afterwards and voilà: It worked perfectly fine. I looked into the Device Manager there and the driver is called “ADB Interface”, came directly with the OS (since the laptop wasn’t connected to the internet).

Any ideas how I can get my phone to show on my private laptop? I haven’t looked for an “ADB Interface” driver for Win 7 yet, will do that tomorrow…

Any suggestions are welcome.

Cheers!

The phone not showing up as a drive is not an error. The files will appear under the “FP3” entry.

Beforehand, you have to open the pull-down menu and unlock the data transfer by selecting “File transfer (MTP)”. That is a security feature and has to be done after every reconnect.

3 Likes

Yep, I did activate the file transfer on the phone after connecting (sorry, forgot to mention it). That doesn’t do anything, and mind you I can only see “FP3” under “Devices and Printers”, not under “My Computer” ( = Windows Explorer) where it’s supposed to be.

A Google search for “ADB Interface driver” yielded nothing useful, so I decided to try and play around with the driver settings in Windows. And: It works now, but I’m not sure why!

I tried to manually “update” the driver in the device settings to the only other option available in the list which was called “MTP device” or something along those lines, which failed. Then I clicked on “Install previous driver”, which didn’t seem to do anything. Next, I deinstalled the driver and also ticked the box “delete driver software”.

After reconnecting the phone, it suddenly worked fine. It no longer says “Google Nexus ADB Interface”, but simply “FP3”. Upon inspecting the newly installed driver, it’s now dated 2006 and the provider is Microsoft - before, it was 2012 and the provider was “ClockworkMod”.

Not sure if this will help fellow FP3 owners in the future, but give it a try if you have the same issue. Good luck!

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.