Volume gets louder by itself


I’ve got my FP2 for about 1 month and it’s great. But I have a problem with the volume.
It’s keeping itself up. It’s like someone is pressing the volume up button at a randomly. It’s happening even without the cover.
It doesn’t make a difference if the phone is at the home screen or in an app.

Pressing the volume down button and tapping anywhere on the screen closes the volume information on the top of the screen.

When this problem occurs, the power button will not work until the next stand-by (which sometimes is delayed because of the volume up event -,- )

I haven’t had this problem in the first 3 weeks (it happened on the first setup of the phone but then the problem was gone).

It seems like the problem occurs since I encrypted the phone.

Any suggestions what I can do to fix this problem?


There are some threads in this forum that try to collect bugs. You could summarize your issues there again, so that what you observed is not lost. I don’t think to many people have tried to encrypt their phones (and most of them use the google free version), so maybe this is why no one was answering you (yet).

I have the same problem.
Without encryption.

Symptons: volume goes up without me pushing any button. pushing volume down will lower the volume again, but “up” won’t do anything (I guess, internally, the button still acts as pressed). Powerbutton does not switch off the screen in this mode.
Rebooting (if you achieve that) is a bad idea: you boot into a kind of emergency menu, with a menu to choose to wipe your phone and stuff like that. This menu can not be navigated, as the up button does not react…

How to get it back to normal? In my case, temporary, you may skew the phone a bit - it really feels like a hardware issue.

Some weeks ago, it behaved that way and eventually acted normal again…

Now, it is back :frowning:

What I observed: Yes, removing the cover did not help. The volume buttons feel completely normal - there is this “click” to each of them, when you press them. But internally…

No solution found yet.

What I’ve tried until today:

I have re-installed Fairphone OS through the updater app. This time I did not activated encryption. But still the same problem.

Sometimes the problem doesn’t occur for hours or even days. But then suddenly, it happens every few seconds.

Only “workaround” is to press volume down and then touch the screen. Then the problem disappears for a few seconds or longer.

The power button and volume up button don’t work when this problem occurs.

I can’t really tell if it’s a hardware or software problem.

But as @Halbinsel said, even in the recovery mode the power up button doesn’t work. Only volume down works in this mode.