English

Using Sailfish OS on the FP2 - Experiences and Issues

sailfish
Tags: #<Tag:0x00007fefbd98a558>

#303

I finally managed to fix video recording when using Android 6 base but the method I used is one of ugliest I have done. Now I can make a new clean build and do some final testing. One thing that needs testing is OTA updating procedure from Android 5 to Android 6 base which will require some manual steps from user (fastboot flashing new images to some partitions).


#304

Wow! Sounds good! :grinning:

Just let us know how to test…


#305

Hi!

Today I run:

# version --dup

…but got:

Error: nothing provides patterns-sailfish-consumer-generic needed by pattern:jolla-configuration-fp2-sibon-0.0.38+master.20171111181125.1.ge3d1263-10.68.2.jolla.noarch

Any ideas how to fix this?


#306

Has anything changed since mal posted a day ago “One thing that needs testing is OTA updating procedure from Android 5 to Android 6 base which will require some manual steps from user (fastboot flashing new images to some partitions)”?


#307

I mentioned in one previous post that updating should not be attempted until I say it’s ok. Not even sure to which version you were trying to update. The devel repo might be badly broken in the following days due to testing. The Android 6 changes are not yet in the repo anyway.


#308

I’m still on Android 5 base.

Is the latest “stable” old Android 5 compatible stuff still available somewhere (in another
repo) if I have to do a reinstall with the old version before the Android 6 compatible devel
repo gets sorted out?


#309

Hello everyone ! :slight_smile:
I just bought a Fairphone 2 I received today, I am trying to install SailfishOS, first with files from Explicit, but I kept having a blue screen after the splash screen, and secondly, after a “clean” installation of Android, I tried again from this page, but the blue screen appeared again.

I tried to watch after a solution I have not found yet, so if someone knows if there’s a way to resolve it… :wink: Thank you all


#310

Read this topic beginning with this earlier post …

… especially note the posts by the developer @mal :wink: .


#311

Okay, thank you, I haven’t went that far… I see that work is still in progress for the new Android 6.0 based version. Also, thank you for your work, mal ^^


#312

Either steal a first-generation screen from a FP2-before-summer’17 owner (except from me, eh :stuck_out_tongue: ) or wait for mal to finish his porting work :wink:


#313

steal a first-generation screen from a FP2-before-summer’17 owner

I did not follow the details, which part of the hardware causes the issues. Is it the display?
If so, we should probably put up a warning sign, that SF users, who break their display and replace it with a new one, might soft brick their device in doing so… ?


#314

Apparently, yeah. And you would be right to do so about the warning :wink:


#315

I tried to upgrade the camera to the new 12MPx module on the v2.1.0.9 of the SF OS… but it seems not working (a black screen instead of the camera input). Same with the 5MPx of the front camera.
I guess this is linked maybe to Android 6 base to be updated ?


#316

New camera module and the display module in the latest FP2 devices need Android 6 base to work. I encountered a very serious bug that is currently preventing me to release the new version. The issue is a kernel panic when initiating Bluetooth scan, but otherwise Bluetooth seemed to work though. Hopefully I can figure out what is causing that.


#317

I do not know if it is relevant, but reboot issues have been reported in Lineage OS especially when Bluetooth is enabled:


#318

A little update for the new year, I managed to work around the kernel panic issue when doing bluetooth scan by using a very old modem firmware from Android 5 base, it seems to be working fine otherwise also, I did encounter a small issue with youtube in web browser (seeking in videos causes browser crash) and I’m currently thinking whether to figure that out before release or not. I will do some testing to see that I don’t notice any other issues.


#319

@mal: From my point of view it would be fine to wait for that fix as seeking it videos will probably affect many users. However, I have a brand new FP2 that I am not using as I am waiting for SF so I could test whatever you have now if you want. Maybe I find more issues you want to tackle before releasing it. :wink:


#320

Hi all!
I try Jolla Sailfish on my FP2, thanks to the work of @explit , and I like the feeling and the gesture philosophy of the OS.
What I don’t like is that I can’t use properly all the apps based on Google Play Services.
Nothing new…
I have tried to install microG but I was not succesufull because I can’t obtain the spoon signature because I can’t access my SF phone with ADB in order to patch framework.jar with needle or tingle.
Did anyone successfully installed microG on a FP2 with SailfishOS? Is it even possible?? I read something about Alien Dalvik VM which could make the patching of framework.jar impossible: is it true?

Thanks so much for your help.

P.S. BTW now I have turned to LineageOS, waiting for help. Also here I have some problem managing microG and I went with openGapps.


#321

You nmght want to try the LineageOS fork incl. microG:


Works fine for me.


#322

Up until now it is my understanding that even if on the Fairphone 2 Sailfish OS installs require a certain Android OS version present on the phone, Sailfish OS is not Android, and Android stuff (like any Android App or stuff intended for Android like microG) by simple logic will not run.

However, there’s a commercial product by vendor Myriad called Alien Dalvik that provides an Android environment in Sailfish OS enabling you to install Android stuff and run it.

Catch no. 1: With Alien Dalvik being commercial, somebody has to pay for it. Vendors of Sailfish smartphones do that, and so you get Alien Dalvik and thus Android support on their devices. There is no such support for the Fairphone 2 currently, and Myriad don’t sell to end customers.

Catch no. 2: Alien Dalvik simulates an Android up to version 4.4 and no further, because Dalvik itself is not present from Android 5 on.

If your focus is on microG, then @BeMiGro had the right hint for you.
If your focus is on a non-Android OS perhaps running Android Apps nonetheless, UBports from the 16.04 base on will come with Anbox.