English

Using LineageOS on the FP2

I disabled the root access under Developer options and installed Magisk instead and activated Magisk hide for my banking app. This works very well so far.

3 Likes

I disabled it too but no affect. That is properly due to the fact I flashed su addon. How about you?

can I undo the flash of the su addon as the Official LineageOS is perfect yet.

You could try the arm su removal for 14.1 from Lineage, but still I would still suggest just going official. The battery drain isn’t that more extreme as the unofficial build.

1 Like

If you don’t need root anywhere else, don’t install the su addon. However, if you want to be able to toggle it on and off ( e.g. for Titanim Backup, or for Amaze root access to / files, …) then I suggest iSu : very simple ( one single app, no need of Magisk/Exposed), it has the button “Change SU state” and when this button is OFF it’s not detected by my bank app :smiley:

3 Likes

I hope I have time to do so on the weekend

Xposed moduls allows me to do much more, not only in the sense of privacy and apps permission. I think of OS customization etc.
In particular it allows to run apps (e.g. Amplify ) what hopefully allows me to improve battery life.

Another one gone official today. Flashed with su and opengapps, phone is encrypted

2 Likes

I’ve seen the official instructions require you to install root if you need it. In the official release, can you still enable developer settings by the usual method? And if so, is root still an option in there?

(Applications) Developer Settings are always included because are part of AOSP/Android. Root access config inside Developer Settings is only included if you flash the su addon in Lineage OS, though. But it’s just a one-time install —it’ll survive OTA updates from then on.

2 Likes

I want to give Lineage@FP2 a chance (coming from FP-OS 1.12 = Android 5.2)…

Just to be on the save side some questions before flashing:

  1. There are no :negative_squared_cross_mark: now! -> so in comparison to FP-OS all features are working properly now?
  • where can I check, in which release “:warning: battery-wakelock with 1-2%/h” will be fixed?
    (Edit: seems so)
  • As I still suffer of having an up-to-date-overview:
    What are the main drawbacks by using Lineage instead of FP-O(O)S (or are there just advantages)? (Despite not having google-apps by default)
  • Coming from FP-OS with root & TWRP: I can go directly via this guide ?! My external SD-Card content will always stay untouched while flashing, right?!
  • How does future updates will be available? Via an built-in updater-app? Or do I always need to flash via TWRP?
  • What is (apart from TitatinumBackup) the most recommend way to save the system partitions to be able to revert back to my current OS (Using Windows)!

I hope thes questions also help others and I hope I not just overseen too much comments in the forum…

1 Like

You are completely wrong here. Maybe a mod (@paulakreuzer ?) could move this? (@paulakreuzer: sorry I missed your hint, @z3ntu moved it)

  1. Yes, I think so. I am not aware of any non-working features.
  2. As I heard today, it should be fixed with the latest nightly
  3. I am not aware of any drawbacks.
  4. I did not do it, but yes, it’s exactly for this case. Yes, the SD won’t be changed.
  5. With the Lineage Updater. It’s in Settings -> About Phone (And it uses TWRP btw, but this shouldn’t bother you ;-))
  6. Use TWRP to do a complete Backup. Then you can just go back exactly how it was before. But this doesn’t replace a backup with titanium, because it only saves the complete system
3 Likes

about 6: A backup of the userspace is still needed seperately from TWRP & Titatanium. Else you’ll lose for example your photo’s

1 Like

It’s always a good idea to save the images etc., but I’m not sure I saved them and moved them to the phone again. I thought they survived the Lineage installation? :wink:

3 Likes

If you do a standard wipe/factory reset from within twrp, it won’t wipe your external data (fotos, music,… ) only app data. Which is different from a factory reset from the ROM

3 Likes

thanks for your answers, @retsifp, @lklaus, @snevas !

The wakelock-problem seems to be solved, as you can read here.

Two other questions:

  1. if GoogleMaps is the only Google-App I need to use … Do I really need to flash “GApps-Mini”, as this is the lowest package which includes Maps?
    I guess only installing Maps-APK from Playstore etc. will not work, as most likely any google service for location will be missing in this case, right? Any recommendation to get running only Google-Maps/Location services, without the need of the other google-clutter?

  2. To gain root acces I need to flash the addon-su (arm) with TWRP, that I got.
    BUT: do I also need a special SU-manager-App (which now is “superuser” for my current FPOS), or is this already included in the addon or in LineageOS itself?
    (Background: For using TitatiumBackup I need root, and I want to be safe that I will have proper rootaccess straigth after flashing LineageOS to get back my backups.)

Thanks for help!

1 Like

You don’t need mini. You need at least Open GApps pico to get the Play Store, and with the Play Store you can install Maps. So it would be pico + Maps instead of mini (whatever difference this makes).

I only flashed addon-su and didn’t install any App, and root looks like before (I had it enabled in the unofficial builds).
If there was no root before, you might just need to enable root in the developer settings.

1 Like

Ok, for the record: I’ve checked* and Gobble Maps app’s basic functions worked with microG (an open source implementation of Google Services). Showing the map, searching a location and planning a trip. I don’t have a Google account to check login, but according to microG’s supported features, it should work (if G. Maps doesn’t handle this itself, which is likely).

*= calm down, privacy defenders and #livingwogoogle like me. All connections were made through Tor (Orbot’s VPN) and protected with LineageOS’s Privacy Guard, :wink:

3 Likes

OK, only Pico sounds OK.
But in principle I don’t want to use Playstore or Google Account at all. Just using the bare GoogleMaps functionality (show map, routing, traffic). I just want to get the APK for GoogleMaps, eg. here or with Racoon or… and therefore I ask if anything MORE from google services is needed to use it. You know what I mean?

7 posts were split to a new topic: Appstores and Trust

I see.

Does it have to be Google Maps for some specific reason, or would OsmAnd perhaps work? You wouldn’t have to bother with Open GApps then.

Here and here is some more info for when coming from Maps. And there’s more on the internet on that I would bet.

1 Like