English

Official LineageOS is here!

Sounds like good news :wink:
–> “sounds” because I am not really sure what it means (i guess i do but still) and, more importantly, what the implications are.
It would be great if you could provide some information regarding these two points – maybe in the first post for visibility?

Specifically, people might want to understand:

  • how is the “1st official build” different from the “last unofficial build” – what makes it official?
  • who is maintaining + hosting the OS – is it now in the hands of the lineage developers? or is it still just mainly a single person?
  • is there some kind of “quality control” (not only regarding functionality but also security issues)?

I think these points are really important! – while i am sure that everybody did great work, I will not rely on an OS that is maintained by a single/very few devs. And this is for two main reasons

  • if something changes in the devs personal life (kid born, new job, illness, …) the development comes to a full stop :unamused:
  • (i am hopeful this is not an issue here ;), but still) for a tiny user base like in this case (FP2 Lineage OS Users = some 10s to few 100s tops?) the potential for undetectably pushing some malicious functions to the users phones is much higher than for something like, say, a linux distribution. or, for that matter, FP Open.

It would be great, if you could shed some light on these questions/concerns :slight_smile:


edit: shamelessly summoning @chrmhoffmann, @snevas, @Roboe :stuck_out_tongue:

2 Likes

@chrmhoffmann Here I found a wrong link: It should bei https://dl.twrp.me/fp2 instead of https://dl.twrp.me/FP2.

2 Likes

[quote=“jme, post:77, topic:34448”]

  • how is the “1st official build” different from the “last unofficial build” – what makes it official?
  • who is maintaining + hosting the OS – is it now in the hands of the lineage developers? or is it still just mainly a single person?[/quote]These are good questions you ask.

The hosting is now officially done by LineageOS instead of unofficial 3rd party (snevas).

Whole LineageOS website including wiki. www. and download. are hosted by Linode (NY, USA) and the links to the checksums and zips are hosted on mirrorbits. (OVH, QC, Canada).

The FP2 port developers can set when the build is going to be build which is every Tuesday.

I don’t know if there’s deterministic builds.

[quote]- is there some kind of “quality control” (not only regarding functionality but also security issues)?
[/quote]Its a weekly release on Tuesday.

Do the developers of the port use nightly builds to test out?

I don’t know how this compares to the official QA in FPOS.

There’s a useful app Lineage Downloader which allows you to switch between builds, see changelogs of your current and future build, and contains links with changes to Gerrit. The Pro version without ads costs ~2,5 EUR. But it doesn’t allow you to try a nightly build.

My 2 ct,

6 Likes

Amazing!
But I got one question:
In the how to was this warning:
Warning: Your device must be on bootloader version , otherwise the instructions found in this page will not work
But the bootloader version is missing…
Which version is needed?

I’m not a 100% sure what that means either - I’m sure someone else will explain - but if you come from official FP OS or FP Open OS and never changed anything in the system you can definitely ignore that warning.

2 Likes

I think that the powerdrain might be fixed now.

Chris

21 Likes

Update to 14.1-20171031-NIGHTLY-FP2 went smooth.

No further reboots until now, but the OTA Update did’nt work:
"Das Herunterladen ist fehlgeschlagen. Bitte überprüfen Sie die Internetverbindung. I did the Update via TWRP.

I had that too. After some time, the update worked via OTA.

For me too via OTA without any problems.

  • modem-17.09.3.zip (unchanged, not installed again)

Update installed via TWRP:

  • lineage-14.1-20171031-nightly-FP2-signed.zip
  • open_gapps-arm-7.1-pico-20171031.zip

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm (incl. swiping it off)
  • MyPhoneExplorer
  • root

Installation of modem.zip isn’t mentioned on Install LineageOS on FP2. Maybe it would be good to add it there (not everyone will read this here on the forum)?

Same here! Battery life is amazing since the update today.

3 Likes

3 posts were split to a new topic: “x” over both wifi and 3G notification symbols

Hi everyone,

I just switched from regular fairphone OS to official lineageos.
I should also mention that my phone has a 12mp camera.

Because I had to format everything, I finished installing and then went to encrypt the data partition, just as it had been before.

However, it appears I am facing the same issue as Encrypting new FP2 fails

I tried wiping, repairing, resizing and reformatting the data partition.

As the topic does not mention the OS I assume it is also happening on regular FPOS. It would then appear to be some sort of OS-agnostic issue.

Problem : I do not have my old 8mp camera anymore.

Does anyone has any idea what the cause could be and how to fix it ?

In which cases the additional modem installation is neccessary?
I support, that it should be included in the installation instructions, if it is needed!

1 Like

jippi, it worked like a charm

1 Like

Hello!

I have problems activating the SIM cards on Lineage OS, I installed lineage-14.1-20171031-nightly-FP2-signed.zip

I was on FPOS 17.10.2. So I followed the guide in the lineage os wiki-page linked in the opening of this thread. I added the zip for open GApps mini.

Everything went well while installing and Lineage boots correctly. However, when trying to unlock my sim cards I get “SIM unlock operation failed”, and I cannot get them to connect. As I understood it, if I came from a recent FPOS I should not need to add new modem files, correct?

Have I missed something?

I did not root.
I’m using 2 SIM-cards

M

1 Like

About the fixed Wakelock: Great news & good work!!
You are talking about lineage-14.1-20171031-nightly-FP2-signed.zip , right?

OK, updates:

I have tried swapping around the SIM-cards, seems that my work-SIM that was in slot 2 only works in slot 1 now… Whereas the Private-SIM works in both positions.

So the following setups:
SLOT1: Private, SLOT2: – - WORKS
SLOT1: Work, SLOT2: — - WORKS
SLOT1: Work, SLOT2: Private - WORKS
SLOT1: --, SLOT2: Private - WORKS
SLOT1: Private, SLOT2: Work - None of the SIMs work
SLOT1: Empty, SLOT2: Private - WORKS

So when I use Work-SIM in slot 2, nothing works.
Any Idea why? Since this worked in my previous setup with FPOS. I didn’t change anything regarding the SIM during the install…

Anyhow, I guess it works for now since I can use both SIMs at the same time.

M