Encrypting new FP2 fails

Hi @Amber, thanks for your reply!

I might have put it a bit unclear, I’m sorry. I have been using a FP2 since they sold it one and a half years ago. Back then it was running Android 5 and I have had no issue with encrypting it.

This week I got a new replacement phone (on warranty, due to an unrelated technical problem). This new phone came with Android 6 preinstalled. Now while setting up the new FP2, I ran into the encryption problem. Since the hardware should be the same as in the original FP2, I suppose the problem must be something else?

Since you mentioned RAM, are there some requirements for the device encryption?

Edit: I’m running the latest Fairphone OS 17.10.2.

1 Like

No requirements that I can link to. But I heard of issues when RAM is full. On my FP2 I have quite a load of apps installed and do not run out of RAM, so I expect FP2 to have hardly issues here. So your problem should be caused somewhere else. But I have no clue currently.

1 Like

Alright, thanks anyways!


  • Remove the new 12mp/5mp camera modules
  • Reboot the phone without these modules
  • Perform the encryption
  • When everything is completed, put the new modules back in place and reboot the phone

Previous answer:
Apparently you cannot encrypt the FP2 if the new 12mp/5mp front and back camera modules are installed.

I had put in the new 12mp/5mp modules in before I started all the software setup of my new phone. After putting the legacy 8mp/3mp camera modules back in, the encryption went through without any hickup.

Switching to the new modules after completing the device encryption worked as well without problems.


This sounds so weired, I think it’s worth to have it as bug report!


Thanks for the heads up. I’ll keep my old camera modules for the time being.

Just want to add that I am experiencing the same problem when trying to encrypt my new FP2. Unfortunately, I do not have an old camera module at hand to try and encrypt the phone with it installed.

1 Like

I had the same issue. New FP2 with 12MP camera. It just rebooted without encrypting.
After reading this thread I removed my camera module, started the device without camera and was able to encrypt it. I then reinstalled the camera and everything works fine.


This obviously is a serious issue. Please file a bug in the official, public bug tracker so Fairphone can fix it!


So did you boot the phone without any camera module? Didn’t know this would work :slight_smile: but if it does this could be helpful for @broshni, who doesn’t have an old camera module?

Anyways, if the problem is the 12mp-module (and not the lack of the 8mp) I can refine the bug report and the marked solution to this thread.

Yes, it did boot without the camera modul. I think @broshni could try the same thing. If it works for him we would have a proof for the no-camera-encrypt-method as it worked for me :slight_smile:

At the moment I don’t have the right screwdriver, but as soon as I have I will try to encrypt w/o the camera module installed :slight_smile:

Tried multiple times and it also fails with the new camera module.

Each time, it rebooted, a crash report has been generated and sent (said hiccup) so we can hope our reports help for a resolution :slight_smile:

1 Like

It worked! :grinning: I removed the camera module and rebooted the phone. Encryption was performed as intended. Afterwards I put the camera module back in place. Everything works normally. :thumbsup:


FYI: I have reported this as a bug now. Thanks to all who shared their experience!


Not sure if this helps anyone but on my recent purchase of a FP2 here in Switzerland I observe the same problem as described by the original poster. Is this a hardware or software problem.

Anyway the version build is FP2-gme17.12.1 with an OmniVision OV12870 and OV5670.

I don’t know whether this is hardware or software related. The Fairphone developers accepted the bugreport and will look into it. So I think we can expect a solution sometime. But since there’s a workaround, I suppose it’s not considered an urgent matter. :slight_smile:

Did you succeed in encrypting your device in the end?

Yeah, “sometime”… Still no update in the bug tracker.

Yeah, every single customer who got a new FP2 in the last three months first having to disassemble their new phone obviously is just a minor inconvenience. :roll_eyes:

I really like Fairphone, but sometimes I seriously question their judgement regarding priorities.

1 Like

Thank you for the solution! I ran into the same problem with a new Fairphone 2 and Fairphone Open 18.01.1. The workaround solved the problem for me.

It is somewhat disappointing that this problem was not identified by Fairphone when testing the new module.

1 Like