Using LineageOS on the FP2

I have this problem aswell. I think it maybe, when I have wifi on, then it disconnects (for whatever reason) and then it does not connect over mobile internet (maybe because I said prefer wifi). So it tries wifi and ignores mobile internet eventhough there is no wifi connection. But this is just a theory.
What I do: either try and get wifi back or restart. Turning wifi off sometimes helps.

1 Like

Xposed not being officially supported is the only reason why I switched back to FP Open OS.
I do need “This App will run without Google” but it looks as it is not supported (yet) …

Coming back to battery usage… I did some experiments.
After reboot, and after an uptime of 4 days, I recorded actual cpu frequency every 10 seconds, while doing basically the same thin (reading text with an elaborated rss reader, which basically is scrolling, text display and internet, with all my background processes untouched).
The script is this:

while :
  s=$(date +%s)
  for i in $(echo /sys/devices/system/cpu/cpu?/cpufreq/cpuinfo_cur_freq)
       echo -n "$s;"
       cat $i
    sleep 10

Which gives up to 4 values per query. Reformatted with a small perl programm I create a csv (available on request, 24lines), which I then import into oocalc for a diagram (phew, quite some complicated massaging… ;-)) Here I can see that

  • cpu generally runs faster
  • more cores are active
    after some days.

After the reboot:

After 4 days of uptime

Additionally, after reboot the charging current varies between 500 and 700 mA, after 4 days I only get a maximum of 400mA…



Was this added? Im still experiencing low microphone volume in some apps (whatsapp and the native recorder for example)


I finally installed lineage OS yesterday. Everything went pretty without problems with the explanation here in the forum. I went by the FP open os way to have twrp! I’m definitely not an expert but this was pretty easy!

After one day using lineage it was definitely a good change! Any problem so far with anything!!

Just that I need g-sevices only because of GPS and signal app is annoying. Last time that I had FP open I tried unified and microg but I didn’t achieve to make it working. So opengapps was the easier option for the moment.

I have one question regarding the battery demand. For me its going down more or less fast… And as before I noticed that somehow WiFi seems to be active all the time (or my suspision is that just the colours are reversed, as it was on for the time its shown white down, and switched off for the green area…)

Any ideas??

Please have a look at this thread.

It seems that using the handsfree works much better. Hopefully it will be fix in the next version.

So I went back to LineageOS.

Somehow network reception in my Fairphone Open OS did manage to regress to the LineageOS level lately, and Fairphone Open OS 17.08.1(.1) introduced random reboots to my phone, which I could fix by flashing 17.06.4 modem files … but anyway.

As a trade-off (I guess) my compass in LineageOS did manage to regress to the Fairphone Open OS level, so I have to calibrate often again.

At least everything is more logical this way.
Now trying 17.08.1 modem files with LineageOS, so let’s see about these random reboots …

Can’t help you with GPS, but you definitely don’t need Google Services for Signal. (I have run Signal w/o Google (or surrogates) for several months now.)

Right, to use Signal on a phone without Google services, just d/l it from here:

And your GPS works how??

And if i habe solved this, how do i geht rid of the oppengapps?

Does somebody using Lineage know if Camera API 2 is supported on Lineage?

Edit: When running Lineage on the Fairphone.

Google knows:

Whether a device uses the new or old camera HAL depends on the device-specific camera blobs. Some might also support both but have severe bugs that prevent using the newer HAL.

Thanks for the link, but that now i still don’t know if the Camera2 Api is exposed when running Lineage on the FP2.

That means: No. The blobs have to support it, but they don’t (We had this discussion here, maybe a search helps? :wink: ).

Does anyone know if there’s a way to use the checkup or proximity sensor calibration tool on LOS? Especially the second one, as with the new camera modules it’s said to be necessary to calibrate the sensor… Or does this not apply for LOS?

Hi, I’m getting a red rectangle popping up in my display covering the sides of it. Sometimes it seems to pop by itself and it pops op when tapping on a wide variaty of tapping options (such a opening a app or just tapping on whatever tap you can make in settings for example).

Did anyone encounter this bug? I flashed the latest modem and LOS OTA-zip file.

TWRP does not find any files on the external sd card… What am I doing wrong?

Update: Formatting the sd card did the trick. :slight_smile:

Did you perchance activate one of the display debug options in the developer options?

1 Like

Hi @lklaus, I don’t think I did that. Right now this problem is solved (I forgot to edit my post this morning). I wiped my phone and flashed the latest zip and modem file, but I’m not sure if I actually needed to do that.

Fortunately I still got some other problems :wink:. The PIN verification acts a bit weird. It flashes away and immediately another PIN verification pops up.

Besides that I can’t seem to get an internetconnection via LTE. It could be because of my AfWall+ settings. I tried a lot (different AFWall whitelist settings, different DNS settings f.e.), but nothings seems to work. After I flashed LOS again and de-installed Orbot it worked fine by putting AFWall and the browser on the whitelist. Later on I got a little x in the LTE-connection icon (after a restart). Maybe it’s because I disabled OneTimeInit and, though I enabled those later again and still no connection. Calling and SMS works fine.