Using LineageOS on the FP2

Can you tell me how you disable apps ? Maybe I am wrong, but I open the settings, choose “Apps” and when I touch a listing the “App info” screen pops up. I am used to see a “disable” button there, but since I am using Lineage OS, most Apps only show two buttons: “Uninstall” and “Force Stop”.

If the app shows uninstall instead of disable, than it’s a user app. Disabling is a function only necessary for system apps because they can’t be uninstalled.


Not sure if this is the right post thread but I just wanted to thank everyone involved for the great work with lineage os! ITS AWESOME! Finally I got the phone I wanted from the start! :smiley:


I’m using LOS for about two weeks now, and it’s great. No xprivacy/xposed, which leads to more scrutiny before installing an app, but otherwise everything is fine (for me)
I noticed better battery behavior, maybe because nougat it’s better than marshmallow, maybe because LOS is better than FPOOS. at least i could see that with LOS up to three cores were switched off, while otherwise this were only two



I have just receive my fairphone.

When i try to flash twrp and restart in recovery mode, i have a blue screen.
I have try fastboot, twrp in root mode… same result.
If I flash system witz LOS, same screen.

Do you have any idea ?


You are not alone!

Dear all,

I am interested in trying LOS. However, a technical question, do I have to install OpenGAPPS to have WhatsApp? Also, when installing OpenGAPPS, can I chose to install only the ones I am interested in (say, PlayStore), or is it installing the whole bunch of them?
I tried Ubuntu touch a few month ago, and found it good enough, but too limited in term of app repertoire (I was mainly missing WhatsApp actually).

I can’t say anything about WhatsApp requirements, since I don’t use it.

Concerning Open GApps: There are different packages for different amounts of Google Apps.
Just go to and choose your desired package, there are explanations right beside the package name, e.g. the “pico” package is explained as “The bare minimum to get Google Play functionality”.
Here’s a comparison of what the packages install.


OK, that’s great thanks a lot! that’s the kind of info I was looking for.

I think whatsapp does not need gapps. You can download the apk-file from the whatsapp website. If you want to get live notifications when they are sent to you, you need to have google services otherwise you can set a time interval that whatsapp does a polling request an checks for example every 5 minutes if you got a message (same as for threema without google).


I had a look at the procedure to install LOS, but I have to say, I am a bit lost and don’t have enough confidence to take the jump. Coming back from Ubuntu touch was already kind of a hassle last time for me. I just hope Fairphone will officially support LOS and come with a simple way to install it (like the magic device tool for Ubuntu Touch) if that’s possible.

I experience a strange effect after two or three days uptime: even with normal usage the phone gets hot and eats battery. I checked cpu frequency and saw that the frequency runs constantly at 2GHz (switching off of correct does work, though)… After a reboot everything is normal again, and the phone runs at lower frequencies most of the time. Does anybody else see this?
(Switched the profile to “efficient”)

Another thing i noticed: in notification settings, advanced, i have the possibility to define a special pulse setting for led notifications per app. I looks like this doesn’t work yet (like LED while charging, but this is known)

Hi François!
I use LineageOS without OpenGApps (I have MicroG), and I confirm: Whatsapp is running well :slight_smile: I installed it with an APK file…

On UbuntuTouch, an app compatible with Whatsapp is developped: Loqui IM. Did you test it already?

2 posts were split to a new topic: Battery life in LineageOS

Today i was riding the train, using mobile data. While entering a tunnel that is providing mobile data also (repeater, provider? Don’t know), ii lost access to it mobile data, and i couldn’t get it back neither switching days off and on, nor entering airplane mode. In the end, only a reboot restored mobile data, and i tried quite some time…


Yesterday I installed Lineage OS on my FP2 for the first time and was disappointed when I realized that Xposed isn’t supported -and I got addicted to GravityBox over the years. So I searched the internet and found this:

and this:

Today I installed both and as of now -5 hours and some testing later- it’s working all fine so far.

This might also be of interest for some:


Hi, I tried to change the DNS servers by longtapping ‘Wifi’ in Settings (following this thread: Living without Google 2.0 - A Google free FP2), but that didn’t work.

Does anybody know how I can change the DNS servers in Lineage?

tnx :slight_smile:

  • Go to Settings > Wi-Fi
  • Longtap your Wi-Fi connection and select Modify network
  • Click Advanced options
  • Scroll down and select IP settings: Static
  • Scroll down and set DNS 1 and DNS 2

Hi @_Chris, tnx!

I must admit that I didn’t read the thread very well :blush:. Still, I can’t change the DNS server. I think I did it right this time, but I couldn’t SAVE the new DNS servers. The possibility to SAVE is changed automatically made impossible when I change the IP tables to ‘Static’.

So, it could be that I did something wrong or it’s something else. I tried to find out what could be the problem. On I found this:

DNS problems
Since Android 6.1.x you only can change the DNS for tether device and nothing else, everything else get ignored, no matter what you set or which app you’re use”

If I understand this well, it’s just impossible to change the DNS on android 7 (exept for tether). That could be an explanation why I couldn’t change the DNS server?

If that’s the case, the only way to use another DNS server is to set the IP-tables in this way (same github thread):

"Or via AFWall+ custom script:

$IPTABLES -t nat -A OUTPUT -p tcp --dport 53 -j DNAT --to-destination || true
$IPTABLES -t nat -A OUTPUT -p udp --dport 53 -j DNAT --to-destination"?

Or is the solution to install another app to change the default DNS?

tnx again!

btw my proxy setting in Wifi Settings is: “None” and my Binaries Preferences Setting/DNS proxy in AfWall+ is: “Disable DNS via netd”.