USB File Transfer Mode

I just received my new FP3 and I’m very happy with it.

However, I’m having trouble getting my Windows 10 Surface Pro recognizing the phone for file transfer.

It recognizes the phone while using the PTP mode (where I can access the DCIM folder etc.) but when I switch to File Transfer-mode the drive disappears and the PC doesn’t recognize the phone at all.

I tried enablingg USB debugging to no awail.

What could be the problem here?

Welcome to the community forum.

Sometimes driver trouble gets in the way of MTP functioning properly … this here should help (if driver trouble would really be the issue) …

  • Disconnect the phone from the computer.
  • In Control Panel - Programs and Features:
    Uninstall everything with “MTP” or “ADB” in its name. And the “Android SDK”, if it is installed.
  • Reboot Windows.
  • In Control Panel - Device Manager:
    Enable View - Show hidden devices, and then uninstall every possible ADB, MTP and smartphone device, hidden or not.
  • Reboot Windows.
  • Connect the phone again

Windows should then install working MTP drivers again automatically.
If this doesn’t work, the problem is probably on the phone’s side (*).

If you had adb and/or fastboot before, they might have gotten uninstalled now if they originated from a formerly installed package like “Minimal ADB and Fastboot” or something similar, so (and it’s better to use the following anyway) …

(*) At least if MTP access to the phone worked before. Just as a reference … If there would have been a problem with MTP from the start, it could have been due to a Windows N version. (“N” = without Media Player, result of an old antitrust case)
A Windows N version would need the “Media Feature Pack” before it can do MTP. This should be installable via Settings - Apps - Apps & Features - Optional features (or something like that, German locale here) in current Windows 10 N, for older Windows N versions there were dedicated downloads …

1 Like

Yeah, sorry, I forgot to write that I found this solution in the forum and tried it already, but it didn’t solve the problem unfortunately. There weren’t any “MTP” or “ADB” programs to uninstall and uninstalling all previous smartphone devices in the Device Manager didn’t solve it either.

I followed your instructions and added the path to the SDK platform tools. Should I run the program from somewhere?