USB file access (MTP) not longer working after upgrade

Hello Fairphone users

I recently upgraded my FP2 to the new Android 6.0.1 release. In general, the process ran flawlessly.

The following behaviour is new:

i.e. the device itself appears but shows an empty window only. On Android 5.1, I just had to unlock the phone to allow access the USB file transfer (MTP). This not longer works after the upgrade.

It’s to mention that this happens with any Windows version, even on Windows 10.

Current temporary workaround is the use of the MyPhoneExplorer app via WLAN (thanks to Franz Josef Wechselberger for this great app!).

It would be fine, when this behaviour could be fixed with the next Fairphone update.

Did you explicitly set MTP as USB connection mode? In Android 6.0 it is no longer saved as default, apparently as a security feature.

How does one do that?

You might have to swipe down to see the notification.


Found it, thank you!
One issue solved, one more to go (Bluetooth connectivity; FP2 doesn’t recognize my Logitech H800 headset anymore).

Thank for your answers. I also found it, so here some screenshots for those with the same issue:

Note: To show the menu on the first screen, you have to sweep from the top edge down first.

Note: This must be done each time after USB plug in but remains during a USB session when the phone goes to the locked screen state.


As @anon12454812 has mentioned “This is a Android 6.0 security feature. If for example you connect your phone to a public USB port (i.e in the train, etc.) it doesn’t have direct access to your data - that’s why it is on ‘charging only’ at first.


I have a similar thing happening to my phone at work. When I plug it in to the USB port the computer nor the phone does anything, not even charging.
To get it to work I have to deactivate and reactivate USB Debugging in the developer menu. After that it works just fine.
No idea why it is doing that.

1 Like

Hi all,

It’s not working for me on macOS with Android File Transfer. I can see the files on the SD card, but when switching to Internal storage the view is empty.

I have already tried

  • restarting the phone,
  • enabling debugging mode,
  • switching between MTP and PTP and back,
  • different USB cables,
  • different USB ports.

I was able to get my pics of the phone via PTP, but I actually would like to have access to the files again via MTP. Any more ideas? :worried:


Exact same problem here (on windows for me and I don’t even see file with PTP)… It was still working yesterday, I didn’t change anything and now I got empty DCIM file which is really frustrating because it’s impossible for me now to back up my trip pictures T.T
Enabled File transfert and USB Debugging Mode without success :’( Can’t find any solution about this persisting pb … Anyone can Help?!

Edit: I finally found a solution to my pb : (which was) switching to MTP with USB debugging ON and still DCIM folder showed empty.

THE solution:

Go to Settings > Apps > (touch the 3 point in the up-right corner) Show System processes (or something like that, I translate from french) > Media Storage > Storage* > Clear DATA.

Don’t be afraid, it has something to do with the way that your fp organizes the data (so it doesn’t affect your data, just the way your phone sees it).
NOTE: It is important to let your fp rebuild his ‘library’ so wait at least 10min and check if you can load properly your pics on the phone (like usual), if it takes to much time, there’s a free app that helps the phone to rebuild it properly (so the phone can show you everything it should) : it’s called media rescan. I did it just to be sure around 20min after I cleared the data of Media Storage.

Then connect your phone like your were used to, choose MTP and it works ! :smiley: Finally a non-empty DCIM folder : that feels so great :stuck_out_tongue:

*Merci pour la remarque Denis :wink:


I have the same Error. the Drop down menu entry do only appear if USB debugging is active otherwise I have to open the development settings and change there to MTP every time I connect with USB.

Hi Geoff,

thank you for your tip, I’m facing the exact same problem.

Could you please provide the instructions with the french labels ?

Everything was OK until “show system processes”. But then I cannot find “Storage” alone in the list, only “stockage de l’agenda”, “stockage des paramètres”, “stockage externe”, “stockage multimédia” and “stockage tél et SMS/MMS”. Which is the right one ?

Thanks in advance,

Edit : solved : it was just the order that had to be changed in the path you provide : it should be “Media Storage > Storage” instead of “Storage > Media Storage”.

Thanks again, now it works !




Sorry for the late answer.

Thank you, I had definetly switched Storage and Media Storage as you noticed :stuck_out_tongue:
I corrected it now so it shouldn’t disturb anyone anymore :smiley:

This topic was automatically closed after 182 days. New replies are no longer allowed.