Upgrading from *official* 14.1 to 15.1 (feedback/issues)

I run LOS 15.1 13.08.18. Everytime I restart my phone, it says the SIM cards were changed (I use 2 SIMs).
Also Google Maps and eBay Kleinanzeigen no longer work - do these work for others? I will try and get a logcat for this (have to read into how to do this).

I did a fresh installation of LOS15.1 via TWRP:

  • did a backup of the actual version running (LOS 14.1 )
  • wiped all before (system, cache, data)
  • installed LOS and gapps zip packages
    Now all works fine, LOS-build-in music player works without the problems described here.

Since it wasn’t the same starting position, i wanted to set up the system again:

  • wipe again system, data, cache
  • restore the backup just created before
    Then this should have followed:
  • wipe system and cache, but this time not data
  • upgrade to LOS15.1, all apps and app data shold remain

But TWRP has given me error 255 for data partition. The only way I managed to get data partition again accesible was to format data,
But then all data from encrypted SD card was gone.

Before continuing tests, I would be good to now how to safely backup/restore between different versions.
Has anybody faced this also? Why this error 255 appears, how this can be avoided?


1 Like

No. Lineage OS only tracks a single version at a time per device. You could stay on latest 14.1, though, there’s no major problem in delaying security updates some months.


I’ve been having a good time with my freshly installed Lineage 15.1, but when trying to update to the newest nightly (20180820) I get an install error from the Lineage OS updater.

I’m using a FP2 with the older camera modules. I did a complete wipe of my phone before installing 20180813. I’m using Open Gapps pico and haven’t rooted the phone. No encryption (yet).

What I’ve tried:
Deleting and redownloading the install 3 times. Restarting the phone of course. Charing the phone fully and then installing - without being connected to the charger.

Probably not relevant, but the first time I tried to install the update, the install was denied because the battery level was <30%.

Is there any sort of error log that I can/should provide?

There is something wrong with the OTA but you can install it semi-automatically from Recovery:

  • download the update (same procedure as you have tried), but don’t try to install it
  • restart in recovery
  • install the file stored in the update folder (/data/lineageos_updates)

Are you using an encrypted phone? Sorry, seems you are not… ;-).

AFAIK this could fix the OTA updates in the next release: https://review.lineageos.org/225529

1 Like

I know I’m OT but why there are so many problems related to the new camera module?

1 Like

Thanks, worked perfectly :slight_smile:

1 Like

I have the same issue with regards to disconnects. On FP2, Bluetooth also says it is disabled when it is enabled. I use P2 and only have 1 device registered, but P2 is the only Pebble which only has BLE. On Gadgetbridge, IIRC there were 2 Bluetooth addresses with the P1 Classic (and should be with all non-P2).

I seem to have severe battery use ever since 20 august manual update but I am not sure what’s causing it. I hope up today and found my device was rebooting while it was on USB charge, meaning it was heavily discharged. Anyone also experiencing this?

You could investigate via GSam Battery Monitor for example, that App helped me discovering that WaveUp is draining my battery because of wakelocks (too sad… even with 15.1 I cannot use it).

Could it be linked to the absurd battery percentage used by Mobile Network standby as experienced by other FP2 users (which also affects other phones)?

Thanks for the suggestion. The device was extremely hot as well. I do have bad mobile reception in-house, but I had data usage off (since I was at home, I did have WiFi on but the device was 5 meters from the AP in pretty much a direct line so good 5 GHz reception). Bluetooth-wise perhaps it was in trouble given my smartwatch was on me in our bedroom. I did not see such absurdity when I checked the battery usage roundup (since yesterday morning my device was at 63% or so when I took it out, and it appeared to go down by 2% every few minutes until it reached 25% and the battery saver kicked in; so it appeared the battery saver saved me there but this even occurred whilst I was on the move and whilst I was gaining better reception). When I noticed it yesterday I had a powerbank w/me, but this morning I was too late since the device was already empty.

At lunch I’ll have a look with some other applications than Android’s stock battery analysis app (which appears quite useless to me the times I’ve used it).

I think i also see this with this version. Cpu clocks higher on average, and idle usage seems to be higher, too…

1 Like

Hi. I too downloaded the first nightly (20180820) and was refused installing.

I was told tapping OK would restart the device in recovery mode for executing the update, but it didn’t.
There was a hint to the extent that the operation required a «compatible recovery system», otherwise the update would have to be installed manually. Now I don’t know how to make sure my recovery system is compatible and if it wasn’t how to make it compatible… What does this all mean (in non-machine-English or non-machine-German)?

How would I have to proceed? I tried rebooting into TWRP (power+vol-up for 10sec) but the FP2 only decided to reboot into LOS15.1.

Thanks for your help!

To follow up on it, given I’m at home, I get 99,2% of the time a “moderate signal” according to BBS. The other 0,8% is only better than that. I never had “poor signal”.

When I fired up my device it was smoking hot, on full 2,27 GHz for 4,5 minutes and updating apps on Aurora/F-Droid. I lost about 5-7% of my battery during that time.

Seems I need more data tho.

I didn’t see reboots so far, but battery life is worse than before, was 3 days on 14.1, and now about 2,5 days.

You have to hold the vol-up button as long as the phone is rebooting, until you see the TWRP screen.
Then you can install the lineage ZIP file that resides in /data/lineageos_updates

1 Like

After a fresh start the device is really busy, among others with the media scanner. I guess a realistic image is only possible after 20m or so.
I already stated in some pay that i have the impression the cpu clocks higher, as the phone gets noticably warmer to the grip than before. Also, watching idle drain I’m at 2%/h instead of around 1

1 Like

Concerning battery life (interval between 2 loading cycles) i read many different topics.
Some users report longer and some a shorter interval.
Personally i think the interval is longer with 15.1. E.g. today i used 15.1. with my navigation app for bicycles and I found it was a great positive difference. With 14.1 my phone became always very warm during navigation and battery was drained after max 2 - 3 hours. With 15.1 phone remains in normal temperature and consumption of power is about 30 % - 40 % which is comparable with a phone of another supplier I had before. Also without navigation life time seems, from my subjective point of view, better.
I think it is very difficult to get a correct measurement because the personal behaviour using the phone is different every day. But apps like battery bot give at least an idea of power consumption.
Therefore, it would be of interest if some users have measurements between 14.1. and 15.1.