Upgrading from *official* 14.1 to 15.1 (feedback/issues)

Concerning battery life (interval between 2 loading cycles) i read many different topics.
Some users report longer and some a shorter interval.
Personally i think the interval is longer with 15.1. E.g. today i used 15.1. with my navigation app for bicycles and I found it was a great positive difference. With 14.1 my phone became always very warm during navigation and battery was drained after max 2 - 3 hours. With 15.1 phone remains in normal temperature and consumption of power is about 30 % - 40 % which is comparable with a phone of another supplier I had before. Also without navigation life time seems, from my subjective point of view, better.
I think it is very difficult to get a correct measurement because the personal behaviour using the phone is different every day. But apps like battery bot give at least an idea of power consumption.
Therefore, it would be of interest if some users have measurements between 14.1. and 15.1.

Thanks a lot, Ingo!
Holding the vol-up button until TWRP is appearing, THAT was what I never had grasped.
Thanks also for the location of the update-ZIP.

1 Like

was there too many bugs at the beginning of the release of Lineage OS 14.1?


I’ve just changed to Lineage 15.1 + picogapps from FPOS mostly in the hope of increasing battery life. Previously the battery was flat in early evening. The first few days there didn’t seem to be much improvement (I wondered if it was busy restoring previous data etc) but for the past 2-3 days battery is still showing 50% at bed time. It makes an enormous difference to how I feel about the phone. A phone that doesn’t last all day is of limited value in my opinion.


I have a problem with latest build (20/08/18) of lineage OS 15.1 with TWRP 3.2.3. In few words, normal call with 2G a.k.a. GSM network does not work. If I make a call after that I press the call button, the display switch off and I can hear the voice, but the other side cannot listen me. The same thing happens in the opposite scenario i.e. when I receive a call.
By using telegram, signal o wire there are not any problems.
Do you have any suggestions?
Thank you

as a follow up: i did a clean reinstall, including wiping data, as before i restored from a corrupt backup. Maybe this was causing effects. Now the phone stays cooler, and battery lasts longer again. idle drain still it’s a bit high, 1.4%/h, seemingly mostly caused by system. let’s see…

Hello everybody,

I updated to 15.1. and everything seems to be working great so far, except for:
Davdroid Sync.
I noticed that my calendar won’t sync anymore (no error message, just nothing happening)
So I reinstalled Davdroid (also tried earlier versions) and now my contacts and calendar apps can’t find my davdroid account anymore, so all entries are basically gone.
The davdroid account appears in the system accounts list, but the apps can’t find it / can’t connect. Davdroid itself seems to be working fine.
Any ideas?

Hi @juniorprofi. I actually had a problem with DavDroid, but synchro works again after a few hours I think the problem was with my host. Have you read the DavDroid logs ?

Overall I’m happy with the upgrade to 15.1 but I preferred the previous version of Trebuchet.

I have no problems with Davdroid and Lineage 15.1. I synchronisize contacts and calendar with Posteo and a Nextcloud without problems.
Not really helpfull for you but maybe it could be seen as a general feedback concerning the synchronisation on 15.1.


today i had an unexpected reboot while checking done network info in termux…i was using an ‘ip route get ipadress’ when the system froze and rebooted. here is the last_kmsg: https://drive.google.com/file/d/138nqetpPrw4RqWRBXpzgfacewGRAUcGU/view?usp=drivesdk

Just a wild guess: have you checked the permissions as well as the Trust / Privacy Guard settings to make sure Davdroid is still authorized to access contacts or calendar?

1 Like

I just upgraded to the latest build of lineage os 15.1 i.e. 27/08. I’m still having problems during a call in both directions (after making and receiving a call the display becomes dark and I have to remove the battery).
I also experimented the same problem with signal and telegram differently from what I wrote before.
As workaround I found that if I restart the OS and I make a call immediately, it works well. After some minutes (I do not the exact amount), it stops.
Do you think that it is a bug? What can I do? @chrmhoffmann
Thank you

I had the same problem after upgrading. First I set the developer option to end calls with the power button. Second I remembered that I had this problem before… Calibrating the proximity sensor with the built-in Calibration app did the trick again. Good luck!

1 Like

Thank you for the suggestion, but the calibration does not solve the problem.

Are you using the latest modem.zip?

See here: [✏ FP2 modem firmware]

1 Like

I updated to 15.1 from 27.08.18 and noticed that the ghost commander now isnt able anymore to switch into the root mode.
When i enable the root mode and then want to change the permissions from “read only” to “Read/write mode” the root symbol appears and disappears a view times in the status bar and Ghost Commander shows “busy…”. But i cant delete files then.

Can anyone confirm this? Or has a hint for a solution?
Before this update it worked not properly but it worked.

Root mode and deleting files seem to work for me (Edit: on LineageOS for microG).
Have you already installed addonsu-15.1-arm-signed.zip?

I can confirm Nextcloud + Davdroid + Simple Calendar works (syncs) with LOS 15.1 + microG.

Thanks for the answer.
Yes, i installed the addonsu. Other apps, like Titanium Backup, have no problems with root access. I also contacted the developer of Ghost Commander.

Thanks for all your answers!
It’s strange, davdroid and the calendar/contact apps have all the permissions they need.
And sync works on 3 other machines, so it can’t be the hoster (baikal).
But somehow the calendar/contact apps can’t connect with davdroid.
Will look further…