Upgrading from *official* 14.1 to 15.1 (feedback/issues)

Oh, how unfortunate! :disappointed_relieved: Is your TWRP up-to-date?

First thing you should do is make a backup of all your userdata and NAND backup to your computer. You can connect your phone in TWRP to your computer through MTP. Then I’ll recommend you updating your TWRP to the latest available and then formating your phone data (WipeFormat Data). This will remove encryption and ensure the filesystem’s clean. Then you should get the NAND backup on the phone again and try to restore it. If it still fails, try disabling “digest verification” to force it restore whatever it’s able.

I wish you the best of lucks.

2 Likes

Please check whether Settings - Mobile network - Advanced - Preferred network type is set to LTE.

Else … does it perhaps work in the other SIM slot?

1 Like

The settings are already on LTE.
I just removed my Chinese SIM card and now I can get the LTE on the Belgian one. Which slot didn’t change anything.
Is this due to dual sim ? Is it because the Chinese SIM are … invasive ?

The Fairphone 2 doesn’t support LTE on both SIM slots, you have to set one slot to LTE, and the other one will be limited to 2G.
I don’t use Dual SIM, so I don’t know what the settings look like in this case, but it sounds like it would have to be related to that hardware restriction.

2 Likes

Ok I understand. Thank you for explaining.

Since this is not related to LOS, maybe should be better to move it elsewhere.

There are currently two issues:

  • I’m hearing audio books every day, but no music player works:
    • Google Player: it shows only one track of an interpret, and not all tracks. This one track can’t be started
    • LOS music player: when starting a music track, no music can be heard, and the launcher trebuchet crashes. My home screen is completely empty, the only way to go ahead then is to restart the phone
  • 2nd SIM: when booting the FP2, at one moment you’re asked to enter the PIN for the SIM’s. I can enter the first PIN, but before getting the chance to enter the PIN for the 2nd SIM, the lock screen appears, and the 2nd SIM remains inactive.
    My workaround to solve this: toggle back and forth to and from ‘flight mode’: when clicking on ‘flight mode’, I’m asked to enter the PIN for the 2nd SIM.

Is this here the right place to drop this, or should another thread be opened?

Hello, I was wondering two things:

  1. The update is beta or stable? This is my only phone so i would need some “stable” OS.
  2. The update erases apps, configs, data or other informaction in your phone? Or is it like a regular update?

Thanks!

I would first try to get it into a known good state and then try to restore the backup.

In that case: do the manual install of FPOS described at https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2
Then see if that boots. So far that never failed me.

1 Like

The builds now are official (no test builds).

However, using LineageOS you are using OS builds which are being built automatically without a beta tester process before release. Things can break, no guarantees.

Most of the time LineageOS is running just fine, but Fairphone OS and Fairphone Open OS in comparison are being tested by beta testers before releases, so I would consider them more stable in the sense of the term.

Experiences differ. There are users for whom upgrading went through without losing anything … and there are users who got stuck and had to wipe their phone.
Make a backup of all your important data and be prepared.

My personal opinion is that in general it’s better to install the phone from scratch when upgrading the major Android version, and I know it means investing time and work.
But if something doesn’t work out, there’s one less question to ask … Could just upgrading the existing installation instead of installing from scratch have caused the problem? (Answer to this mostly is: Yes, making troubleshooting more complicated.)

1 Like

same issue! cant record videos with open camera

Thanks @Roboe for your tips. I made both backups: userdata and NAND backup.
I updated TWRP (3.2.3) with the official app. My filesystem was not encrypted, but I formatted Data, system and caches. FP2 was very hot: maybe that was the problem? I’ll try again, after overcoming my discouragement… Thanks you again.

Thanks you @Ingo. I was thinking of trying that.
What was troubling for me is that I flashed a file (eg LOS 14.1 zip) the first time without problems but at the second try, after formatting FP2, it gave errors.
Even the restoration of the backup initially worked, phone booted and partially worked (I got a Whatsapp message (!) too), but it had a weird behavior, so I tried exactly the same provedure to restore backup but it did not work anymore.
I’ll try as you say, thank you

Ah, now that you said the phone got really hot. That might be related. Whenever I do some heavy stuff like full backup/restore/flashing an OS, I tend to let the phone cool down after one step has finished before doing the next.

Now I manually installed Fairphone OS 18.04.1 and the first boot seemed to be normal, I saw the homepage but the phone goes off: low battery… I’ll wait until it loads.
Do you think I can still try to install LOS 15.1?
Edit: Fairphone OS 18.04.1 finally started. But I do not understand that all my parameters are still there, even my security scheme, after wiping system, data, cache and Dalvik cache almost ten times.

I just saw that in security it says “phone encrypted”, which seems to be confirmed by twrp (asks for a pin , but still can’t access /data) and in trust it says "encryption inactive)? Display misinformation or something deeper?

Edit: I just learned that i had an accessibility helper active. After disabling and reentering the pin it now shows “encryption active”

I noticed that in 15.1 when I activate the “Do not disturb mode”, it always set “until disabled”.
In 14.1 it used the last option which in my case is “until 07:00”, i.e. when the alarm goes off.
That option is still there but so far I had to check it manually which requires an additional swipe and two taps.

Does anyone know how I can get to the same behaviour as it was with 14.1?

Best upgrade ever, battery lifetime almost doubled!

A post was merged into an existing topic: Magisk and Systemless Xposed on LineageOS 15.1?

I just did it!
Upgrade from 14.1 w/o data wiping, smooth upgrade, and my Afw (managed profile) was upgraded as well :+1:
Downside so far: no vibration/ringmode toggle in power menu, only in quicktiles (Gravitybox)
Awesome work!!
Update: NeoPowerMenu (Xposed) is still able to modify the power menu, actually it replaces the menu with it’s own, which looks at bit misplaced, but never mind…
Update regarding NeoPowerMenu (Xposed): I strongly suspect that it caused my reboots while charging, so I deaactivated it, charging is good now.

2 Likes

Finally I upgraded to LOS 15.1.
First I downgrade to Fairphone OS 18.04.1 following these instructions.
Then I install LOS 15.1 following these other instructions.
I restored my apps and data with Titanium Backup.
I noticed it takes longer for my home wifi to be detected. I also have some problem to restore sync with DavDroid. And I liked the old Trebuchet better…
Thanks again @Ingo and @Roboe

1 Like