Updating LineageOS 17.1 for microG via TWRP + feature test

Now I have another problem: I downloaded the most recent build from the website: lineage-17.1-20200922-microG-FP2.zip, and I can see the downloaded file in the FP2 via Total Commander, but I do not know how to install it. It seems the updater works only with Lineage updates without the fork, at least it tells me only “LineageOS, 17.1, Android 10, 25 September 2020”.

Sure. Aurora is safe for installing apps AFAICT.

Flash the zip through TWRP. Though do a backup before, you never know.


That worked fine, thank you, merci beaucoup. However, afterwords the Fairphone Updater showed an update ready to be downloaded, same date as the one as I just did via TWRP. My question here is: does the Fairphone Updater show regular Lineage OS Updates, or those for Lineage OS for microG, which is currently installed on my FP2?

1 Like

The Fairphone Updater showed you an update to be installed? Under LineageOS you have the Fairphone updater? Do you mean the LOS updater?

Though I can’t tell you if the updates shown in the updater are regular LOS or LOS+microG updates…

It is an app I found on F-Droid, it says
Version 0.1.1

1 Like

Yes but it’s the LineageOS updater, it’s written in the name. Moreover, you’ll find exactly the same updater under Settings→System→Updater.

I think these are the LOS+microG updates. Myself I’m under LOS 17.1 without microG, and the last update was on September 25th, not on the 22nd.


Who is actively using the LoS for microG version on the FP2? I’m asking because of Bootloop after trying to remove UnifiedNlp :-( - fixed, but how to switch to MicroG?, which doesn’t seem to get any attention, which made me wondering a little ;).

I’m using /e/ for the time being.

I’m using it, and I’ve been using it for quite some time now. I think I’ve migrated from “normal” LOS back then, but can’t really tell any more.
Manually installing microG on LOS used to be a hassle, due to Signature Spoofing, which required patching LOS after each update. So I was really happy when LineageOS for microG became available and made things easy for me. :slight_smile:

1 Like

I’m using LOS-microG on my FP2, but only since a few weeks. I am happy with it :smiling_face_with_three_hearts: Up to now the only downside was not to find DB Streckenagent on Aurora Store. I can live with that, as DB Navigator works properly. Apart from that, I use it mainly to check my emails and the weather forecast when I am travelling.

You were right. Today I downloaded an update with the updater and compared it with the latest version on the LOS-microG website. It was the same (20201013). Also the installation went smothly. Therefore updating can easily be done. This is great when encouraging people to use an OS without g++gle :smiley: :heart_eyes:


It’s there, says a test Fairphone 2.


Hi AnotherElk, thanks a lot for your answer, however, it will not allow me to install an “alarm”. I get the following message:

. But this will not stop me using Lineage_MicroG :smiley: :grinning: :smile: and one more thing: I can see how busy you are replying and helping everywhere in this forum - THANK YOU!


Have you ever tried running the Self-Check in Microg Settings? What does it show? If everything’s marked as OK in there, push notifications should work

1 Like

Late reply, but I just wanted to say that I upgraded to 17.1 today.
I have been using Lineage for microg since quite some time. I was still on 16, because I had a lot to do lately. I upgraded from lineage 16 for microg to lineage 17.1 for microg. No problem while upgrading. And no problem so far.
My phone was a bit slow these last months and apps sometime crashed (telephone app while phone ringing, which made me miss calls, or the clock app while the alarm was on…). I hope that the upgrade will do the trick, because I don’t feel like a clean install right now!

Time to time, I also have apps crashing (mainly PokémonGo) or app suddenly provoking a reboot (mainly Whatsapp). But this latest is quite rare (once a week) so I can live with it :slight_smile:
But phone app never crashed for me.
I’m running the official LOS 17.1 (with OpenGapps pico)

Thanks for your answer!
It’s been almost a week now and I still have some apps crashing. Not the clock app any more (so long…), but I had the phone app today again. I also had two other apps almost once a day.
I don’t really have reboots though. What happens on my phone is that the screen freezes (the first times I thought the phone was about to restart), and after a while I get a message saying that the app is not responding. I can either close it or wait.
So: the phone doesn’t reboot and I don’t have to force a reboot; the app doesn’t close by itself.

Just made a search on the forum and found out that the issue happens to others as well:

Sorry to be so late to thank you for your input, but I was reluctant to post a negative answer and I was still hoping but up to now, even after the latest Lineage-Update) it is the same message: “Fehler bei der Push-Registrierung”. The Self-Check in Microg settings shows all green ticks, so nothing there. Maybe it is connected to my other problem, when I switch off data connection after having checked my emails, and swipe it on again, it will often (or never, but I am not sure of that) not connect again unless I restart the phone. But as said before, I can live with that.

I don’t use this myself, but perhaps registering manually would be worth a try …

1 Like