Update to Android 12 broke Switch App Button (Square)

Interesting thread about how to reproduce the error, possible fix and alternatives for the switch app button:
(FIX!!!) 3rd Party Launchers and the Recent Apps button issues, consistent replication.


Yes, but best to read the thread from the beginning. Thanks for the info, so conclusion is a reproducible problem observed with third party launchers.

@ansgar Can you confirm that turning animations off in Developer options, avoids the Switch apps button failure? Not a solution certainly, but a work-around.


@AxelWe I was actually able to reproduce the error this way now. Thanks for the hint!

@OldRoutard With AIO Launcher and animations enabled the error occurs when quickly pressing the switch app button, with animations disabled or with the Quickstep Launcher the error does not occur, so the workaround works. It does not seem to be a direct problem with the Fairphone 4 / Android 12.


I also have this issue with Lanwchair launcher.

And I have the problem with /e/ 1.8.1 and Bliss and Kiss launchers.

Restarting and the solution with the animation faktor from xda didn’t work either.

Quickly clicking the square brings the error “Trebuchet was closed repeatedly.”

After setting the Kiss launcher to “always active”, the problem was solved.

So, it was like this:

  1. Kiss was the permanent choice for the launcher and after the update to the last version of /e/ I got this problem.
  2. I did some tests, restarts and changed the launcher back to Bliss. But the problem still persists.
  3. After that I did switch back to Kiss, but when pressing the round button in the middle, I was still asked for which launcher I want to use and the problem was still there.
  4. I made Kiss the permanent choice again and the problem is fixed for now.
1 Like

Hey there,

Since the update, the square button for recent apps isn’t working properly anymore. I press it and nothing happens, which is quite annoying since you can’t switch apps anymore. Anyone has the same experience? Any known fix? I still prefer the 3 buttons navigation to the gestures.

Thanks a lot


At least on my site the button is working well… So seems not to be a general issue…

A reboot usually solves it, but it already showed 3 or 4 times

1 Like

Are you using a different launcher or the stock one?

1 Like


This was already discussed here Broke Switch App Button


Yes. However this is the first report I’ve seen of the problem on another ROM, so this is looking like a generic Android problem. I haven’t looked over at AOSP yet.

1 Like

Thank you all for the replies
I must have missed the topic that mentioned it already, but the common points seem to be

  • 3rd party launcher (for me microsoft launcher)
  • developer settings on with modification to animation speeds (I put them to 0.5, I’ll turn that off and see if it helps)

Here I am indeed on stock fairphone OS, but I did see the same issue for other phones following @AxelWe’s link, so it seems to be related to AOSP itself.

1 Like

This is a known bug with Android 12. In my case also sometimes only the launcher showed as “recent app” and nothing else and sometimes the button did not work at all.

According this thread in Reddit a possible workaround may be to enable the developer options and then set the “Animator duration scale” to “Animation off”. At least for me it seems to work so far. My theory is, that the recent apps will be shown using an animation and that animation sometimes crashes. By disabling animations completely, this can not happen any longer. Maybe you also need to restart device once or change from 3-button-navigation to gestures and back to 3-button-navigation once, so the recent apps button works again. But after that it should keep working with the animations turned off.

What is a bit worrying here - the bug seems to be known for at least one year(!). How can it be, that it is still not fixed?

Well, hardly a top priority, since there’s a work-around, some people (like me) turn off animations anyway (so I’ve never seen the problem), and maybe it’s already fixed in A13, for those who have already got there.

Even with the developer’s options off it seems to happen. I’ll try to put the animations to off.

Thank you all for the help

I did some more tests and it seems the problem only occurs when using a third party launcher.

As long as the default launcher “Quickstep” is used, even with animations turned on in the developer options, the “recent apps” button works without any problems. But as soon as I use another launcher, the recent apps crashes immediately when pressing the “recent apps” button quickly multiples times.

The issue seems to be, that the built in launcher - Quickstep - crashes. As soon as you force stop Quickstep in the app settings, the recent apps show again.

However there seems to be another workaround:

When I remove all data in Quickstep (Settings → Apps → All Apps → Quickstep → Storage and cache → Clear storage) “recent apps” now seems to work even with animtions turned on in the developer options. At least I can not get the thing to crash when I repeatetly press the “recent apps” button.

Edit: the problem returns when using Nova Launcher. However with “Ruthless Launcher” it seems to work - but only until you open the app drawer there :-(. So the launcher also affects this issue.

I remember a similar problem from my old Xiaomi phone with Android 11 - there it was the same: as soon as I used Nova launcher you may experience issues with the “recent apps” features and the symptoms where exactly identical. The same workaround was there also just to force stop the built-in launcher to make recent apps work again.

To me this looks like a deeper problem introduced at some point which is still present. Especially since this not only affects Fairphone 4 but also other devices and even older Android versions and other system launchers.

After I changed to the gesture navigation I finally come to the conclusion that the “classic” 3-button navigation is just broken since the gesture navigation was already introduced in Android 10 and is seen as the new standard for Android.

3-Button navigation:

  • Screen brightness slider is with with white symbols on a light blue slider - it still works this way but it looks somehow broken.
  • Recent apps only work if either you only use the built in launcher “Quickstep” or if you disable animations in the developer options.
  • Recent apps can be moved slightly upwards and stay there when animations are disabled. This seems to be a bug did not get fixed yet caused animations are usually not changed - because doing so is a developer options and not regular user setting.
  • The navigation buttons are sometimes displayed “white on white”, for example when opening the notification drawer which is displayed with a white background. You can still see the navigation buttons since they have a shadow, but this looks like a bug to me.

Gesture navigation:

  • Screen brightness slider is displayed properly with black symbols and not with white symbols on a light blue slider.
  • Activating the “recent apps” view always works, even with animations enabled in the developer options.
  • The buttom gesture bar is always display correctly and not “white on white” in some situation like the 3-button navigation. So when opening the notification drawer the navigation bar will turn dark as well as in apps which display a navigation bar with a white background like Vivaldi

It seems 3-button navigation is considered an outdated feature which is not really tested properly. I try to get used to the gesture navigation, at least it works much more reliable and predictable.

Does anyone know if the situation is better in Android 13? At least in Android 12 devices from other manufacturers seem to have the same issues with the navigation, so it’s not specific to the FP4 but more a problem of Android itself.


For completeness: this is a known bug and documented at Googles issue tracker:


1 Like

This issue has now appeared for the fourth time, prompting me to ask around if others can relate:
The multitasking button (“recent apps”) stops working. Until the phone is rebooted.
In the last case, the phone was in use but unresponsive for a few seconds. When working again, everything is fine apart from the multitasking button not doing its job.
I think I used the browser (Brave).
Anyone else experienced the same?

Yes see above its related to the launcher (when its not stock)

1 Like