English

Update gets stuck at "just a moment" after downloading

After numerous attempt to get update 1.3.6 to work I managed to do it direct from the phone memory, using Amaze to see where it was stored. Selected the zip file and the update worked well. I see the help section has been updated to suggest this as one of the options (Method 1 I think)

1 Like

Disable the sleep mode on your phone. Once the screen goes black, the process seems to stop. This did the trick for me.

Additional info: Settings -> Display -> Sleep : Put this to 30 mins and your update will go through normally. After upgrade set it back to whatever you want.

Hope this helped.

Alfi

2 Likes

Thank you so much, Irina!
That had been bugging me for weeks.

Thanks for this! I’ve been trying to sort this for weeks and it seems to have finally worked!

Hello everyone,

the Update to Open OS 16.06 has made my Fairphone 2 unusable. The update is trapped on the “Just a sec…” screen that runs infinitely. For better understanding, I will put this as a chart:

“Just a sec…”-Screen - -NEXT–> “Choose WLAN”-Screen (WLAN connected) --NEXT–> “Just a sec…”-Screen ----> Loop
"Just a sec…"-Screen --NEXT–> “Choose WLAN”-Screen (no WLAN) --SKIP–> SKIP ANYWAY --> “Choose WLAN”-Screen —> Loop

As you can see, I can do nothing, I always come back to the “Just a sec…”-Screen. Its very frustrating as I can not open any app (however tapping on notifications starts the app). Is there any way to skip the Update without loosing my user data via reset?

You could just press and hold “Volume +” and “Power” and hold and hold …
… until you see the recovery-screen. Wipe dalvik and cache, restart system

1 Like

First of all, thank you for your fast help.

I tried both solutions, but unfortunately they didn’t work. I set the display to never turn of, wiped Cache/Dalvik and started the update again. I left the phone active overnight and at the next mornig, it still needs "Just a sec…"
Any new suggestions?

Just to avoid confusion (as I think your post may have been mistakenly moved here): The screens you describe, do they occur when you try to log in to the phone for the first time after the update?
Also, which version were you on before the update?

1 Like

The screens I described in the prior post came after I started the Fairphone Updater, downloaded the update, waited for installation and then restarting the phone (as required).
Sorry, which version it was before I do not know. Right now it has the FP2-userdebug 5.1 FP2 fp2-sibon-16.06.0 Version.

Then ther is this:
https://forum.fairphone.com/t/pencil2-how-to-update-a-rooted-fp2-with-twrp/18948

I created a backup with TWRP and resetted the phone to factory settings. After booting, the “Just a sec…” Screen disappeared in seconds and I was able to use the phone as usual (of course without my data on it).
However, with my backup recovered, it is just like before. It has to be something connected to my apps, I suppose…

Well, that’s not surprising, as the TWRP backup makes an exact copy of your device’s file system. So whatever went wrong before is also safely stored and preserved for future generations on this backup :wink:
Thus, if you want to backup data, settings, and apps on a software-broken phone, I would recommend to also (or only) backup data manually, and/or apps and settings via titanium (or something similar).

1 Like

I pointed you to a post named “How to update a rooted FP2 with TWRP”. Within this post I have written about a backup, but in your action I miss “update”

@Spielmops I first tried the backup way because in the instructions you linked, one had to to downloads with the phone. However the “Just a sec…” Screen prevents me to start any app (for instance browser) and therefore I couldn’t download anything. Also I was not sure if this way would erase my data or not. Maybe you can answer this question?

You got me: I forgot to mention, that the update-procedure does not affect your data. Will update that post later. :frowning:

It’s easier to do the whole action incl. downloads from the phone, but if those downloads are not possible with the phone, you can gather the needed datas per PC and store them on sdcard.

@Spielmops I have a question on step 2 ("Download the new boot-image with root from here: http://siteactif.org/fp2/15.")

How do I know which file to download?

  1. Which Version? I downloaded the update to 1.5.1 in step 1, so do I need “FP2-gms59-1.5.1-ota/” ?
  2. There are several files:
    boot-FP2-gms56-1.4.2-ota-su-eng-r210.img
    boot-FP2-gms56-1.4.2-ota-su-nocrypt-r210.img
    boot-FP2-gms56-1.4.2-ota-su-noverity-r210.img
    Which one to pick?

Thank you in advance

http://siteactif.org/fp2/FP2-gms59-1.5.1-ota/boot-FP2-gms59-1.5.1-ota-su-eng-r218.img

1 Like

It worked! Thank you very much!! And all my data is still there. @Spielmops, you are my hero of the day :smiley:

One last question: It seems like I now have the standard version with google. Is there a version for the non-google version or a way to change it?

Yes.[quote=“Phoenix2222, post:74, topic:16372”]
a way to change it
[/quote]
Yes

Search here for your Live without Google …

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.