Update gets stuck at "just a moment" after downloading

Using the OS software update app:
it always gets stuck at “just a moment” after downloading the 1.2.8 update .

For how long did you wait? AFAIK, the updater has to copy the OTA file somewhere and since it is quite a big file, it might take some time (possibly even a couple of minutes).

Fixed it by going into the advanced mode and installing the update manually.
It gave me a warning that I am about to install an older version of the OS -
installed it anyways.
It is working fine now with the new version 1.2.8.

1 Like

I had this problem this morning. Just when I was about to lose patience, the update went on, it took about one hour ore perhaps more.So you should be patient.

was trying it for 8 hours over night…

I had a long waiting time after the download ended.

I am trying to update, but after downloading the file, the update stops. It asks me if i want to install the update,and restarts downloading the file again. This problem is occuring over and over again, and no update is going through.


Have you been trying updating using the advanced mode? You can access it in the software update app on the bottom.

Also clearing the cache of the software update app could be a thing to try

cleared cache, and tried it via advanced mode. It might be the case that memory is full.

Just to be sure: you did not have installed TWRP as an alternative recovery-program (e.g. for XPosed installation) before, right? In this case the automatic installation via Updater should not work Link1, Link2

cleaned memory and the update has gone through. I had only 0,91 GB left on my internal memory. Probably not enough for the update. Maybe a tip for the updater-app, show the user that memory could be a problem.


Hi all, I have the same: stuck in “just a moment” for almost 2hrs now. I don’t mind having to be patient (I read somewhere maybe even for 8hrs) just want to be sure I haven’t done anything wrong. My free memory is 22GB, battery is (was:-) fully charged, but dit not reboot before starting update. Should I have done that? And if yes, should I do a hard reboot now and start over again?

Thanks for your help.

See my post, try that if you get stuck for too long, it worked for me.

At my FP2, I must do 3 trys for a correct update! The 1. I interrupted this after 3 hours. The 2. is going overnight. At the 3. try I deactiveded the SD-Card! After the installation with 2 reboots, the sd-card was correct mounted.

I have the same problem even when I try manual installation, as suggested by @fosb - I can’t get pass the “just a moment”, no matter the method - and after reboot/restart it’s still the old OS version. I’ve tried both methods several times with the same result, I’ve restarted after some minutes and I’ve been waiting for hours and hours. No SD-card to deactivate…

Thanks @fosb

I am however definitely not an experienced user. Clearing cache I probably can figure out, but installing manually is too scary:-) So as long as I haven’t done anything wrong, I prefer waiting a bit longer…
If I’m still stuck tomorrow, I might come back to that and ask for training wheels ;-).

Actually installing manually isn’t really different to the update function.
You have to click two more buttons I think…
The advanced menu is giving you the option to install the new version
1.2.8, nothing to configure, no paths to set or so.
But after that the procedure is the same as with the update function,
the phone is doing the rest on its own

1 Like

Hi @fosb,

The update finished. It took 4 hrs or so, but then it started going and restarted. Thanks for your help anyway of course. I was happy to know I did nothing wrong to start with.

Regards Mariekekeke

I did the update with the ‘advanced mode’, but again it’s already 1 hour on the “wait an instant”-screen… Before, I tried it 3 times with the automatic update and the last time was already for 3 hours on the “wait an instant”-screen.