Update gets stuck at "just a moment" after downloading

If I try to update my fairphone 2 to the newest version, it ceases and doesn’t continue! After downloading there is always this message “Please be patent” and the little wheel is turning. I can’t get further to the “Rebooth” or “abort” fields…

Thank you & cheers from Switzerland

I moved your post here where you should find some answers.

Avoid that your phones enter standby mode during the update. You can do so by:

  • Taping on the screen from time to time
  • Set the “sleeping” time to the maximum (30 minutes) in Settings --> Display --> Sleep
  • Settings --> Developer options --> enable “Stay awake” (phone must be connected to charger)

perfect, thanks Paul!

Thank you Irina! I’ll try again… :slight_smile:

thank you all for the help. Johannes solution did the trick for 1.2.8 and setting the display timeout to 30 minutes made the 1.3.6 update happen. [quote=“Johannes, post:24, topic:16372”]
approach 2 in the help desk article.

Sadly the 1.3.6 Update brought me a new bug. Directly after the update I recognised, that I can not reach the P on the keyboard anymore. This made me install a Screen Touch Test App which showed a 5 mm area on the right site of the screen where the Touch is not working. See the attached pictures:

Is this a common error with the new update or am I the first to report it? I did a quick Forum search but couldn’t find similar errors. Seams to be clearly software/update related as I recognised it first just a few minutes after the update.

Kind regards, Andreas

I see you’ve already found the main topic on the issue (here). I had the impression that for most people the occurrence has been random, but it could be that it has a higher chance of appearing when the phone has been under higher workloads for a while (an the update seems to be quite a lot of work for the phone). That would explain why for some people it occurs after the update.

As it’s not a general problem with the update, it’s probably best to keep the discussion about the screen in the linked topic for now.

After numerous attempt to get update 1.3.6 to work I managed to do it direct from the phone memory, using Amaze to see where it was stored. Selected the zip file and the update worked well. I see the help section has been updated to suggest this as one of the options (Method 1 I think)

1 Like

Disable the sleep mode on your phone. Once the screen goes black, the process seems to stop. This did the trick for me.

Additional info: Settings -> Display -> Sleep : Put this to 30 mins and your update will go through normally. After upgrade set it back to whatever you want.

Hope this helped.



Thank you so much, Irina!
That had been bugging me for weeks.

Thanks for this! I’ve been trying to sort this for weeks and it seems to have finally worked!

Hello everyone,

the Update to Open OS 16.06 has made my Fairphone 2 unusable. The update is trapped on the “Just a sec…” screen that runs infinitely. For better understanding, I will put this as a chart:

“Just a sec…”-Screen - -NEXT–> “Choose WLAN”-Screen (WLAN connected) --NEXT–> “Just a sec…”-Screen ----> Loop
"Just a sec…"-Screen --NEXT–> “Choose WLAN”-Screen (no WLAN) --SKIP–> SKIP ANYWAY --> “Choose WLAN”-Screen —> Loop

As you can see, I can do nothing, I always come back to the “Just a sec…”-Screen. Its very frustrating as I can not open any app (however tapping on notifications starts the app). Is there any way to skip the Update without loosing my user data via reset?

You could just press and hold “Volume +” and “Power” and hold and hold …
… until you see the recovery-screen. Wipe dalvik and cache, restart system

1 Like

First of all, thank you for your fast help.

I tried both solutions, but unfortunately they didn’t work. I set the display to never turn of, wiped Cache/Dalvik and started the update again. I left the phone active overnight and at the next mornig, it still needs "Just a sec…"
Any new suggestions?

Just to avoid confusion (as I think your post may have been mistakenly moved here): The screens you describe, do they occur when you try to log in to the phone for the first time after the update?
Also, which version were you on before the update?

1 Like

The screens I described in the prior post came after I started the Fairphone Updater, downloaded the update, waited for installation and then restarting the phone (as required).
Sorry, which version it was before I do not know. Right now it has the FP2-userdebug 5.1 FP2 fp2-sibon-16.06.0 Version.

Then ther is this:

I created a backup with TWRP and resetted the phone to factory settings. After booting, the “Just a sec…” Screen disappeared in seconds and I was able to use the phone as usual (of course without my data on it).
However, with my backup recovered, it is just like before. It has to be something connected to my apps, I suppose…

Well, that’s not surprising, as the TWRP backup makes an exact copy of your device’s file system. So whatever went wrong before is also safely stored and preserved for future generations on this backup :wink:
Thus, if you want to backup data, settings, and apps on a software-broken phone, I would recommend to also (or only) backup data manually, and/or apps and settings via titanium (or something similar).

1 Like

I pointed you to a post named “How to update a rooted FP2 with TWRP”. Within this post I have written about a backup, but in your action I miss “update”