Update gets stuck at "just a moment" after downloading

My phone has downloaded the update and I clicked reboot but now it’s stuck off and won’t turn on again. Going to try some of the things suggested in this thread (taking out battery, replacing it and then plugging it in for example). Very annoying as I rely on my phone for work.

In the Facebook group Fairphone-Freunde some people observed that the FP2 doesn’t get stuck if the screen can’t go off or the phone can’t enter standby mode. This can be done by taping in the screen from time to time or by changing the settings (Settings --> Display --> Sleep --> 30 minutes) orr (Settings --> Developer options --> Stay awake).

1 Like

Just plugged it in and it started up again, with battery now at 1%. Seems like the update drained the power totally or something?

Well, I think the updates always should be done with a full battery or connected to a charger.

Hello cstypka,

sorry that it took mr so long to answer your mail. I have been traveling up the west coast and I didn't have internet. Yet I didn't try to update the system. Also I am back in Germany and can't reproduce your exact problem. Nevertheless I'll try to update it today to see if I run into the same issue.

Best regards,


I have this issue too. Along with ALL of the known software issues! Help!

It’s hours I’m trying to update it… It takes a huge amount of time…
“just a moment” for hours…

If I try to update my fairphone 2 to the newest version, it ceases and doesn’t continue! After downloading there is always this message “Please be patent” and the little wheel is turning. I can’t get further to the “Rebooth” or “abort” fields…

Thank you & cheers from Switzerland

I moved your post here where you should find some answers.

Avoid that your phones enter standby mode during the update. You can do so by:

  • Taping on the screen from time to time
  • Set the “sleeping” time to the maximum (30 minutes) in Settings --> Display --> Sleep
  • Settings --> Developer options --> enable “Stay awake” (phone must be connected to charger)

perfect, thanks Paul!

Thank you Irina! I’ll try again… :slight_smile:

thank you all for the help. Johannes solution did the trick for 1.2.8 and setting the display timeout to 30 minutes made the 1.3.6 update happen. [quote=“Johannes, post:24, topic:16372”]
approach 2 in the help desk article.

Sadly the 1.3.6 Update brought me a new bug. Directly after the update I recognised, that I can not reach the P on the keyboard anymore. This made me install a Screen Touch Test App which showed a 5 mm area on the right site of the screen where the Touch is not working. See the attached pictures:

Is this a common error with the new update or am I the first to report it? I did a quick Forum search but couldn’t find similar errors. Seams to be clearly software/update related as I recognised it first just a few minutes after the update.

Kind regards, Andreas

I see you’ve already found the main topic on the issue (here). I had the impression that for most people the occurrence has been random, but it could be that it has a higher chance of appearing when the phone has been under higher workloads for a while (an the update seems to be quite a lot of work for the phone). That would explain why for some people it occurs after the update.

As it’s not a general problem with the update, it’s probably best to keep the discussion about the screen in the linked topic for now.

After numerous attempt to get update 1.3.6 to work I managed to do it direct from the phone memory, using Amaze to see where it was stored. Selected the zip file and the update worked well. I see the help section has been updated to suggest this as one of the options (Method 1 I think)

1 Like

Disable the sleep mode on your phone. Once the screen goes black, the process seems to stop. This did the trick for me.

Additional info: Settings -> Display -> Sleep : Put this to 30 mins and your update will go through normally. After upgrade set it back to whatever you want.

Hope this helped.



Thank you so much, Irina!
That had been bugging me for weeks.

Thanks for this! I’ve been trying to sort this for weeks and it seems to have finally worked!

Hello everyone,

the Update to Open OS 16.06 has made my Fairphone 2 unusable. The update is trapped on the “Just a sec…” screen that runs infinitely. For better understanding, I will put this as a chart:

“Just a sec…”-Screen - -NEXT–> “Choose WLAN”-Screen (WLAN connected) --NEXT–> “Just a sec…”-Screen ----> Loop
"Just a sec…"-Screen --NEXT–> “Choose WLAN”-Screen (no WLAN) --SKIP–> SKIP ANYWAY --> “Choose WLAN”-Screen —> Loop

As you can see, I can do nothing, I always come back to the “Just a sec…”-Screen. Its very frustrating as I can not open any app (however tapping on notifications starts the app). Is there any way to skip the Update without loosing my user data via reset?

You could just press and hold “Volume +” and “Power” and hold and hold …
… until you see the recovery-screen. Wipe dalvik and cache, restart system

1 Like