Update 6.A.020.0 - Android 13 - Mobile Data not working after update

I just did update 6.A.020.0 and restarted my phone. Unfortunately my mobile data is not working.
I tried everything (restarted my phone, changed the APN etc).

In case that would matter, I’m based in Singapore.


A post was split to a new topic: :de: Probleme mit WLAN Verbindung

For me, mobile data only worked after second restart, weirdly enough.

1 Like

Same here, since update no data connection. Live in Belgium

1 Like

Try multiply restarts.


I hat a similar issue (yet not the same: my mobile data did not work after using a WiFi), after Airplane-Mode-Off-On Mobile data came back, and fiddling with die APN, or just another restart, or idk-what, may have fixed it.

Not sure if fiddling will help you, though, your descriptions sound more serious to me …

Yep! That did the trick. Hard to believe that it takes several reboots but now my data is back! Thx a bundle!


same here, after 3 reboots my data is finally back. Would be great to have some further explanation from the Fairphone team so we can understand better what happened…


Had the same problem with Tele2 (now known as Odido). After the second restart the Internet connection via mobile keeps working.


Same proleme here
i discovered that mobile data was enabled on both sim card
i disabled it on the main, reenabled it, it asked me something like “Do you want to use this sim for data” i said yes, and hourra !

i think the settings are f**ked up after the update
so disabling/reenabling data in the sim card helps.


2 posts were merged into an existing topic: Mobile data tile no longer exists in latest update

Having the same problem here. Germany, Telekom network.
This is a problem I had after almost every single system update. Except once, when it just worked after update, as far as I can remember … and I guess it was the mayor update to Android 13.
Usually it started working after a reboot.
Not this time. Will try now multiple restarts.

Same here with odido. I had already tried a restart. Turning the simcard on and off for four times helped.


Toggle ‘use sim’ in settings/sims (twice) worked for me.

1 Like

3 posts were split to a new topic: Mobile data problem - Android 13

A post was merged into an existing topic: Mobile data problem - Android 13

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.