English

🇩🇪 Update 19.08.1 und Probleme

Tags: #<Tag:0x00007f05d43f1a20>

Hallo Fairphone Freunde und Fairphone Team,

nachdem mein FP2 seit längerem Probleme mit der Telefonverbindung hatte, funktioniert diese nun wieder einwandfrei. Leider stellt das FP2 nun keine Wlan Verbindung mehr her. Ich weiß das es schon ein solches Themengebiet giebt, dass nun aber doch schon vor mehr als 1,5 Jahren gestartet wurde und nicht viel neues hergiebt.
Liebes FP Team, es kann doch nciht sein dass ein solches Problem bereits seit so langer Zeit bekannt ist und es keine Lösong Eurer seits gibt!!
Soll ich mir jetzt einen Vertrag mit einem größeren Datenfolumen zulegen, weil dass teuer gekaufte Gerät nicht macht was es soll.

Hat vieleicht dch noch jemand einen Vorschlag?
Vielen Dank schon mal

3 Likes

Exakt dasselbe Problem habe ich auch…
Mein WiFi Router kann auf 2.4 GHz und auf 5 GHz senden… Mein PC nur auf 2.4 GHz empfangen… daher MUSS ich das 2,4 GHz Band verwenden.
Bis zum Update auf 19.08.1 hat das FP2 auch dieses 2.4 GHz Band verstanden. Nun leider nicht mehr… Bitte achtet darauf, dass das 2.4 GHz Band ASAP wieder funktioniert, mit eurem OS, denn die Welt ist voller 2.4 GHz Router!

Danke!

@Wasn_los
Könntest du vllt ein bisschen präsizer sein ? Was genau funktioniert, wann funktioniert es nicht ? etc…
@FP2CS
Mein Router sendet auch auf 2,4 GHz und es funktioniert…Was passiert nach einem Neustart/ Flugmodus ?

Hallo Milo,
nach den Update wird meine WiFi Verbindung zuhause zwar angezeigt, Verbindung gespeichert, aber das Telefon verbindet sich nicht. Habe den Router neu gestartet, die die WiFi Liste auf dem Telefon gelöscht, mich neu eingeloggt, den Flugmodus de- und wieder aktiviert. Immer das gleiche Ergebnis, Verbindung gespeichert, aber kein Anmelden möglich.

1 Like

Mir geht es auch so. Upgrade gemacht und jetzt geht WLAN nicht mehr. Das Problem habe ich aber schon länger - seit Upgrade auf Android 7. Vor dem letzten Upgrade konnte ich mir aber noch helfen indem ich den Flugmodus aktivierte und wieder deaktivierte. So fand das WLAN das FP2. Aber jetzt funktioniert auch dieser Trick nicht mehr.
Es liegt also eindeutig am Upgrad. Hier sind schon einige Kommentare deswegen. Also wir sind nicht allein. Fairphone sollte sich ziemlich schnell Gedanken machen das Problem zu lösen.

Es war mir möglich ein Workaround für bei mir Zuhause zu erstellen.

Scheinbar hat das FP Probleme mit WPA2 und WPA+WPA2 VerschlĂĽsselung.

Als Workaround habe ich mir in meinem Router (eine FRITZ!Box 7312) einen Gastzugang speziell fĂĽr mein FP angelegt unter:

Browser deiner Wahl (FireFox / Chrome) -> fritz.box in die Leiste eintippen um in das RoutermenĂĽ zu kommen -> ggf. Password eingeben -> linke Seite: MenĂĽpunkt WLAN -> Gastzugang:

SSID vergeben, Verschlüsselung auf WPA (TKIP) oder ähnlich lautend setzen, Netzwerkschlüssel vergeben, in eventuellen Haken darunter so viel wie möglich erlauben.

Theoretisch ist es natürlich auch möglich, direkt das gesamte WLAN auf WPA umzustellen, aber persönlich würde ich davon aus Sicherheitsgründen abraten.

Nachtrag: Workaround funktioniert natĂĽrlich nicht fĂĽr Netzwerke, auf die ihr keinen Einfluss habt (Uni, Arbeit, etc) - hier muss das FP-Team nachhelfen, mMn

4 Likes

Ich komme auf meine 2.4 GHz Theorie, ich ich einen Dualband Router habe, und wenn ich das 5 GHz Band wähle kann ich mich mit dem FP2 anmelden.
Ich bin ebenso wie @Wasn_los schon viele Optionen durchgegangen:

  • FP2 Neustart (in gewisser Weise war es das, was ich durch das Update beheben wollte; denn seit dem letzten Update hatte mein FP2 immer mal wieder das Problem, sich nicht auf bekannte WiFis zu connecten. Ein Neustart hatte das stets gelöst… daher war auch dieses Mal der Neustart meine erste Variante)
  • bekannte Netzte Liste leeren
  • die SSID immer wieder entfernen und das Passwort damit neu eingeben.
  • den Router neu starten
  • den Router auf 5 GHz umstellen (womit mein Laptop aber leider nicht kann, weil er ein alter Haudegen ist - weshalb ich wieder auf 2,4 GHz zurĂĽckgestellt habe)

Aus meiner Sicht liegt es also an der Bandbreite (weil auch beim 5GHz Band eine WPA2 Verschlüsselung eingestellt war)… andererseits ist mir aber auch dort aufgefallen, dass keine automatische Verbindung erfolgt sondern man die SSID immer manuell wählen und den Key jedes Mal eingeben musste… also vlt. doch auch was mit dem WPA2?! Ich versuche mal, diese Lösung mit dem Gastzugang bei mir nachzustellen… hab halt leider einen anderen Router, aber wird’s schon irgendwie auch geben…
EDIT: Einen Gastzugang kann ich bei mir leider nicht erstellen :frowning:

Danke für die Hilfe/Anteilnahme…
Trotzdem hoffe ich, dass es bald ein Update gibt, welches dieses offenbar verbreitet auftretende WiFi Problem behebt!

WiFi funktioniert hier in beiden, 5GHz und 2,4GHz, mit dem 2019.08.01 Update, Fairphone OS.
Es verbindet zu beiden Frequenzen. Ich nutze dabei aber nur public WiFi also keinerlei WPA WEP oder WPA2.

I have the same problem here in the Netherlands. No connection to wifi anymore.

Mag jemand von euch, die Probleme mit dem WLAN haben, Logs mitschneiden, während ihr erfolglos eine Verbindung zu dem WLAN herstellt?

(Ich habe bisher keine Probleme, habe ein 5GHz- und ein 2.4GHz-WLAN mit WPA/WPA2-PSK getestet.)

08-29 15:45:23.406 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:45:28.347 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:45:38.327 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:45:48.308 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:45:58.292 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:46:06.817 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:46:18.359 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:46:28.328 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:46:38.391 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:46:42.130 1821 2873 E WifiConfigStore: Failed to look-up a string: WPA_PSK
08-29 15:46:42.208 1821 2875 E SupplicantWifiScannerImpl: Failed to start scan, freqs=null
08-29 15:46:42.211 1821 2873 E WifiConnectivityManager: SingleScanListener onFailure: reason: -1 description: Scan failed
08-29 15:46:42.236 1821 2873 E WifiHAL : wifi_get_ring_data: Error -95 happened.
08-29 15:46:42.236 1821 2873 E WifiHAL : wifi_get_ring_data: Error -95 happened.
08-29 15:46:42.236 1821 2873 E WifiHAL : wifi_get_ring_data: Error -95 happened.
08-29 15:46:42.236 1821 2873 E WifiHAL : wifi_get_ring_data: Error -95 happened.
08-29 15:46:42.236 1821 2873 E WifiHAL : wifi_get_ring_data: Error -95 happened.
08-29 15:46:42.362 1821 2873 E WifiStateMachine: Supplicant SSID temporary disabled:ID: 1 SSID: “MEINE NETZWERK SSID” PROVIDER-NAME: null BSSID: null FQDN: null PRIO: 6 HIDDEN: false
08-29 15:46:42.362 1821 2873 E WifiStateMachine: NetworkSelectionStatus NETWORK_SELECTION_ENABLED
08-29 15:46:42.362 1821 2873 E WifiStateMachine: hasEverConnected: false
08-29 15:46:42.362 1821 2873 E WifiStateMachine: update time=08-29 15:46:42.123
08-29 15:46:42.362 1821 2873 E WifiStateMachine: creationtime=08-29 15:44:59.848
08-29 15:46:42.362 1821 2873 E WifiStateMachine: KeyMgmt: WPA_PSK Protocols: WPA RSN
08-29 15:46:42.362 1821 2873 E WifiStateMachine: AuthAlgorithms:
08-29 15:46:42.362 1821 2873 E WifiStateMachine: PairwiseCiphers: TKIP CCMP
08-29 15:46:42.362 1821 2873 E WifiStateMachine: GroupCiphers: TKIP CCMP
08-29 15:46:42.362 1821 2873 E WifiStateMachine: PSK: *
08-29 15:46:42.362 1821 2873 E WifiStateMachine: sim_num *
08-29 15:46:42.362 1821 2873 E WifiStateMachine: Enterprise config:
08-29 15:46:42.362 1821 2873 E WifiStateMachine: altsubject_match NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: password
08-29 15:46:42.362 1821 2873 E WifiStateMachine: ca_path NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: subject_match NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: engine 0
08-29 15:46:42.362 1821 2873 E WifiStateMachine: client_cert NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: anonymous_identity NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: ca_cert NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: identity NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: domain_suffix_match NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: key_id NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: engine_id NULL
08-29 15:46:42.362 1821 2873 E WifiStateMachine: IP config:
08-29 15:46:42.362 1821 2873 E WifiStateMachine: IP assignment: DHCP
08-29 15:46:42.362 1821 2873 E WifiStateMachine: Proxy settings: NONE
08-29 15:46:42.362 1821 2873 E WifiStateMachine: networkSelectionBSSID=any cuid=1000 cname=android.uid.system:1000 luid=1000 lname=android.uid.system:1000 lcuid=1000 userApproved=USER_APPROVED noInternetAccessExpected=false isCarrierNetwork=false roamingFailureBlackListTimeMilli: 1000
08-29 15:46:42.362 1821 2873 E WifiStateMachine: triggeredLow: 0 triggeredBad: 0 triggeredNotHigh: 0
08-29 15:46:42.362 1821 2873 E WifiStateMachine: ticksLow: 0 ticksBad: 0 ticksNotHigh: 0
08-29 15:46:42.362 1821 2873 E WifiStateMachine: triggeredJoin: 0
08-29 15:46:47.656 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:46:56.688 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:47:05.725 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:47:18.418 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.
08-29 15:47:25.386 1821 2873 E WifiConfigStore: Failed to look-up a string: WPA_PSK
08-29 15:47:28.403 1821 2873 E WifiQualifiedNetworkSelector:: MEINE NETZWERK SSID:5c:49:79:2a:a2:5a is in blacklist.

Gibt es eine elegantere Methode logs als Dateianhang hochzuladen?

Nachtrag: Verbindungsversuch geht auf eine FRITZ!Box 7312 mit 2,4GHz und WPA+WPA2

2 Likes

Selbes Problem hier, ich kann mich an meinem WLAN (devolo Powerline/WIFI) zu Hause nicht mehr anmelden. Es schien einmal kurz zu funktionieren, jetzt geht es aber dauerhaft nicht mehr.

Ich habe genau das gleiche Problem und direkt einen Support Request geschickt. Dort ist aber leider eher eine Abwimmelungsstrategie am Start.

1 Like

@Milo.E ich habe alles versucht: WIFI an- und abgeschaltet, Flugmodus an- und abgeschaltet, Fairphone neu gestartet, WLAN-Verbindung auf dem Fairphone entfernt und komplett neu eingegeben (mit korrektem Passwort!) und WLAN-Router an- und abgeschaltet. Hat alles nichts gebracht.
FĂĽr mehr technische Analyse reicht mein Wissen (und auch meine Geduld) leider nicht aus.

2 Likes

Ich schaff’s leider selbst nicht, einen Log zu erstellen… hab alles installiert wie in den Guids aufgelistet… wenn ich ADB -> Connect to device mache und die IP Adresse aus dem Status meines FP2 eingebe passiert aber nix… ist wohl alles sehr mühsam und für jmd. der das nicht versteht etwas zu kompliziert?!

Beim Log ist ja MEINE NETZWERK SSID “is in blacklist” sehr auffällig… wie kommt wohl so eine SSID in eine Android/Fairphone-Blacklist?
Hab jedenfalls aus blanker Freude mal meine SSID geändert… hat aber trotzdem nicht funktioniert, mich mit dem FP2 zu verbinden…

1 Like

Dass es in “Public”-Netzwerken noch funktioniert kann ich bestätigen. Surfe gerade ohne Probleme im ICE.

Es scheint da irgendein Problem mit WPA2 zu geben wie es scheint, vielleicht verschärft durch PMF (protected management frames). Das größte Problem ist allerdings die nicht vorhandene Kommunikationsstrategie von Fairphone, also endlich mal zu informieren wie es weitergeht. Dieser Bug hätte VOR der Veröffentlichung des FP3 irgendwie gelöst werden MÜSSEN, das Problem ist seit Monaten oder sogar weit über nehm Jahr bekannt…

2 Likes

Ich bin auch an Board mit dem Problem. Allerdings nur in meinem Heimnetzwerk, bei einem anderen häufig genutzten Wlan funktioniert es einwandfrei.

Ich war immer mit WPA/WPA 2 PSK mit unserem Netzwerk verbunden. Unser Router hat nicht die Auswahl zwischen 2,4 GHz und 5 GHz. Also das kann es nicht sein… Die Workarounds von Bugs #36 und #87 bringen mich absolut nicht weiter.

3 Likes

Haben alle, die Probleme haben, auch eine FritzBox?
Dann schaut euch mal den folgenden Artikel an: PCWelt
Die FritzBox nutzt bei 5GHz ggf. mehr Kanäle, als viele Geräte unterstützen.
Als ich die FritzBox auf die Standardkanäle eingestellt hab, hat bei mir alles funktioniert.

3 Likes

Thanks I will. Try this. i habe indeed a fritzbox