[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

Solved: the solution is to install version 20160106 rather than 20160108 of GApps
Different Gapps releases can be acessed from https://github.com/opengapps/arm/tags
I also wiped wiped cache and dalvik-cache first, though I don’t know whether that was necessary
Thanks joagri!

Thanks for the updated ROM. The updated ROM is fine, but when I try to install the latest GApps, with

adb sideload open_gapps-arm-4.4-nano-20160108.zip

the install fails with the following

- Installing updated GApps
E:Error in /tmp/update.zip
(Status 2)
Installation aborted

I can install the previous version open_gapps-arm-4.4-nano-20151225.zip with no problems.
I’ve Googled the error but not come across an obvious fixes. Any clues or suggestions?



Hello Pete, reboot into recovery and install gapps this way (from sdcard) . Worked without any problems with me.

How does that work with GApps? I often see people suggesting installing newer GApps but doesn’t Android update the GApps to the latest version through the Play Store itself?

I downloaded open_gapps-arm-4.4-nano-20160106.zip not open_gapps-arm-4.4-nano-20160108.zip. Maybe thats important???

… and also wiped cache and dalvik-cache first…

I just tried with a jawbone up2 and I was able to pair and connect and use the jawbone up software from the playstore.

So I think that BT LE seems to work at least to some extend.


PS: I also have a fitbit somewhere but can’t find the charger.

My experience is that it works to some extent, but is still a bit flakey :slight_smile: . A particular problem I have noticed is automatic re-connections, which often just do not happen. This is not confined to BLE: I have problems with the following devices, only the first of which is BLE:

  1. [Garmin VivoActive GPS Smartwatch with Sports Apps:][1] this is BLE, and I think its own BT implementation is a bit flakey. Works OK immediately after both devices are powered on, but re-connects fail after subsequent disconnections. This did not work with the old FP Stock ROM as that did not have BLE

  2. [IOPlay 2 Bluetooth handsfree car kit][2] (Not BLE) Connections are sometimes incomplete: the IOPLay shows the phone as being connected, but the phone does not respond to music controls, and music playing on the phone is not play through the handsfree. This mostly worked OK with the old FP stock ROM

  3. [BoomBar Portable Rechargeable Bluetooth Speaker][3] Agin re-connections sometimes fail. To play music through the Boombar I often have to initiate the connect manually from the BT Settings page on the phone

I know this stuff is tricky, and it’s hard to reproduce the problems deterministically. Let me know if I can help, by providing log files or anything else.

Thanks again for all you work on this ROM!

[1]: http://explore.garmin.com/en-GB/vivo-fitness/
[2]: http://www.my-io.com/products/io-play2-overview/
[3]: http://www.mobilefun.co.uk/kitsound-boombar-portable-rechargeable-bluetooth-speaker-black-p40120.htm


Dear chrmhoffmann… Kindly provide the Download link for update ROM fp1-kk444-CH-0.9.3

It’s in the first post of the topic over at XDA (here) - the link you want should be: https://basketbuild.com/filedl/devs?dev=chrmhoffmann&dl=chrmhoffmann/fp1-kk-stock/fp1-kk444-CH-0.9.3.zip


Do you think it would make sense to merge this thread with the howto (=to put the HOWTO as a wiki on top of this thread and freeze the old one, maybe?). So that people will find the links faster and can make the updates if needed? Just an idea. Maybe it’s okay the way it is. XDA is mentioned on it. It’s still important people compare checksums.

All – the part on how to install all the FP apps back on the phone needs some love. If someone wants to extent that part (download the image, extract and sideload the apks) – go wild :slight_smile: In the end of the HOWTO a FP1 should look like 4.4.2 FP1 … just with 4…4.4.

Thanks @fp1_wo_sw_updates & @Johannes. I downloaded the latest zip and installed it with old GApps as the link provided by @petefoth did not work for me. because, previously GApps files were 84 MB and this time, may be i m wrong, it rises beyond 1 GB. Any idea?.. sorry for poor English. Maybe @petefoth can explain this. thanks all of you and especially @chrmhoffmann for hard work

Are you sure you are selecting the right version? It has to be the nano package for version 4.4 on an ARM SoC. That’s still ~84 MB.

Edit: It doesn’t have to be the nano package. You can choose any of the provided packages. But the larger packages likely contain many apps you won’t ever use.

Ya it was a zip file in the page i selected. However, i got it from website quoted by @Johannes. Thanks again all of you

Hey guys,

I’m using chrmhoffmanns ROM now for two days and it’s working really well. I couldn’t find any problem till now. My system runs without google but with xposed and gravity.

Thank you chrmhoffmann and thanks to this awesome community, your wiki (https://forum.fairphone.com/t/unofficial-pencil2-howto-testing-the-latest-unofficial-4-4-4-rom-and-switching-back-to-fp-os-again-for-unix-fp1/11024) helped me a lot!

1 Like

Hello everyone,

I have install chrmhoffman ROM (fp1-kk444-CH-0.9.3 zip) and i’m very happy about.I want to thank all of you very much for your work and your time you spent on it, especially chrmhoffmann.
I have try it now about 1 month and everything seems to be good.
For me, because of my work, it is necessary, to use the screen-Mirroring. This morning I try two different miracast dongle, but nothing happens. I don’t know whats wrong.
There were no problems with the original rom. Does anyone have a solution?


I don’t have a miracast dongle, so I can’t tell.


I don’t have one, but what brand/model do you have exactly?

On which side do you think you have the problem? The phone side or the TV side? Can you “see” if the phone “accepts” it? Can the phone “find” the other screen/TV?

I think some people in the forum got something up & running.

If all else fails, there is still Chromecast made of course by Google …

Under 4.4.4 "Settings > Display > Cast screen" looks promising.

Anyway, before buying anything more I think it’s best to ask the support what really works with the phone and what does not. And please publish what they tell you here! Good luck!

1 Like

I was not able to pair a Polar H7 heart rate monitor. So not all BT LE devices seem to work.

Thanks for your answer.
I tried Samsung AllShare Cast and an integrated adapter.
The problem is on the Phone side, because before flashing the phone, (FPU-1) I have no problems.
Before I also tried EZ-Cast, netgear ptv2000, Samsung AllShare Cast, and several integrated dongles. No problems with allt these dongles.
My phone doesn’t see any dongle. I was activated the ScreenMirorring, but I can’t see any dongle.

So it worked before on the stock FP1 software? This is interesting to know. Maybe it’s a change in the Android version or missing software (bin blobs?). Sorry I cannot help you here, but maybe those hints (=worked before) could be useful for @chrmhoffmann.