[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

Hi joagri,

Thanks again, I will try it ASAP :smiley:

Hi. Bear with me, first post to the forum and all, wanted to say a couple of things:
First a massive thanks to @chrmhoffmann for making android 4.4 on fairphone a reality, I can’t imagine the time you’ve put in to this. Secondly thanks very much to anyone who contributed to this excellent guide. II’d installed custom ROMs on previous phones but having felt no need to with my fairphone up to now I really had forgotten how to do most things.

The update mostly went really smoothly, although I did get the problem with the phone being stuck between the “android” and “loading” screens. Had to use the buttons to turn it off and boot into recovery as I couldn’t get it to do so with adb, but once I did and wiped data all worked alright. Really impressed with the boot time and android 4.4 does feel that little bit snappier. The only problem I’m having still though is kind of to do with why I upgraded - the bluetooth.

I got a fitness tracker band from my fiancee’s family for Christmas which required bluetooth LE. A quick google told me the fairphone hardware would support it but not the software currently, hence the sudden interest in updating. Unfortunately despite the update I still can’t get this to work.

The particulars: I’m trying to connect to a Jawbone UP24. As the instructions say to do I start their app, follow the steps to turn the band on and then try to get it to pair with my phone. It always times out and tells me the device can not be found regardless of soft resets, app restarts, phone reboots etc. This sounds very similar to the problem Pete was having with his Garmin watch. Unfortunately while I can see the device in settings/bluetooth I can’t seem to pair with it - I either get an incorrect PIN message or else the bluetooth appears to reset itself when attempting to do so.

Not sure if there will be much anyone can do to help me out with this, but thought I would make sure I mention the problem for the sake of ongoing development anyway. Many thanks again, and Happy Christmas.

1 Like

Welcome to the forum, @d_swordfish! Why not introduce yourself here? :slight_smile:

I hope you can find a solution to your problem!

Merry Christmas! :slight_smile:

My gf is thinking of buying fitbit devices for both herself and me, but as you may guess: Bluetooth LE.
That problem might be solved by installing 4.4.4. Is anyone using a fitbit with their FP1?

Also, can someone give a summary of the most recent 4.4.4 release? What’s still missing/broken?

Best would be to go to a store and try the device before buying it. :slight_smile:

I didn’t get the Fitbit connected. The app sees the device, but can’t connect. Similar to what d_swordfish experiences.

Michel

Maybe @chrmhoffman could make it work, if you send it to him?

Thanks for the offer to fix issues. I’ve encountered one:
I’m a blau.de customer which uses the E-Plus (and now also O2) network in Germany. The roaming issues was fixed by Fairphone as discussed in this thread.

Unfortunately I can’t give you mmc/mmn data since I don’t know what that is (and googling didn’t help). My only guess is that this is a typo and you mean MCC/MNC. These seem to be the following for my provider blau.de (second source):

MCC: 262
MNC: 03

I don’t know whether this is the correct information to make usage of both O2 and E-Plus network work, though.

I’d be happy to hunt for more information if necessary.

1 Like

That is probably an option. How can we arrange this?

I haven’t read about other people experiencing problems with automatically connecting to wifi networks. Am I the only one having this problem?

Best regards, Michel

I have version 0.9.2 and haven’t had any problems yet.

Had some really weird things happen with my phone this week after installing the custom ROM. After a few hours switched off my phone booted into android 4.4, but a load of stuff no longer worked. No amount of resets, taking battery out, changing settings seemed to make any difference. Ended up having to wipe user data and start fresh. Next day the same thing happened! Have returned to the standard fairphone OS for now as I need to use the phone but I’ll be continuing to lurk and will probably give it another go soon.

Full(ish) list of symptoms:
Lock screen not appearing
Home button inactive, both long and short press - vibrates but does nothing
Buttons in swipe down menu (e.g. wifi on/off) cannot be reached
All settings returned to default values (e.g. wifi turned off, input methods back to defaults)
Off button long press no longer shows sound profiles - just option to shutdown

1 Like

You can try [this thread][1]. Read carefully and do the same
[1]: [FP1(U)] Baseband software unknown)

I once installed the Cyanogenmod for FP1 and suddenly started having lots of random issues, some similar, some different from yours. After lots of hard resets I found that the problem was a large useless .zip file using all of the cache partition. I erased it and it returned to normal. Take a look if there’s such a file in your phone.

Changelog fp1-kk444-CH-0.9.3 - also you might want to check if there are new gapps here and flash at same time: http://opengapps.org/?api=4.4&variant=nano

Enjoy

6 Likes

Everything runs well, thank’s a lot for your excellent work

I would like to install this on my FP1 but I’m a bit scared… not being a programmer and all. What do I need to know?

Thanks

Look in this first post and follow the link to the xda-developers forum.

1 Like

Thanks for the quick fix. Unfortunately I’m not in Germany anymore and can’t test it myself. Is anyone else here with E-Plus as a provider?

There is a very detailed guide by @fp1_wo_sw_updates

1 Like